1. nicallen63's Avatar
    I have installed OpenSSH and BSD subsystems, and made sure SSH is on in BossPrefs, but still I can not SSH into my iphone to save my life. Everytime i try to use Terminal it says "connection timed out" and every time i use Transmit it says "could not connect to server" "permission denied".

    In terminal i put in - "ssh [email protected]"

    In Transmit i put in -
    Server - "192.168.1.105"
    Username - "root"
    Password - "alpine" ive tried dottie too
    Port - "22"
    Protocol - "SFTP"

    Any help would be much appreciated, thanks.
    2008-08-05 04:30 AM
  2. bluemax189's Avatar
    are you using winscp? gotta set protocol to SCP. It works for me, just cant seem to change permissions with a 3g running 2.0 software.
    2008-08-05 03:20 PM
  3. dirtybird1977's Avatar
    Are you using a Mac or PC? If on a Mac you need to download CyberDuck on a PC download WinSCP. Google those names and you'll find the downloads.
    Dirty as I wanna be!
    2008-08-05 03:43 PM
  4. Eurisko's Avatar
    He's using Transmit, which is a Mac program.

    If this is the first time you're logging into the iPhone through SSH, you need to do it in the terminal. This allows the pairing information to be generated. Go into Terminal and type: ssh [email protected] and it'll pause for about 30 seconds then tell you it wants to generate a key.

    After that, you'll be good to go with Transmit.
    Get "iPod & iTunes for Dummies", it'll change your life.
    2008-08-05 03:59 PM
  5. Numberzz's Avatar
    Besides Transmit, I have found that a program called Fugu is also great with SSH. If you continue having problems with Transmit after you did what was described in the previous post, try Fugu.
    "Now everyone calm the hell down and let me think about how to clean up your mess, while you build me a monument dedicated to how awesome I am."

    MacBook Pro + iPhone 3GS
    2008-08-05 05:40 PM
  6. samuraikc's Avatar
    Im having a similar problem. I've tried terminal, Fugu, and cyberduck (im using OSX if yo u haven't guessed) and all give me the "connection refused" error immediately after i hit connect. I'm using all the exact steps that has already been listed. any idea what might be causing the error?
    2008-08-10 09:35 AM
  7. BlackWolf's Avatar
    if you getting "connection refused" than you probably don't have SSH installed or it is not set to on.
    2008-08-10 01:08 PM
LINK TO POST COPIED TO CLIPBOARD