1. wolvorine4424's Avatar
    I installed NES on iPhone 2G and i have a question conserning the links to NES ROMs.

    When I open up iFunBox:

    in folder view i see NES ROMS and when i add some to it they get copied to:


    but i want that to point to: (because this is where the NES app looks for roms at)


    How can I change that link so it points to the correct dir?

    In iFunBox i copied the whole filesystem to see if i can find the link and change it, but so far i have not found anything.

    I do not want to manualy go into the dir up add files, its anoying. But if i can correct that link to make it copy to the corrrect dir would be great.

    I just attempted to change the NES file so it would look for the ROMs in the other dir and chmod to 755 (the game never started, so i reinstalled)
    Back to playing with the DIR links.

    Just a thought:
    Can iFunBox see that the game is installed and it already has the link programmed in. wich makes me look for it in the phone itself a waist of time.
    Last edited by wolvorine4424; 2008-08-21 at 09:24 PM. Reason: Updated
    2008-08-21 08:30 PM
  2. BlackWolf's Avatar
    what is annoying about copying it in manually? should be the same afford as anything else.

    anyways, you can create symlinks with the "ln" (link) command. use it like this:
    ln -s target source
    so that would be
    ln -s /private/var/mobile/Media/ROMs /private/var/root/Media/ROMs
    which would make /root/Media/ROMs link to /mobile/Media/ROMs

    2008-08-21 09:23 PM
  3. wolvorine4424's Avatar

    ln: accessing '/private/var/root/Media/ROMs': Permission denied

    sudo ln -s /private/var/mobile/Media/ROMs /private/var/root/Media/ROMs
    This did not work. I think it copies it directly to NES. will try to add NES at the end and see.

    sudo ln -s /private/var/mobile/Media/ROMs/NES /private/var/root/Media/ROMs/NES
    Did not work eather

    Thank you. I forgot about the link commands.

    Do the DIR in root folder sepose to exist (because I have them in both mobile and in root)
    NES still tells me that there are no ROMs.

    I did the ln command and then rebooted the phone, after that i tried copying the ROMS and they still go to the root folder not the mobile folder.

    Is the ROOT password blank?

    because a assumed it is because when i just hit return when it asked me for the password it did not error out.
    Last edited by wolvorine4424; 2008-08-21 at 10:06 PM.
    2008-08-21 09:46 PM
  4. BlackWolf's Avatar
    the password for root is "alpine", just as it is for mobile.
    and when you executed ln there is no root folder anymore, if you move into the root folder you get redirected to the mobile folder, that's why there are ROMs in the root folder.

    remember to delete the root folder before you execute the ln command, otherwise you will get a "file already exists" error.

    oh, and if it still doesn't work, please tell me the error message it gives you. because "doesn't work" is really hard to analyse

    2008-08-21 10:12 PM
  5. wolvorine4424's Avatar
    There is no root folder???

    I have it and I have files in it.

    Um, I'm confused. If there is not sepose to be a root folder, then all the files in /private/var/root should be in /private/var/mobile

    Or am i wrong again.

    I do not get any errors, it just goes back to the prompt.

    OK, I just screwed something up. again.

    with icommander: when i try to enter the mobile dir it crashes. or try to select the @User dir crashes again

    Back to reflashing. man, I can do this in my sleep now.

    Ok, a little more simpler. I hope.
    Is there a way to LINK 2 DIR's for example.

    when NES tries to look for ROMs in the /private/var/mobile/Media/ROMs/NES dir, i want it to see the /private/var/root/Media/ROMs/NES dir. and list the ROMs that are in it.

    But only the /ROMs/NES dir nothing else. Is this possible?
    Last edited by wolvorine4424; 2008-08-21 at 10:55 PM.
    2008-08-21 10:39 PM