1. 96hondaex's Avatar
    Now we just need a fix for the resolution of the pictures...
    2009-06-28 07:16 PM
  2. illyb2000's Avatar
    "I am getting that o2 message too I think its due to the network detecting its an iphone 2g. Maybe the answer could be to put the sim in another phone send MMS to 1010 get the confirmation then put your sim back into iphone and see if it works. "


    when i do that it says "sorry, this is only available to iphone customers"
    Last edited by illyb2000; 2009-06-28 at 07:19 PM.
    2009-06-28 07:16 PM
  3. Lecram25's Avatar
    I just changed my APN to wap.voicestream.com, it's interesting to see that T-Mobile seems to have opened all ports via that APN (before they blocked the hell out of everything, hence the reason for the proxy hack).

    Anyway, I sent an MMS to myself and it sent fine (without the 5 minute lag some are reporting) and promptly received it (of course, the image was scaled down).

    Working Steps (T-Mobile USA):

    1) Install the hack via Cydia (Reboot)
    2) Settings -> General -> Network -> Cellular Data Network and tap Reset Settings
    3) Reboot
    4) Settings -> General -> Network -> Cellular Data Network and input wap.voicestream.com for both APNs and use these settings:

    MMS APN: wap.voicestream.com
    Username: [Leave blank]
    Password: [Leave blank]
    MMSC: 216.155.174.84/servlets/mms
    Proxy: 216.155.165.050:8080
    MMS Max Message Size: 307200 (300kb limit)
    MMS UA Prof URL: wap.sonyericsson.com/UAprof/W800iR101.xml (meant to fix the small image size issue but doesn't seem to be working)

    5) Reboot
    6) Settings -> Messages and check that MMS Messaging is on.

    You should now be able to send picture messages. No need for the carrier update.

    Here is another T-Mobile USA MMS setting:

    [MMS] APN: wap.voicestream.com
    Username: [Leave blank]
    Password: [Leave blank]
    MMSC: mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy: 216.155.165.50:8080

    Side note: Does anyone know if this guy has PayPal? I am definitely donating!

    EDIT: List of more profiles: http://delicon.sourceforge.net/profiles.html
    Last edited by Lecram25; 2009-06-28 at 10:21 PM.
    2009-06-28 07:16 PM
  4. tekwiz's Avatar
    I am getting that o2 message too I think its due to the network detecting its an iphone 2g. Maybe the answer could be to put the sim in another phone send MMS to 1010 get the confirmation then put your sim back into iphone and see if it works.

    Everytime I send a mms it crashes to safe mode and then sends anyone else getting this?
    I was the only one here having that issue as far as I know. It would crash but the message would send. It would receive fine though. I ended up restoring and patching from there and that fixed it.
    2009-06-28 07:29 PM
  5. commandoscorch's Avatar
    So does anyone have this working on At&t? If so can they please post how they did it. Thanks!
    2009-06-28 07:49 PM
  6. hondakorn's Avatar
    So does anyone have this working on At&t? If so can they please post how they did it. Thanks!
    i did....all i did was install the cydia hack. Keep in mind my imei was changed prior to the installing the hack and i have a medianet bundle......not an iphone plan
    Same username on: hondatech, 7thgenhonda, clubrsx, orlandoforums, civicforums
    2009-06-28 07:56 PM
  7. commandoscorch's Avatar
    i did....all i did was install the cydia hack. Keep in mind my imei was changed prior to the installing the hack and i have a medianet bundle......not an iphone plan
    I guess your changed imei must have something to do with it. I am considering doing this to mine and seeing if it will work. I also have a standard messaging plan and not the iphone one and when I put my sim in another phone, I can send MMS messages. Just out of curiosity, what are the settings that you used?
    2009-06-28 08:03 PM
  8. hondakorn's Avatar
    I guess your changed imei must have something to do with it. I am considering doing this to mine and seeing if it will work. I also have a standard messaging plan and not the iphone one and when I put my sim in another phone, I can send MMS messages. Just out of curiosity, what are the settings that you used?
    i just used the same settings that i used in swirly. mmsc.cingular.com and the proxy
    Same username on: hondatech, 7thgenhonda, clubrsx, orlandoforums, civicforums
    2009-06-28 08:19 PM
  9. Dimit's Avatar
    It worked for me and I am on T-Mobile in Chicago, but even thogh the MMS works, the internet no longer works, I get a message telling me to upgrade my internet plan, is there anyway around it??
    2009-06-28 08:23 PM
  10. iRos's Avatar
    Hmm, I don't have a subject field
    2009-06-28 08:24 PM
  11. tekwiz's Avatar
    It worked for me and I am on T-Mobile in Chicago, but even thogh the MMS works, the internet no longer works, I get a message telling me to upgrade my internet plan, is there anyway around it??
    what data plan do you have? Were you using Internet2.voicestream.com?
    2009-06-28 08:26 PM
  12. Dimit's Avatar
    Yes I was using internet2.voicestream.com, But now with my apn Wap.voicestream.com, my internet gives me a message telling me to upgrade. Is there a fix for this.
    2009-06-28 08:34 PM
  13. phreakwenci's Avatar
    Whoa whoa whoa.... What hack from cydia? The ispazio one? Tell me! This is soo awesome!
    2009-06-28 08:35 PM
  14. commandoscorch's Avatar
    Did anyone who HAS NOT changed their imei get this to work with At&t? It looks to me like at&t is blocking the mms feature except for those that have changed their imei to a different number.
    2009-06-28 08:39 PM
  15. Hitone's Avatar
    As I said in a previous post I have got everything apparently set up correctly but cannot get the APN settings to all stick.

    I am on Orange UK which includes MMS all be it at 30p a post...

    I can now receive MMS no problem and the resolution is fine.

    Suggestion have been made that the Cellular data APN must match the MMS APN in order to make the settings stick - in the case of Orange the Cellular APN is 'orangeinternet' and the MMS APN settings is given as:
    APN: orangemms
    Username: Orange
    Password: Multimedia
    MMSC: http://mms.orange.co.uk
    MMS Proxy: 192.168.224.10:8080
    MMS Max Message Size: <blank>
    MMS UA Prof URL: <blank>

    So they obviously cannot match

    Any suggestions please
    Last edited by Hitone; 2009-06-28 at 08:53 PM.
    2009-06-28 08:40 PM
  16. h.abdulhamid86's Avatar
    hey, so what happens when you receive a video message? anyone?
    2009-06-28 08:40 PM
  17. Gutman's Avatar
    Whoa whoa whoa.... What hack from cydia? The ispazio one? Tell me! This is soo awesome!
    Yes, I believe so.


    My only issue is that it says it is 671.5 MB

    Is this accurate?
    Attached Thumbnails MMS on iPhone 2g with OS 3.0-photo.jpg  
    2009-06-28 08:40 PM
  18. gengstapo's Avatar
    It was a charm, finally I got MMS on my iPhone 2G
    This was great finder, really awesome..

    I would like to thanks to the community especially to geniusan for making this dream come true. You guys are great, hats off

    Keep the good job for the community of iPhone 2G
    2009-06-28 08:43 PM
  19. oh!scars's Avatar
    works for me on att.....but i have my imei changed.Also still sez message failed but pic still sends
    i got a question for ya. since your imei is different are you pictures blurry like ours?? and if there not how can i change my imei setting. i think maybe thats the problem with tmobile since were using an iphone on their network.
    2009-06-28 08:45 PM
  20. tekwiz's Avatar
    Yes, I believe so.


    My only issue is that it says it is 671.5 MB

    Is this accurate?
    that is not accurate.

    To those with settings that won't stick, have you tried "reset settings"
    2009-06-28 08:50 PM
983 ... 6141516171826 ...
LINK TO POST COPIED TO CLIPBOARD