User Tag List

  1. rikwen-5's Avatar
    Windows 7
    iPhone 3GS

    It starts writing on my laptop but the phone reboots when ~767mb is written, i got three equal big *.img, same problem each time.
    What could be wrong? I have set bs=1M, could that affect it? dont now what to try with...

    2010-05-10 08:29 PM
  2. Free Lancer's Avatar
    Trying to recover data off my Iphone 3GS to MAC VM and I tried using this guide, however, I um unable to run DD as I cannot get the filesystem to unmount or mount as read only and I keep getting 'Resourse Busy' error. Please see my logs here:

    localhost:~ root# df -kh
    Filesystem Size Used Avail Use% Mounted on
    /dev/disk0s1 750M 497M 246M 67% /
    devfs 28K 28K 0 100% /dev
    /dev/disk0s2s1 15G 142M 15G 1% /private/var

    localhost:~ root# dd if=/dev/disk0s2s1 bs=4096 | ssh [email protected] 'dd of=iphone_reclaim.img'
    dd: opening `/dev/disk0s2s1': Resource busy

    0+0 records in
    0+0 records out
    0 bytes transferred in 0.000035 secs (0 bytes/sec)

    localhost:~ root# dd if=/dev/disk0s2s1 bs=1M | ssh [email protected] 'dd of=iphone_reclaim.img'
    dd: opening `/dev/disk0s2s1': Resource busy

    localhost:~ root# mount -o ro /private/var
    mount_hfs: Resource busy

    localhost:~ root# mount -o ro force /private/var
    force on /private/var: Operation not supported by device
    localhost:~ root#

    I downloaded umount from somewhere and scp'd it to Iphone:

    MacAdmin$ scp ~/Desktop/Iphone\ FW/umount [email protected]:/sbin/
    [email protected]'s password:
    umount 100% 15KB 14.6KB/s 00:00

    localhost:~ root# umount -f /private/var
    localhost:~ root# mount -o ro /private/var
    mount_hfs: Resource busy

    Might go bald pulling my hair......any help? How is the rest of world doing this?
    2010-06-03 06:08 PM
  3. pmemac's Avatar
    Sorry - wrong post
    2010-08-31 02:56 PM
  4. digitalchemist's Avatar
    I'm not sure why people claim the bs=1M option will fix your problem -- that has nothing to do with what you're experiencing.

    The device is /dev/rdisk0, not /dev/disk0.
    2010-09-07 06:33 AM
  5. redpenguin's Avatar
    Any idea how to do this on Linux?

    So far my img is being created just fine.

    I don't have access to a Mac, but I have Ubuntu Linux access.
    2010-10-17 12:38 PM
  6. jasonchb's Avatar
    dd if=/dev/disk0 | ssh [email protected]’sIPaddress ‘dd of=iphone-dump.img’

    dear all, hope you can assist me in entering above disk dump command on my pc running on windows 7 using software named putty
    2010-11-12 06:31 AM
  7. saintx7's Avatar
    i'm using iphone 4 os 4.1
    i already tried anything
    for transfering img file to

    dd if=/dev/rdisk0s2 bs=4096 | ssh [email protected] 'dd of=iphone_rdisk0s2_4096.img'


    dd if=/dev/rdisk0s2 bs=4096KB | ssh [email protected] 'dd of=iphone_rdisk0s2_4096KB.img'


    dd if=/dev/rdisk0s2s1 bs=4096KB | ssh [email protected] 'dd of=iphone_rdisk0s2s1_4096KB.img'


    dd if=/dev/disk0 | ssh <username>@<computer-ip> 'dd of=iphone-dump.img'

    but when i input the password
    always got "setgid : invalid argument"

    anyone can help me please???
    2010-12-12 05:00 PM
  8. Bunniesandsheep's Avatar
    You know, this could all be a lot easier if someone got tct running on the iphone...
    My Devart:
    Ipod touch 2g, 8gb, 3.0, with qTweeter, multifl0w, SBSettings, virtual RAM, Backgrounder and all the other useful jailbreak apps.
    If you need photoshop help, pm me =]
    2010-12-12 10:55 PM
  9. erutan's Avatar
    @atomic hooligan
    First of all I'd like to point out that you rock! you're the man! your tutorial is the most professional tutorial on the web.
    So, thank you very much!

    'setgid : invalid argument' error means that you haven't configured your mkgroup on the ssh server side (unix? mac? win?). If the groups haven't been created on the server side, the client connection will fail after authenticating successfully, with the error message: setgid: Invalid argument.
    Cygwin(Windows)/Unix ssh server - Run the command mkgroup -l > /etc/group
    Then it should work.

    There are some topics found on the web, but I believe that in order to save time, just do it the other way around... from MobileTerminal on the iPhone ssh into your computer.

    For All Windows Users
    The following method worked for me like a charm!
    I have a 3G iPhone with 3.1.3 installed, and I wanted to retrieve files from before I updated the iPhone.

    I installed cygwin with openssh and ddrecover packages on my Windows XP:
    - Download and install setup.exe from Cygwin Installation
    - Select the openssh and ddrecover packages in the installation (you can use the search box to find them).
    - Run cygwin and enter the following commands:
    mkgroup -l > /etc/mkgroup
    mkpasswd -l > /etc/passwd
    ssh-host-config -y
    net start sshd
    - Keep cygwin open.
    - After performing the steps to jailbreak the iPhone and install openssh and MobileTerminal enter the following command on the iPhone as root (use 'su' command to login as root):
    dd if=/dev/disk0 | ssh <yourXPusername>@<yourXPIPaddress> 'dd of=iPhone-dump.img'
    - You will not see any progress bar, but you can check the file size on the PC as it grows. It took me 9 hours to transfer my 16GB image file.
    - The file will be located in cygwin's installation folder under home/<yourXPusername>/
    - Mount the file with:
    1. OSFmount - Free
    2. MountImage - Trial
    - Use PhotoRec or other software to recover files from the mounted image.
    - For PhotoRec - choose Apple partition map as the partition table format. You can also choose the file types to search.

    Good Luck! :-)
    Last edited by erutan; 2011-01-23 at 12:40 PM. Reason: additions/clarifications
    2011-01-22 02:15 PM
  10. anjszulc's Avatar
    Hi All !

    Thx for this post
    it's great tutorial !

    I make a myiphone.img but...

    I open this on my windows by the OSFmount 1.4.1
    and a can't open this two disk

    primary partition 1 - 62,5 MB
    primary partition 2 - 905 MB

    where are a contacts? on which disk ? where i can find it ?

    How I can copy this contacts on my iPhone ?

    some on do this like me ?

    please let me know )


    edit: i have a iPhone 2G 3.1.3
    2011-02-12 11:13 AM
  11. ShiBBan's Avatar
    I'm on a iPhone 4 with fw 4.01. I have done a dump from my iPhone but I don't know what to do next. I have tried to mount the img (dump from my iPhone) with Disk Utility from my Macbook but no luck. I only get the message

    What can I do next? I really need to get some files back (most pictures and videos) from my iPhone!
    2011-03-14 04:37 PM
  12. thomasscharrer's Avatar
    I am a licensed private investigator and I can recover deleted text messages, call logs, photos, video and other deleted information off of an iphone. You can either send the phone to my lab or you can purchase a kit that allows you to do it at home. For a free consultation ask for Tom 8 6 6 6 4 0 1 0 1 0.
    2011-07-10 03:04 PM
  13. ctiffanie0708's Avatar
    Hi,since this has been said that this method would not work for Iphone 3G.....Would there be a possibility that this would work for Iphone 4?? Please help coz I lost all my photos when i first time sync my iphone into my PC. so i desperately needa get the photo back please could someone help me? xxxx
    2011-08-11 09:45 PM
  14. Gauthier029's Avatar
    Hi everyone
    Any news for iphone4?
    I need help for my photo and video
    2011-09-04 01:30 PM
  15. Mizja's Avatar
    Hi your explaination for doing this with a PC is great, I had jailbroken my iphone 4 and everytime I try to run Cydia(or Safari) it opens quick and closes? Also when I installed on my PC (Windowas 7)cygwin and installed openssh and ddrecover, then try and run the commands it keeps telling me to go to the help, so I enter the code for the help menu and also has errors?

    Please help.


    Last edited by Mizja; 2011-11-01 at 05:10 AM. Reason: forgot to say i installed openssh and ddrecover on my pc
    2011-11-01 05:08 AM
  16. ipodtouchheko's Avatar
    Ok i read this but i'm still not sure. So i voice recorded this one funny thing my friends and I did. Well it was 16 minutes long. I wanted to trim it so i did like right where the funny part was. And like before i did the trim before so I knew it will divide them into 2 different voice memos but instead it got rid of the part that i wanted. SO i was soooo upset.

    DO you know how i could get the other part of the memo back?? (the voice memo that i want not the one i don't want)
    Please help... Thanks!
    2012-01-08 10:33 PM
  17. ryanryan2120's Avatar
    so after i write the "dd iif=/dev/disk0|ssh ((username)@ipaddress) dd of=iphone-dump.img" i put in my password then says " 0 bytes transferred in 0.020694 secs (0 bytes/sec)" i can see the "iPhone-dump.img" file on my computer but it too says zero bytes. why is this doing that?
    2012-06-16 11:32 AM
  18. Graffixed's Avatar
    Hi, I know I am late but it happened to me a year ago and I have been searching for a long time. I believe your guide is very helpful, with the outstanding replies from other users. I on the other hand am not able to have a chance at trying to resolve my issue in relation to this thread and similar to everyone's problem. As I am reading all the of replies and comments, I am happy that everyone is involved and helpful.

    *Cutting to the Chase*

    I have an iPhone 3GS OS 4.0.1 and a Windows 7 computer. I completely do not understand how to utilize this guide in my favor as it is too complex from my understanding. I have Terminal on my iPhone 3GS and I tried installing OpenSSH through Cydia and it will not let me as I am getting the following message, "Wasn't able to locate file for the com.dba-tech.common package. This might mean you need to manually fix this package." I really don't understand what that means. It will not even let me remove and reinstall. As for my computer I installed Cygwin but I do not understand how to use it. I do indeed have important information on my iPhone that some files, photos, and voice recordings were accidentally deleted and not backed up that I am trying to retrieve.

    I know I am a newb but I do really need help with this and understanding it and explained to me in Layman's Term. If someone or anyone can give me detailed step by step instructions, that would be wondrous. Thank you in advance.
    Last edited by Bo Troxell; 2012-12-02 at 07:56 PM.
    2012-11-19 10:07 AM
  19. Jackie1's Avatar
    Help, I used wondershare dr phone to try to recover deleted files and it gets to 99% and didn't want to finish. I'm on a jailbroken iphone 5 on 6.1.2 and accidentally deleted 20 photos/vids yesterday and they aren't in my backup.

    I tried EaseUS MobiSaver 3.1 and it finished but doesn't show any deleted pictures. I shows all the photos from the last 3 months, but when you click "show deleted" it doesn't have any.

    What's I'm wondering is, if I try the photorec, would this work better? or if EaseUS doesn't see them, nothing will?
    2013-11-11 04:48 AM
  20. brentw's Avatar
    I know this is a older post but does anyone know how to do this through USB? I can do it with cygwin on a android phone and I can connect to the phone usb with putty so why cant I pull this phone image through the USB port instead of it taking hours to pull over wifi? There has to be a way. Anyone?
    2013-11-19 05:06 PM
64 1234