1. niuri_cigarete's Avatar
    I have an iPhone 2g and I've installed 3.0 OS about a month ago. It's jailbroken and activated. The thing is, i've noticed just now that there's no Safari icon and I can't access the internet. I've checked the Applications folder and it's there. What should I do to fix this? Any ideas? I'm not an expert at all this jailbreaking stuff so please explain everything in a simple way. Thanks.
    2009-10-09 09:22 AM
  2. nsachar's Avatar
    Do you have sbsettings? if yes, go to more > hide applications then see if safari is there and if it is then click the thing to OFF.
    2009-10-09 10:31 AM
  3. niuri_cigarete's Avatar
    sorry, but i acctually dont even know what that is
    2009-10-09 09:37 PM
  4. nighthawk283's Avatar
    Tell us what packages u have install or restore
    2009-10-09 09:46 PM
  5. Raptors's Avatar
    That's happened to me before, when I jailbroke my iPhone " stocks and contacts" were missing,

    I just rejailbroke
    2009-10-09 09:59 PM
  6. nsachar's Avatar
    Go into Cydia. on the home page look at Featured Packages. from there find SBSettings and install it.

    Once done it will tell you do reboot or w/e. Then drag your finger across the status bar a little bit until you see the drop down screen. from there follow my previous instructions.

    if you don't have safari as hidden then you're just gonna have to rejailbreak bro.
    2009-10-10 02:17 AM
  7. niuri_cigarete's Avatar
    I've just tried this, but it appears there's another problem. I can't connect to wi-fi. It doesn't find any networks or it's some strange sgmd connection that doesn't even exist (I know that because I used my laptop for searching for wi-fi networks). Is it possible that 3.0 OS is causing this? I didnt have any problems with 2.0 firmware
    2009-10-12 05:15 PM
  8. iRockish's Avatar
    Did u poof it or install some package that hid it? How did you get to 3.0?
    2009-10-12 10:01 PM
  9. SL4VE's Avatar
    re-jailbreak
    2009-10-13 01:57 AM
  10. Metroplex's Avatar
    yeah, dude, just rejailbreak easiest thing to do from this point.
    2009-10-13 02:02 AM
  11. flounderasu's Avatar
    I have an iPhone 2g and I've installed 3.0 OS about a month ago. It's jailbroken and activated. The thing is, i've noticed just now that there's no Safari icon and I can't access the internet. I've checked the Applications folder and it's there. What should I do to fix this? Any ideas? I'm not an expert at all this jailbreaking stuff so please explain everything in a simple way. Thanks.

    Re-jailbreak. It's going to be the easiest way, at this point. Just remember to sync first, so u don't lose any contacts, calendars, etc.
    2009-10-13 06:50 AM
  12. niuri_cigarete's Avatar
    well, you see it was bought while it was still available to buy without the contract. It was then sent to me and I had to jailbreak and activate it because I use not supported service.
    2009-10-13 03:02 PM
LINK TO POST COPIED TO CLIPBOARD