1. m021478's Avatar
    I am trying to apply a new theme via Winterboard (that contains the appropriate mask .pngs to apply the theme even for apps that do not contain a themed icon) but for some reason I cannot get certain icons on my springboard to adopt the newly applied theme style.

    In the past, I've been able to get around this issue by browsing to /var/mobile/Library/Caches/ and deleting the "SpringBoardIconCache" & "SpringBoardIconCache-small" folders, the respringing or rebooting. I've searched these forums for a solution to my problem and I also found someone that was able to resolve their similar issue by deleting the /private/var/mobile/Library/Caches/com.apple.springboard-imagecache-icons.plist file, and then rebooting... but that specific .plist file didn't exist in my cache folder???

    You can see which specific icons refuse to have the theme applied to them from the screenshots below... (just for reference, the icons that appear as circular bubbles are the icons that did have the theme applied properly - such as the entire first row of apps in the first screenshot below... Weather, Maps, Photos, Camera).

    As far as which icons didn't have the theme applied to them... most of them are official app's purchased from the iTunes App Store, though the 'Reader' icon on the first screenshot is a webclip, and on the forth screenshot below, the "UnlimVideos" and "GV Mobile +" are both jailbreak apps.











    Any suggestions would be greatly appreciated... This issue is preventing me from using a number of themes that I'd really like to be able to use...

    Thanks!
    2010-01-22 02:17 PM
  2. Zwayne's Avatar
    Make sure that the apps name is correctly spelled.
    2010-01-22 03:00 PM
  3. diptwo's Avatar
    My messages icon never changes, but it did long time ago and now that prevents me from using any themes. I deleted the "SpringBoardIconCache" & "SpringBoardIconCache-small" folders and it didnt help. Also i looked for "com.apple.springboard-imagecache-icons.plist" file but id wasnt there. Any other ideas on how to resolve that problem? Thanks.
    2010-01-22 05:42 PM
  4. dysphoriQ's Avatar
    As stated before, make sure the app names are spelt and in the same case, shown on your iphone. Also on some OS, Windows XP for example, wont let you rename the icon with some characters, like "-". To get around this, SSH into your iphone and rename the icon through there.
    2010-01-23 09:54 AM
  5. m021478's Avatar
    Regarless of how an App's name is spelled, if the theme has a "UIImages" folder inside of it, and within that folder exist the appropriate mask icons (AppIconMask.png, AppIconOverlay.png, AppIconShadow.png), then the style of the theme is supposed to be applied to any icon on my springboard, regardless of whether or not the theme has a custom made icon named.

    I know this is how it has always worked for me using my Tenuis theme, and I have heard this subject discussed enough to know this is how it is supposed to work, but for some reason I still can't get certain App icons to adopt the theme's style??

    Any suggestions?
    2010-01-24 10:37 AM
  6. Saqqarahdev's Avatar
    I find myself in the same spot than you since yesterday. did u fix ur prob?
    2010-04-19 12:28 PM
  7. Bo Troxell's Avatar
    If you are 100% certain they are spaced, spelled and caps are correct, try running iwipecache from cydia, it will clear any auto create ui images.

    Couple ways to check proper naming of an icon.
    1. For Cydia app, Install Cydelete and you will be able to press the X and view the name.
    2. You can go to categories, then go to a category, then press add. now find the app you need the name of. that is the correct capitalization/spelling of the app
    3. swipe SBSettings, then press more. go to Hide Icons, and find the app. that is the correct capitalization/spelling of the app.
    4. Install Rename (I or II) and open it. find your app and its correct capitalization/spelling will be under the O-N (original name).
    5. press icon and make it wiggle, press delete, a window will pop up for you to verify deletion and shows the way it is spelled, spaced and caps.
    Last edited by Bo Troxell; 2010-04-19 at 07:55 PM. Reason: Automerged Doublepost
    2010-04-19 07:55 PM
  8. cswarthrob's Avatar
    similar problem here...i can theme certain icons or dock
    2010-04-26 07:12 AM
  9. Raaj FX was banned's Avatar
    Download iWipeCache.
    2010-04-27 04:28 PM
  10. cswarthrob's Avatar
    already have it ^
    2010-04-27 04:35 PM
  11. joeblstrn's Avatar
    I have the same issue. Cleaned out the cache manually and download the tool from cydia and still nothing. Also conformed the imaged is named correctly.
    2010-05-04 07:42 PM
  12. Musicalchairs's Avatar
    Just PayPal'd iKoN from DeviantArt for iLLuMinE theme..

    SSH'd

    Made sure all icons were named correctly..

    all icons change except stock iphone apps.

    SAFARI
    CLOCK
    CALENDAR
    NOTES
    YOUTUBE
    CAMERA
    PHOTOS
    APP STORE
    IPOD
    CONTACTS
    SETTINGS
    CALCULATOR
    WINTERBOARD (only CYDIA app that doesnt change)
    ITUNES
    COMPASS
    VOICE MEMOS
    STOCKS
    WEATHER
    MAPS

    Frustrating..
    2010-05-07 03:10 AM
  13. 6PNT1's Avatar
    so after having the same problem, i looked and looked....and the answer simple! under winterboard, theres an option that says summerboard, flip that sucker to ON, that should do it...it worked for me, hope this solves the issue. Good luck!
    2010-05-13 07:57 AM
  14. sam0212's Avatar
    Summerboard is on. Works for all icons except calender, clock, voice memos, stocks and settings !!
    2010-09-22 08:44 PM
  15. rsx202002's Avatar
    I downloaded Elite Pro HD for my Iphone 4 using 4.3.2 firmware. When I apply and respring only the lock screen changes but the icons remain the same. Can anyway please help me find out why the icons do not change?
    2011-04-27 03:42 PM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.