1. SnowLeo's Avatar
    here goes:
    I installed the icococlasm 1.3 deb on my iphone 3gs (pwnage tooled) and forgot that I had sbrotator still installed and when i resprang it immediately sent me to the apple logo endlessly cycling forever. I tried everything I could find to fix and thought I might just wait a day or so. So today I fianlly decide that I'm gonna try to use iphone pc suite feature to get you out of reboot mode by like basically disabling all jailbreak stuff and mobile substrates... but when I went to plug my iphone into my computer my computer wouldnt recognize my iphone, not even in itunes. I tried using the same usb cord in the same usb slot with an ipod touch 1st gen and it shows up fine. I tried using 2 other computers and on neither did my iphone show up. This is a very severe issue as my iphone is my only phone and way of contacting anyone and now I cannot even restore because my iphone doesnt show up on my computer. I currently have ssh connectivity but I dont know how long itll last as Ive had it on and off throughout the 5 hours I spent trying to fix this. I tried dfu mode in every method but that still didnt make it show up in itunes... I tried letting it run out of battery.
    Another thing I might note is that sbrotator and iconoclasm did not show up in my mobile substrates so I tried reinstalling them and then deleting the files and still had no luck. Last night my iphone also got really hot and I really hope the overheating didnt permanently damage the device.
    Any advice or suggestions at all would be greatly appreciated. Thank you.
    2010-05-11 04:16 AM
  2. johnnylovescookies's Avatar
    Unplug,
    and turn off the iphone completely by holding the home and power buttons for 10 seconds aprox.

    Then open the clock on your computer in the bottom right.

    Plug in your iphone or ipod as you press down the home and power buttons.
    Do all three simotaneously.

    Then wait EXACTLY 10 seconds, and after that, let go of the power button but continue holding the home button for 30-45 seconds.

    Your computer will flip out with the usb device attached noises.
    You should hear 3 tones

    Then shift-click restore and browse a firmware you want
    2010-05-11 04:20 AM
  3. SnowLeo's Avatar
    What does opening the clock do? I have a mac so there is no clock in the bottom right. I tried dfu mode in all forms and plugging it in at all points through the process but nothing helped. My iphone just simply isnt being recognized by my computer no matter what I do. I really appreciate your help and how this thread is one of your 2 posts here. So welcome to MMi
    2010-05-11 05:00 AM
  4. Puka1701's Avatar
    Try continuously hold down the power and home buttons until a connect to iTunes message appears. Maybe you have hardware problems though...
    2010-05-11 05:04 AM
  5. SnowLeo's Avatar
    no... Ive tried this forever and no message appears. Yet i plug in an ipod touch 1st gen into the same usb cord with the same usb port and the ipod is recognized perfectly. I also tried my iphone on 2 different computers both mac and pc with itunes and still had no luck. if only there were some other method to fix it through terminal or ssh
    2010-05-11 05:06 AM
  6. Puka1701's Avatar
    Sounds like hardware issues to me. If you use WiFi, there is a chance the iPhone will connect to it before rebooting. I'm not sure what good that will do you though.
    2010-05-11 05:12 AM
  7. SnowLeo's Avatar
    well I have ssh connectivity and can connect through wifi to my iphones file system.... yet I cannot connect in any form through usb. When you say hardware are you referring to my iphone? Because my iphone overheated quite a bit last night and the could have produced permanent damage to the device.
    2010-05-11 05:15 AM
  8. Puka1701's Avatar
    That's what I was referring to (the iPhone). Try looking at the filesystem content of the offending package[s] on your other iDevice through Cydia. Then replace the modified files from a fresh copy of the iPhoneOS (or delete them if they aren't there) via ssh. Note that you may need to install the packages to get the filesystem content entry in Cydia.
    2010-05-11 05:25 AM
  9. SnowLeo's Avatar
    Yeah I already tried that.... Im 99.999% sure it was because I just installed the iconoclasm 1.3 deb while I had sbrotator installed and I sshed into my iphone and the files were not in the /library/mobilesubstrate/dynamiclibraries like they shouldve been so I reinstalled them via terminal and then deleted them and had no luck.

    OK... either my dads a miracle worker or Im just a dumbas* but Ive been searching and trying and screwing around for 5 FULL HOURS today... and I reluctantly give it to my dad and within 5 minutes he has it restoring with itunes... WHAT THE F***
    lol.... problem solved but I wasted a huge chuck of my life that I may never get back
    Last edited by SnowLeo; 2010-05-11 at 05:49 AM. Reason: Automerged Doublepost
    2010-05-11 05:49 AM
  10. Puka1701's Avatar
    Shouldn't you be celebrating the fact that you have functional hardware? That's what I would be doing now...
    EDIT: You should ask your dad what he did to get it to work.
    Last edited by Puka1701; 2010-05-11 at 06:29 AM. Reason: Update
    2010-05-11 06:28 AM
  11. tsanborn2010's Avatar
    How'd he get it to work because mine is doing the same thing but I don't have SSH enabled
    2010-05-11 09:48 PM
LINK TO POST COPIED TO CLIPBOARD