1. ismoothproject's Avatar
    Ok. So I have pretty much everything setup for building, except for this one little bug.

    I will be posting it shortly.
    ModMyi Rocks!
    2011-04-04 04:52 PM
  2. KaMneed's Avatar
    Ok. So I have pretty much everything setup for building, except for this one little bug.

    I will be posting it shortly.
    Is there any news?
    2011-04-05 06:27 PM
  3. Fhsjaagshs's Avatar
    I think it converts video on their server.
    2011-04-05 07:41 PM
  4. ismoothproject's Avatar
    Sorry I took so long! I will be podting the error in about 5 min... My mac has to boot up.

    Ok. Here are the errors I am getting.

    Can someone please explain this? One of them is a file is missing. I have looked over the ENTIRE source code I downloaded and I cannot find any file!

    The others might be resolved once we have the other file.

    The iSmooth Project.

    Ok, nevermind! I just fixed all of the bugs above. Now this is what I am having trouble with.

    The iSmoothProject.

    Hello Everyone!

    Please ignore all of the bugs above, I just found the files and downloaded them and put them where they belong.

    So now, it is making it work for iOS 4.3.1!

    I was reading somewhere that system files in 4.1 don't exist anymore, so we need to find them and make a debian that installs them safely.

    Here is the link: https://github.com/comex/frash/issues#issue/28

    This is a very helpful link.

    Thanks for all of your continuing help!
    The iSmooth Project.
    Last edited by ismoothproject; 2011-04-06 at 04:00 PM. Reason: Automerged Doublepost
    ModMyi Rocks!
    2011-04-06 04:00 PM
  5. ads2006's Avatar
    Hello iSmooth Project,

    Good job.

    Have you already have the new frash file that support iOS 4.3.1 in iPad ?

    Best Regards,

    2011-04-06 06:24 PM
  6. ismoothproject's Avatar
    Sorry, but what do you mean by that?

    Do I have the latest source code? Is it working yet for 4.3.1?

    The iSmooth Project
    ModMyi Rocks!
    2011-04-06 06:41 PM
  7. ads2006's Avatar
    Sorry if I misunderstood but I am imagining you will be providing a new frash.deb file to be uploaded to the iPad to work with OS iOS 4.3.1. Is that right ?

    I have a iPad iOS 4.3.1 and I tested frash.deb versions 0.01 and 0.02 and it not worked.

    My understaning of this topic is to give ways to make Flash work with iOS 4.3.1 right in iPad, iPhone, etc..., right ? If positive should we expect a guide to do that ?

    2011-04-06 07:45 PM
  8. ismoothproject's Avatar
    Perfectly explained!

    Yes, I will be making a debian file and will be on modmyi repo. It will be as simple as: install in cydia, and it works!

    That is my goal! It will be called "Frash4iOS"

    The iSmooth Project.
    ModMyi Rocks!
    2011-04-06 07:48 PM
  9. ads2006's Avatar
    Please allow me my latest stupid question. I just signed into this forum so I'm not familiar with it. What you mean with "my modmyi repo" ? Is it some kind of download page inside the Web Site ? When do you expect to have the "Frash4iOS" available to users ?

    2011-04-06 07:56 PM
  10. ismoothproject's Avatar
    That's ok! I ask a lot of stupid questions myself! Lol

    This website, modmyi has a cydia repo (you know what repo is, right?) and I will publish "Frash4iOS" on it.

    For the second question. 2 weeks? That is what I am hoping for. It could be longer and when it is public, it will be a little buggy of course, but it should be soon!

    Ok, I cannot get on my mac because someone else is using it, but I am on my linux server so I will be able to do some things! (The Linux server is running my custom linux operating system. SO SWEET AND FAST! lol)

    Anyway, so this is what I am looking for.


    I am going to be jailbreaking an old iOS 4.0 firmware and unzip it to get these system files that frash needs. These are not in the latest firmware so I will get them, put them on my device, and see what happens! lol

    When we publish Frash4iOS, we will include these in the debian obviously.

    I will be posting updates with my current status of what I am doing so you guys can help, or follow!

    The iSmooth Project.

    UPDATE 1

    Almost done jailbreaking the iOS 4.0 firmware......

    UPDATE 2

    Oops! I downloaded the wrong firmware file!!!! LOL Will be done in about 15 minutes...

    UPDATE 3

    Sn0wbreeze is jailbreaking the firmware as I type...

    UPDATE 4

    I am unzipping the firmware and opening the DMG to get the system files...


    UPDATE 5

    Ok. NONE of what I listed above was in iOS 4.0!!!!!! Maybe 3.1.3!!!! Give me 30 more min! lol sry!

    UPDATE 6

    Building jailbroken 3.1.3 ipsw...

    UPDATE 7

    Unzipping and extracting files...

    UPDATE 8

    Ok. they are STILL missing. Something is fishy.... Give me a moment...

    UPDATE 9

    I have an idea... Hold on...

    UPDATE 10

    Ok. SOOOO I just looked and someone says it is in 3.1.2. Here we go all over again!!!!

    UPDATE 11

    If anyone can find these files on there device:


    Please zip them and post! Thanks!

    UPDATE 12

    Wish me luck! We will know in 5 minutes if the files exist in 3.1.2!!!!

    UPDATE 13

    Ok. IT WASNT in 3.1.2!!!! It must be in 3.1.2, or else, I dont know what to do!!!!

    Here we go ALL over again!!!!

    UPDATE 14

    Ok you guys will not belive this.

    While I was waiting for the iPad firmware to finish downloading, I went onto my eMac (OSX 10.4) and went to /usr/lib and guess what:

    /usr/lib/libmx.a.dylib (Pretty close!)

    Do you think it will work???? I am trying right now...

    UPDATE 15



    already existed.

    /usr/lib/libm.dylib is a shortcut to

    which did not exist.

    Confusing? I think so!


    Ok. So frash works, (It has been working, this is what I am trying to fix) but when I tap the Flash icon to start I get this:

    "Could not connect: Connection refused"

    Does anybody know what this is???? I am going to try rebuilding and installing Frash4iOS.

    Hello Everyone!

    Very BUSY day from what you just read above!

    I am going to be posting the partally working Frash4iOS debian file once I finish building the updates...

    So far we have acomplished:

    Frash4iOS knows if there is Flash on a webpage and puts the gray square with the text "Flash" on it. When you tap the square, it pauses for a second, and then says "Could not connect: Connection refused".

    If anyone has iOS 4.1 or lower I would love if they could install this debian, and see if it works on their os. iOS 4.2 or higher are more than welcome to install this and play around with it to see if they can get it working!

    Thanks for your continuing support!
    The iSmooth Project.

    UPDATE 16

    I might have fixed the connection problem! I will know shortly...

    UPDATE 17

    THE ERROR STOPPED!!!! Now lets see if it works!!!!

    UPDATE 18

    Ok. So now I just get a black screen. So some improvement!

    This is what I did.

    In the food.plist launch daemon there is this:


    which I looked in /sbin and it doesn't exist.

    I googled and basically it is the same as sshd.

    So I changed it to:


    and the error stopped!
    Last edited by ismoothproject; 2011-04-06 at 10:40 PM. Reason: Automerged Doublepost
    ModMyi Rocks!
    2011-04-06 10:40 PM
  11. ismoothproject's Avatar
    Sorry everyone!

    I forgot that I was attending a special event tonight and will not be able to build it to tomorrow.

    I am really am sorry about this! I will have it for all to download tomorrow!

    Thanks for your patience!
    The iSmooth Project.

    Ok so this is what I ran into now.

    iPod:~ root# /var/mobile/frash/food_wrapper
    Apr 6 20:26:54 iPod food_wrapper[165] <Error>: launch_msg(CheckIn): Operation not permitted
    iPod:~ root# /var/mobile/frash/food
    Assertion failed: (rpcname), function main, file food.c, line 331.

    If we fix this, I think it will work!

    After rebuilding, the could not connect error appeared again...

    Anyway, despite all of the errors, here is the debian file!



    It may work on older iOS's than 4.2, but you can still try on a new device!

    (Thanks to all of the people who have been private messaging me with your help!)

    Get ready to embrace what we will do tomorrow!
    The iSmooth Project.

    UPDATE: Here is our repo if you wish to install it through CydIa!

    Last edited by ismoothproject; 2011-04-07 at 02:52 AM. Reason: Automerged Doublepost
    ModMyi Rocks!
    2011-04-07 02:52 AM
  12. ads2006's Avatar
    Great Thanks.

    Will test it tonight (Brazil time) and will let you know about the results.

    2011-04-07 01:31 PM
  13. ismoothproject's Avatar
    Ok! THank you guys so much!

    I will be working on it more today. When you try it there is a 99.9999999% chance it is going to give you an error.

    I have been looking in the code and it looks like it is hosting a local server for something. In the "food.plist" LaunchDaemon, it has an inetd server. The file does not exist anymore and when I looked it up it is pretty much the same as sshd server.

    That is why we are getting the Connection Failed error. Other than that, everything should work! We have all of the dylibs that we need now, thanks to a lot of people that were private messaging me.

    The iSmooth Project.
    ModMyi Rocks!
    2011-04-07 02:09 PM
  14. Ste_Moore01's Avatar
    Will you be making an SBSettings toggle for this like the old frash had?
    2011-04-07 02:26 PM
  15. ismoothproject's Avatar
    Yes! I will probably mod the old one to work for the new one.

    Ok. So according to everyone, Frahs4iOS is still not working.

    That is ok! I was expecting it not to work. I was seeing if it worked on some devices, and not others.

    Our next thing we have to do is find inetd which is supposed to be in "/sbin". If everyone could check all of there iDevices for this file, that would be great!

    I on the other hand do not have it and will be googling and looking in my mac's "/sbin" since I found the System.b LIB on my mac and it worked.

    Now THIS, is facinating...

    Quote Wikipedia:


    As of version Mac OS X v10.4, Apple has merged the functionality of inetd into launchd.


    Attempting right now...

    OK! The above works!

    Modify /System/Library/LaunchDaemons/food.plist





    Now all I have is a black screen.

    Any ideas? (At least the bugs are gone! YAY!)

    UPDATE 1

    I will be working on Frash4iOS around 2:30PM (EST - USA). I know some people working on this project are not in my area! lol

    Hello Everyone!

    This version of Frash is still not working, but it does not have any errors! On my device i tap the Grey Flash square and it goes black like it is loading, but nothing happens.

    I don't know if this is my device, or it isn't. We are still programming of course to try to fix this!

    DEB File:



    (Some people have been reporting that the repo isn't working. It is hosted by some website and I have no control over it. It may be working now so try again!

    Thanks for all of your continuing support!
    The iSmooth Project.
    Last edited by ismoothproject; 2011-04-07 at 09:23 PM. Reason: Automerged Doublepost
    ModMyi Rocks!
    2011-04-07 09:23 PM
  16. ads2006's Avatar
    Hello iSmooth Project,

    Just applied your .deb file in my iPad 4.3.1 and got the message _abort() food.c:43 when trying to open a Flash page.

    2011-04-08 02:41 AM
  17. ismoothproject's Avatar
    Thanks for letting me know!

    Has anyone else gotten this error?

    Also, I am porting the iPhone version of Frash. I am guessing it is because it is compiled for iPhone.

    I don't have an iPad with me so I can't do that much about it. (I will do my best though! )

    Oh and thank you all for helping! Because you are all being wonderfully helpful, I am going to let you try my latest beta product! (Which does work! Lol I am using it right now!) it does crash sometimes, but not that often and you can always uninstall if you don't like it.

    It is called iSpeed. It makes your iDevice 3x Faster! Try it and be amazed!


    Tell me what you think and how well it worked for you!

    Thank you all for your support!
    The iSmooth Project.
    Last edited by ismoothproject; 2011-04-08 at 03:41 AM.
    ModMyi Rocks!
    2011-04-08 03:26 AM
  18. Zyxback's Avatar
    Hello there buddy.. I'm new here and this is my first post. I googled alot to find working frash for my iphone 4 with ios 4.3.1 but no luck. I installed ur frash via cydia and im getting black screen without any error i guess just like you, nothing happens. But anyway thanks alot for doing this i hope you will fix this soon...
    2011-04-08 12:20 PM
  19. eddietah's Avatar
    Don't use it it also cause lotsa problem to my iPhone before
    2011-04-08 12:37 PM
  20. ismoothproject's Avatar
    Yes we will be fixing the black screen soon! But you are right, no bugs appear when it tries to load!

    This is a very active project and we are coming very close to having Frash4iOS Finished!

    Oh, and eddietah, it shouldn't cause a lot of problems. If it does, tell me and I will fix it for you!

    Did you guys try my iSpeed thing yet? I private messaged a guy and he rated it 10/10 ! He says it is wonderful and really works as I said it does! He also says thanks so much is iPhone 3GS is now rocket fast!

    Thanks for all your help!
    ModMyi Rocks!
    2011-04-08 02:55 PM
542 123412 ...