1. JBirdMedic's Avatar
    I am seeking an existing mod or a creation by someone talented a mod that will stop the ios from making a pop-up to warn users that the iphone is in airplane mode.
    I only note this when using messages or really Bitesms, but I understand it also pops up to native weather and stocks apps as well.

    Note: I work offshore on an oil platform and have no cell service but have wifi. These pops up drive me insane using imessage during my 14 days offshore.

    Please and thank you in advance if anyone can tackle this.
    2012-07-18 11:05 PM
  2. hadzo's Avatar
    1) You can try "alertBlocker" in Cydia... its a paid app but it may do the trick. Or contact developer of the app to see if he would custom write you something.

    2) I'm a little curious with why do you feel the need to be in Airplane mode??? WiFi works just fine even with Airplane mode off. If you are worried for roaming data chargers or such just go to your setting app than general/network and turn off "Cellular Data". Now the phone will have no need to warn you of airplane mode.
    Hit the thanks button if I helped in any way
    2012-07-20 04:41 PM
  3. JBirdMedic's Avatar
    Thanks for the reply @hadzo.
    1. Not fond of buying an app just to see if it will work.
    2. Staying in airplane mode significally reduces the battery drain since the phone isnt constantly trying to find a tower.
    2012-07-20 08:34 PM
  4. DC_Dave's Avatar
    Popup blocker has a 14 day trial period, this is also 99c
    I didn't realise offshore oil rig work was so poorly paid :P
    Last edited by DC_Dave; 2012-07-21 at 05:17 PM.
    2012-07-21 05:12 PM
  5. JBirdMedic's Avatar
    Have Popup blocker and it does not block these popups.
    Smartass.
    2012-07-21 10:59 PM
  6. DC_Dave's Avatar
    Hi, so I guess you still have a sim in and you are not in airplane mode as you have wifi on and so it says no signal. But the airplane warning alert part of popup blocker still does not stop this message. Might be worth an email to the popup blocker author.
    2012-07-22 03:45 PM
  7. JBirdMedic's Avatar
    @DC_Dave...Yes SIM is in, we are in airplane mode, then turn wifi back on after going into airplane mode.
    Will pursue an email to popup blocker to see if he is interested in adding that option.
    2012-07-22 03:57 PM
  8. JBirdMedic's Avatar
    NOT RESOLVED:
    Popup blocker had a setting for this turned off by default. DOH!
    Last edited by JBirdMedic; 2012-07-25 at 04:53 PM. Reason: CHANGED FROM RESOLVED TO NOT RESOLVED
    2012-07-22 04:14 PM
  9. patoons's Avatar
    RESOLVED:
    Popup blocker had a setting for this turned off by default. DOH!
    which setting? I toggled the airplane mode setting in popup blocker and when I opened bite, instead of warning me, it just turned airplane mode off...
    2012-07-25 04:23 PM
  10. JBirdMedic's Avatar
    which setting? I toggled the airplane mode setting in popup blocker and when I opened bite, instead of warning me, it just turned airplane mode off...
    Your correct, I found that out as well.
    I emailed and tweeted the popupblocker dev in hopes of resolution, just forgot to post here this is NOT RESOLVED afterall.
    2012-07-25 04:52 PM
  11. com_mander's Avatar
    Your correct, I found that out as well.
    I emailed and tweeted the popupblocker dev in hopes of resolution, just forgot to post here this is NOT RESOLVED afterall.
    After looking everywhere for a solution to this with no success, here's how I ended up fixing almost the exact same problem for the stock messages app.

    Using iFile,
    Edit /var/stash/Applications.xxxx/MobileSMS.app/Info.plist (on my iPhone /Applications is linked to the correct .xxxx)
    Change SBUsesNetwork~iphone from 20 to 2
    Save
    Respring

    A non apple app may instead use UIRequiresPersistentWIFI, which I think is boolean.
    2013-02-07 11:28 PM
  12. JBirdMedic's Avatar
    After looking everywhere for a solution to this with no success, here's how I ended up fixing almost the exact same problem for the stock messages app.

    Using iFile,
    Edit /var/stash/Applications.xxxx/MobileSMS.app/Info.plist (on my iPhone /Applications is linked to the correct .xxxx)
    Change SBUsesNetwork~iphone from 20 to 2
    Save
    Respring

    A non apple app may instead use UIRequiresPersistentWIFI, which I think is boolean.


    com_mander,
    Your a genius! After waiting almost a year you found the solution!
    Works on bitesms!
    2013-02-08 10:51 PM
  13. JBirdMedic's Avatar
    After looking everywhere for a solution to this with no success, here's how I ended up fixing almost the exact same problem for the stock messages app.

    Using iFile,
    Edit /var/stash/Applications.xxxx/MobileSMS.app/Info.plist (on my iPhone /Applications is linked to the correct .xxxx)
    Change SBUsesNetwork~iphone from 20 to 2
    Save
    Respring

    A non apple app may instead use UIRequiresPersistentWIFI, which I think is boolean.
    com_mander,

    So this no longer works for me on my ip5 on ios 6.1.4.
    Any ideas?
    2014-02-10 09:59 PM
  14. Spydar007's Avatar
    Download NoAnnoyance from Cydia. Add this repo: pNre's Cydia Repository
    2014-02-19 04:17 PM
LINK TO POST COPIED TO CLIPBOARD