1. Marty McFly's Avatar
    Should springboard wallpapers show up behind the SB widgets? I'm using Dacals Animation only widget and it's working great but just have a white background behind it. Wondering why my SB wallpaper won't show. Thoughts?
    2014-05-19 02:39 AM
  2. Simon's Avatar
    Should springboard wallpapers show up behind the SB widgets? I'm using Dacals Animation only widget and it's working great but just have a white background behind it. Wondering why my SB wallpaper won't show. Thoughts?
    The webview has a white canvas right now. If Jake makes it transparent like groovylock is then we should be able to see wallpaper behind the widget. Assuming the widget doesn't show it's own wallpaper of course.
    2014-05-19 02:41 AM
  3. NewD's Avatar
    Should springboard wallpapers show up behind the SB widgets? I'm using Dacals Animation only widget and it's working great but just have a white background behind it. Wondering why my SB wallpaper won't show. Thoughts?
    Springboard Wallpapers, built into SB Widgets should show behind animation if you have them switched on. IF however you want to see your Apple Wallpaper chosen in Settings behind an SB widget you have to put a transparent image where a wallpaper image is called for in the html or the js file.

    The webview has a white canvas right now. If Jake makes it transparent like groovylock is then we should be able to see wallpaper behind the widget. Assuming the widget doesn't show it's own wallpaper of course.
    Yeah. What Simon said. He explained it better. Didn't see his post when I made mine..
    Last edited by NewD; 2014-05-19 at 02:44 AM.
    2014-05-19 02:42 AM
  4. Simon's Avatar
    One of the simplest codes out there - Ian's Timed Walls -- alone.. Only 15 lines of code..
    PM me the link if you can. Wanna try out same one and see if I'm getting similar issues. None if mine are doing that on any of the versions of sbhtml I've tried.
    2014-05-19 02:42 AM
  5. NewD's Avatar
    PM me the link if you can. Wanna try out same one and see if I'm getting similar issues. None if mine are doing that on any of the versions of sbhtml I've tried.
    Will do when I get home..

    So when we're seeing the white, Simon, it's because our widget hasn't launched yet. Right?
    2014-05-19 02:44 AM
  6. Simon's Avatar
    Will do when I get home..

    So when we're seeing the white, Simon, it's because our widget hasn't launched yet. Right?
    Yup, the white is the default webview right now with nothing loaded. Groovylock was same way at first until jake made the webview transparent.
    2014-05-19 02:45 AM
  7. menard_00's Avatar
    I'm on i5 and getting same white screen. Loaded a new theme 10 times and lock/unlock has worked for me every time.
    2014-05-19 02:55 AM
  8. NewD's Avatar
    Yup, the white is the default webview right now with nothing loaded. Groovylock was same way at first until jake made the webview transparent.
    Okay, Simon. Thanks. Jake's asleep right now over there in England. We'll catch up with him in the morning.

    Has anyone tried the older style SB widgets that have overlays plus weather information?
    2014-05-19 02:57 AM
  9. Azon3's Avatar
    Thanks to this amazing tweak I have pano walls on my sb again. Running MJSmashPanoLite_v1 and all is well .
    2014-05-19 03:00 AM
  10. Simon's Avatar
    Okay, Simon. Thanks. Jake's asleep right now over there in England. We'll catch up with him in the morning.

    Has anyone tried the older style SB widgets that have overlays plus weather information?
    I haven't. Not sure if I have any of those ones.
    2014-05-19 03:02 AM
  11. GroovyCarrot's Avatar
    I'm having the same problem of white screen until a reboot. A simple respring or going in and out of an app doesn't fix it for me on 5S.

    I'm gonna start going through and turning of MobileSubstrates of tweaks like SpringPaper that attempt to do the same thing as SBHTML. THough I've turned off the enable button for SpringPaper - I haven't turned off its MobileSubstrate with iCleanerPro.

    Report your findings here so Jake can work out the final issues.

    Are any of you on iPhone 5 getting the white screen issue? Or is it confined to 5S? I know Bliken, who will report in here shortly has a 5S and is having the same issue.

    JKauff, are you on a 5S? Do you use any other SpringBoard Wallpaper tweaks by any chance?

    This hasn't worked for me, Simon. After several attempts - only the reboot worked.
    Logic-wise I would say any tweak that affects the dock may steal the events that this tweak hooks? If that's a start

    Also transparency fixed and icon courtesy of Simon: https://www.dropbox.com/s/htbkr99qi4...html-1.0.4.deb
    2014-05-19 03:05 AM
  12. kristatos's Avatar
    Logic-wise I would say any tweak that affects the dock may steal the events that this tweak hooks? If that's a start

    Also transparency fixed and icon courtesy of Simon: https://www.dropbox.com/s/htbkr99qi4...html-1.0.4.deb
    I bow before thee, Sir...running 7.0.4 with SB animations....sweet!...

    7.0.4 with SB widget.jpg
    2014-05-19 03:13 AM
  13. bliken's Avatar
    I too am having the white background with nothing showing up. Using UNIAW6.4SB

    Opened apps and closed them....respring doesn't do anything either
    2014-05-19 03:16 AM
  14. King_O_Hill's Avatar
    I did a brief beta for Jake on this -- and only 1.0.1, is working perfectly for me - with no white screen.

    All I get is a white screen.
    Last edited by King_O_Hill; 2014-05-19 at 06:17 AM.

    Check out WW3 for iOS 9/10 - Widget-Weather 3.0
    2014-05-19 03:34 AM
  15. RKO1195's Avatar
    You need to only lock the phone and unlock and it will work nothing else
    2014-05-19 03:36 AM
  16. Jkauf55's Avatar
    Okay, Simon. Thanks. Jake's asleep right now over there in England. We'll catch up with him in the morning.

    Has anyone tried the older style SB widgets that have overlays plus weather information?
    No I'm on ip5. No other tweaks beside iwidget and GroovyLock. After updating to 1.0.4 it's been loading better. If not a simple lock, waiting a few secs, and unlocking has fixed it.

    That's what I'm using (older style SB w/ Overlay).

    Last edited by Jkauf55; 2014-05-19 at 04:01 AM.
    2014-05-19 03:42 AM
  17. kristatos's Avatar
    I'm having the same problem of white screen until a reboot. A simple respring or going in and out of an app doesn't fix it for me on 5S.

    I'm gonna start going through and turning of MobileSubstrates of tweaks like SpringPaper that attempt to do the same thing as SBHTML. THough I've turned off the enable button for SpringPaper - I haven't turned off its MobileSubstrate with iCleanerPro.

    Report your findings here so Jake can work out the final issues.

    Are any of you on iPhone 5 getting the white screen issue? Or is it confined to 5S? I know Bliken, who will report in here shortly has a 5S and is having the same issue.

    JKauff, are you on a 5S? Do you use any other SpringBoard Wallpaper tweaks by any chance?

    This hasn't worked for me, Simon. After several attempts - only the reboot worked.
    I have an iP5 running 7.0.4 and had the white screen a couple of times after I change the icon layout through the settings.app...
    But it was fixed after respring with CC GUI cleaner...but it only happened after changing the icon layout...I have resprung several times
    using different methods and it hasn't happened again...this was with 1.0.3 version and also 1.0.4...I use Iconoclasm still...not HSD...

    Also...it happened after I unlock the phone right away after respring (before the LS dims)...I changed the icon layout again but waited for the LS to dim (I have it set for 30 secs) and it was OK...

    Okay, Simon. Thanks. Jake's asleep right now over there in England. We'll catch up with him in the morning.

    Has anyone tried the older style SB widgets that have overlays plus weather information?
    See my post #32...Sb widget from a theme that hasn't been ported to iOS7..been waiting months to use that SB...thanks GC...
    Last edited by kristatos; 2014-05-19 at 03:56 AM.
    2014-05-19 03:53 AM
  18. Jkauf55's Avatar

    Also transparency fixed and icon courtesy of Simon: https://www.dropbox.com/s/htbkr99qi4...html-1.0.4.deb
    Icon on Springboard?
    2014-05-19 03:56 AM
  19. TeddyDiesel's Avatar
    Here is using an old one from Mone, and it works great!


    Running ip5, 7.0.4, and only having to lock/unlock to get it to kick in.

    Amazing work, thank you!


    Edit: Also, ClassicDock still good to go.
    Last edited by TeddyDiesel; 2014-05-19 at 04:07 AM.
    2014-05-19 03:57 AM
  20. bliken's Avatar
    Well after a few reboots and a hard reset. I have UNIAW6.4SB working with times walls.

    ImageUploadedByModMyi1400462427.317072.jpg

    ImageUploadedByModMyi1400462435.931369.jpg

    ImageUploadedByModMyi1400462443.484739.jpg
    2014-05-19 04:20 AM
1,139 12341252 ...
LINK TO POST COPIED TO CLIPBOARD