1. NewD's Avatar
    Ah.. SO THIS is the bug people have been talking about after loading an App.. I've heard most others refer to their 'widgets disappearing' after downloading/updating an app. But I thought people meant their iWidgets would disappear which is a bug we saw a long time ago before WB was updated. So they mean - THEIR ICONS are disappearing BEHIND their SB widget? I'm getting a little confused. I think that I, also, have only seen this bug when downloading an app. But I haven't downloaded anything from App Store is months. And I still have seen this bug... I have though downloaded several things from Cydia.. So maybe it's 'any' install process'. For all we know - it could happen any time we even look into Cydia and it refreshes packages.. I'm not in the mood to go hunting after the few weeks I've had chasing down other things for myself and couple of others. I can live with THIS bug.. LOL!!!

    But I'd love to know the source of the bug if any of you can find repeatable steps to make it happen..
    2014-06-17 12:59 AM
  2. thazsar's Avatar
    Repeatable step:
    Download anything from AppStore!

    My temp solution is:
    Added the Settings.app as a QuickLaunch in Control Center.

    I can then, turn off SBHTML temporarily. This fixes it w/out a Respring
    Last edited by thazsar; 2014-06-17 at 01:28 AM.
    2014-06-17 01:25 AM
  3. bliken's Avatar
    I just hold the power button on the top and when it says power off......I hit cancel and it fixes it.
    2014-06-17 01:39 AM
  4. Boots's Avatar
    HAHA! SEEEE for me it's totally random points when it happens...at first I thought it was only happening when updating or installing an app but then I noticed it happens when sometimes closing an app so I have not been able to pinpoint regularities

    Just a curiosity...I can live w it
    2014-06-17 01:44 AM
  5. NewD's Avatar
    Repeatable step:
    Download anything from AppStore!
    Just did that.. Didn't happen. Like Boots' - mine is very random.
    My temp solution is:
    Added the Settings.app as a QuickLaunch in Control Center.

    I can then, turn off SBHTML temporarily. This fixes it w/out a Respring
    Nice temp solution, bro, for those of you who have it be triggered by App Download. That's not my trigger.

    I just hold the power button on the top and when it says power off......I hit cancel and it fixes it.
    Nice workaround, Blik! That's nice & easy.
    2014-06-17 02:34 AM
  6. MamaJaay's Avatar
    Can make it happen on demand if you have springtomize installed. Go to "pages" and adjust the icon row spacing or column spacing, or side inset. Then press home button. (Don't respring) you'll see
    2014-06-17 03:17 AM
  7. Boots's Avatar
    So then could this be a springtomize conflict?
    2014-06-17 03:23 AM
  8. MamaJaay's Avatar
    It happens to people not running it (S3) too, I'm simply using it to forcibly reproduce the event.
    2014-06-17 03:27 AM
  9. NewD's Avatar
    Yup, MJ!! That made the bug repeatable for me - for sure. Nice find!

    SB background layer moves to homescreen - touch functions work again (if leftover from a LS conversion).. Icons, normally in HomeLayer, get hidden behind widget from being moved to Background layer..

    Last edited by NewD; 2014-06-17 at 04:11 AM.
    2014-06-17 04:06 AM
  10. thazsar's Avatar
    I don't have Springtomize so that's not my conflict. Mine has to do w/ Five-Column Springboard.
    2014-06-17 06:13 AM
  11. NewD's Avatar
    I don't have Springtomize so that's not my conflict. Mine has to do w/ Five-Column Springboard.
    The bug in SBHTML presents when any given tweak hooks into the Springboard in a way the SBHTML is also hooking.. Actually the concept is pretty easy to understand.. It only "seems" like a random bug - but it all seems really logical to me now..
    2014-06-17 06:24 AM
  12. thazsar's Avatar
    The bug in SBHTML presents when any given tweak hooks into the Springboard in a way the SBHTML is also hooking.. Actually the concept is pretty easy to understand.. It only "seems" like a random bug - but it all seems really logical to me now..
    Agreed! I kinda wish the code for SBHTML was publicly on Github or somethin. I'd like to see what it hooks into and see if there was a better way...although I have limited knowledge.
    2014-06-17 06:33 AM
  13. NewD's Avatar
    Agreed! I kinda wish the code for SBHTML was publicly on Github or somethin. I'd like to see what it hooks into and see if there was a better way...although I have limited knowledge.
    There were a bunch of us who were still having trouble with 1.0.4 of SBHTML - in the form of changing a widget would not show until you put your phone to sleep then woke it up..

    Then "over night" Jake had an AHA! moment. And 1.0.5 came out and suddenly SBHTML worked perfectly for everyone.. Whatever he changed in his hooking method from 1.0.4 to 1.0.5 has created the bug. I still have 1.0.1 (the only version that worked "at all" for me prior to 1.0.5) - and, as you would expect, I just tested it with MJ's reproducing bug test using S3, and 1.0.1 does not have the bug that 1.0.5 does. So Jake will have to do some testing with S3 loaded. My guess is - if the bug is fixed for S3 - then it will disappear for folks who use other Springboard altering hooks.

    Do you have 5S?
    2014-06-17 06:42 AM
  14. thazsar's Avatar
    There were a bunch of us who were still having trouble with 1.0.4 of SBHTML - in the form of changing a widget would not show until you put your phone to sleep then woke it up..

    Then "over night" Jake had an AHA! moment. And 1.0.5 came out and suddenly SBHTML worked perfectly for everyone.. Whatever he changed in his hooking method from 1.0.4 to 1.0.5 has created the bug. I still have 1.0.1 (the only version that worked "at all" for me prior to 1.0.5) - and, as you would expect, I just tested it with MJ's reproducing bug test using S3, and 1.0.1 does not have the bug that 1.0.5 does. So Jake will have to do some testing with S3 loaded. My guess is - if the bug is fixed for S3 - then it will disappear for folks who use other Springboard altering hooks.

    Do you have 5S?
    I do! Why?
    2014-06-17 03:24 PM
  15. NewD's Avatar
    I do! Why?
    Two reasons:
    1) I think all people who experience this bug have 5S
    2) Jake only has an iPad mini air to test on for 64-bit things. And some tweaks like springtomize3 I don't think work on iPad. Just wondering how he'll test for it.
    2014-06-17 04:06 PM
  16. kristatos's Avatar
    Two reasons:
    1) I think all people who experience this bug have 5S
    2) Jake only has an iPad mini air to test on for 64-bit things. And some tweaks like springtomize3 I don't think work on iPad. Just wondering how he'll test for it.
    I have an iP5...it happens to me as well...as long as I stay away from going into the AppStore and installing/updating apps, I'm good...
    2014-06-17 04:30 PM
  17. jawonder's Avatar
    I'm using the tweak Dock&Roll and i was having a problem where if i make a call or use the spotlight to search my dock would disappear below the home screen and i can't use any icons on it . I read a few of your experiences and decided to turn off Springtomize and it was the culprit .

    My only problem now is what do i use to get rid of page dots, tried all the "no page do tweaks" in Cydia but they don't work .
    Last edited by jawonder; 2014-06-17 at 05:31 PM.
    2014-06-17 05:08 PM
  18. NewD's Avatar
    I have an iP5...it happens to me as well...as long as I stay away from going into the AppStore and installing/updating apps, I'm good...
    Great. That's good to have in the equation.
    2014-06-17 05:40 PM
  19. thazsar's Avatar
    I'm using the tweak Dock&Roll and i was having a problem where if i make a call or use the spotlight to search my dock would disappear below the home screen and i can't use any icons on it . I read a few of your experiences and decided to turn off Springtomize and it was the culprit .

    My only problem now is what do i use to get rid of page dots, tried all the "no page do tweaks" in Cydia but they don't work .
    NoPageDots7 worx for me on an ip5S.
    2014-06-17 05:58 PM
  20. oldskoolsk8r's Avatar
    Springtomize3 works for me to get rid of page dots


    Sent from my iPhone using Tapatalk
    2014-06-17 11:19 PM
1,139 ... 13212223242533 ...
LINK TO POST COPIED TO CLIPBOARD