1. NewD's Avatar
    Good to know. Wasn't sure if it would so was just throwing out some ideas as to why it isn't working for him.
    From your screenshot looks like whatever code he had to upsize the LS to i6 size isn't working in GL+ either.
    Hmm. You think that's what's breaking his code?

    Here are my config.js and UniAW6.js files.
    http://dl.dropbox.com/u/24971703/gra...20signori2.zip
    Last edited by NewD; 2015-01-01 at 08:56 PM.
    2015-01-01 08:42 PM
  2. Simon's Avatar
    Looks like he has the viewport code that June originally shared to upscale widgets in the lockbackground.html. Wonder why GL+ doesn't like that code.
    2015-01-01 08:43 PM
  3. signori's Avatar
    I understand if it didn't work on my 6+ only but it also won't work on a fresh restored 5s and 5th gen iPod. I tested Marty's original widget, with out the resize code.
    2015-01-01 08:54 PM
  4. NewD's Avatar
    I understand if it didn't work on my 6+ only but it also won't work on a fresh restored 5s and 5th gen iPod. I tested Marty's original widget, with out the resize code.
    Try my files - two posts back, Signori.. If that doesn't work I have another angle from which to come at this… Signori, please send me your widgetweather.XML file. Sometimes certain areas around the world return coordinates that won't work.
    2015-01-01 08:58 PM
  5. Simon's Avatar
    The resize code won't affect anything else. I just thought it was weird that wasn't working in GL+ too.
    2015-01-01 09:00 PM
  6. roneraven's Avatar
    Hey new, got it all working, just updating you
    2015-01-01 09:09 PM
  7. signori's Avatar
    Try my files - two posts back, Signori.. If that doesn't work I have another angle from which to come at this… Signori, please send me your widgetweather.XML file. Sometimes certain areas around the world return coordinates that won't work.
    I will do it in a bit. Watching the bowl games. Thanks.
    2015-01-01 09:19 PM
  8. DEH's Avatar
    Hi New

    I have no problems installing groovyAPI+, GroovyLock+ and GroovyBoard+, but when I have install them i can't download from safari until i uninstall them all again. Are there others who have experienced it?
    Dream until your dreams come true.
    2015-01-01 09:35 PM
  9. NewD's Avatar
    I will do it in a bit. Watching the bowl games. Thanks.
    Signori, bad news and good news. The good news is that there's nothing wrong with your phone or your understanding of my simple coding techniques.. (but you knew that!! LOL).... The problem is somewhere in the Accuweather code itself - even when set to false. Simon is in England now.. and your widget only shows DEMO MODE too when he tries it - even with my config.js and UniAW6.js files. BUT- - when he uses MY widgetweather.xml file for my location in Pennsylvania in the US - it WORKS for him.. Where are you located? In the US? If you are outside of US - this could be the trouble.. GroovyLock+ doesn't seem to like some part of the code of this older widget of Marty's. Not sure I have the skill to fix it. But I will try as I get time. You might need to take it to Dacal or GroovyCarrot in the GroovyLock thread and see if they're willing to help. I'm a pretty good coder now - but I don't know enough about what Jake did with the groovyAPI.do code to understand why Marty's widget would work for you in LH4 and Convergence on 6+ but not in GL+ with the one line code added in.. and yet - it DOES work for me with a US address. Strange.. I'm sorry but I can't get bogged down supporting a very old widget. But if I get time - I love solving mysteries.

    Thanks for you patience and sorry we got off on the wrong foot, my friend!
    2015-01-01 09:40 PM
  10. jawonder's Avatar
    Hi New

    I have no problems installing groovyAPI+, GroovyLock+ and GroovyBoard+, but when I have install them i can't download from safari until i uninstall them all again. Are there others who have experienced it?
    Yeah i have that problem, didn't realized it was cause by GL and GB. To solve it i copy and paste link in safari search bar and it brings up the download link .
    Last edited by jawonder; 2015-01-01 at 10:13 PM.
    2015-01-01 10:10 PM
  11. DEH's Avatar
    Yeah i have that problem, didn't realized it was cause by GL and GB. To solve it i copy and paste download link in safari search bar and it brings up the download link .
    Hi

    Thanks for the info, I will try to do that.
    Dream until your dreams come true.
    2015-01-01 10:15 PM
  12. Simon's Avatar
    Hi New

    I have no problems installing groovyAPI+, GroovyLock+ and GroovyBoard+, but when I have install them i can't download from safari until i uninstall them all again. Are there others who have experienced it?
    Known bug right now. I just hold down on the link and choose open in new tab to get around it.
    2015-01-01 10:33 PM
  13. Simon's Avatar
    Signori, bad news and good news. The good news is that there's nothing wrong with your phone or your understanding of my simple coding techniques.. (but you knew that!! LOL).... The problem is somewhere in the Accuweather code itself - even when set to false. Simon is in England now.. and your widget only shows DEMO MODE too when he tries it - even with my config.js and UniAW6.js files. BUT- - when he uses MY widgetweather.xml file for my location in Pennsylvania in the US - it WORKS for him.. Where are you located? In the US? If you are outside of US - this could be the trouble.. GroovyLock+ doesn't seem to like some part of the code of this older widget of Marty's. Not sure I have the skill to fix it. But I will try as I get time. You might need to take it to Dacal or GroovyCarrot in the GroovyLock thread and see if they're willing to help. I'm a pretty good coder now - but I don't know enough about what Jake did with the groovyAPI.do code to understand why Marty's widget would work for you in LH4 and Convergence on 6+ but not in GL+ with the one line code added in.. and yet - it DOES work for me with a US address. Strange.. I'm sorry but I can't get bogged down supporting a very old widget. But if I get time - I love solving mysteries.

    Thanks for you patience and sorry we got off on the wrong foot, my friend!
    Looks like he is in Canada if his location under his profile here is still accurate.
    2015-01-01 10:36 PM
  14. DEH's Avatar
    Known bug right now. I just hold down on the link and choose open in new tab to get around it.
    Yes it works 😃
    2015-01-01 10:44 PM
  15. NewD's Avatar
    Looks like he is in Canada if his location under his profile here is still accurate.
    The more I considering the problem - the more I'm concluding that the issue is something in yours and Signori's widgetweather.xml itself that Marty's widget doesn't like. When I place my xml file in there and others from US - it works great. When I use a widgetweather.xml file from you in England or from wherever Signori is - it doesn't work..

    I already ruled out the character ' / ' in several of the descriptions like Rain/Wind.. thinking that character (which is not in any of my daily or hourly descriptions.. ) might not be liked in the parsing. Then I ruled out anything to do with the zip code.. That's not the issue. The updatetimestring is fine too.. Still looking. I love a good mystery.. So we'll see.... Can't place it on any priority list - but code mysteries are relaxing for me -- so I'll chip away a little bit at a time..

    Thanks for your help troubleshooting, Simon..
    2015-01-02 01:58 AM
  16. roneraven's Avatar
    So I've noticed that my WW and clock don't update like they should now.

    I checked my phone at 6pm and then again at 9pm. When I checked it at 9pm the clock still said 6. Sometimes it's pretty laggy also taking a few seconds to register that I unlocked the phone and should be on the main screen.

    Is anyone else having this issue?
    2015-01-02 03:53 AM
  17. jawonder's Avatar
    So NewdestinyX still nothing can be done for 6.4 widgets that use AccuWeather and yahoo ? .
    2015-01-02 04:52 AM
  18. NewD's Avatar
    So I've noticed that my WW and clock don't update like they should now.

    I checked my phone at 6pm and then again at 9pm. When I checked it at 9pm the clock still said 6. Sometimes it's pretty laggy also taking a few seconds to register that I unlocked the phone and should be on the main screen.

    Is anyone else having this issue?
    Roneraven. Please take the time to read all posts before you post. This has been talked about several times. The bug, and how to have a workaround. Please read. I'm not mad. Just don't want to keep repeating things. 😉👍
    2015-01-02 06:59 AM
  19. NewD's Avatar
    So NewdestinyX still nothing can be done for 6.4 widgets that use AccuWeather and yahoo ? .
    I wanted to start slow, JA.. But when I talked to Jake about this - he told me that, as long as the widget in question doesn't use a call to a local file on the phone (no widgetweather.xml, no myLocation.txt) then it should just simply work in GL+ without any code added at all. The bug in WK Webbview right now is that it can't read a local file in our Documents folder. That's why we need the single-line code change in my tutorial in post number #2 for widgetweather.xml-reading widgets.

    But the problem with those Yahoo/AccuWeather widgets is that 95% of them still needed to address the mylocation.txt file in the documents folder. And I haven't been able to get them to work yet using the single line code change. even though Jake says there should be no difference the name of the file that it addresses in the documents folder.

    But what should work, even though I haven't tested this yet, is to set one of those older widgets with GPS mode turned OFF in the config.js and put in your WOEID for Yahoo or ZIP code for Accuweather. My guess is that will work in GL+ with no code change. Give it a try.
    2015-01-02 07:06 AM
  20. roneraven's Avatar
    Roneraven. Please take the time to read all posts before you post. This has been talked about several times. The bug, and how to have a workaround. Please read. I'm not mad. Just don't want to keep repeating things. 😉👍
    My bad new, thought I was staying current with the thread but I must have missed that somewhere lol.

    I'll dive back into the thread again tomorrow. Thanx
    2015-01-02 07:12 AM
831 ... 4567816 ...
LINK TO POST COPIED TO CLIPBOARD