User Tag List

  1. peeInMyPantz's Avatar
    Hi,
    recently I started experiencing this problem.
    Whenver i login to ssh on my iphone using my pc, my iphone screen hangs, or it gets very slow while exiting any applications. It remains slow even after i exit ssh and turn off ssh. Speed only resume after I restart my IPhone. One thing I notice when I ssh into my IPhone using 'SSH Secure Shell Client' is that nothing appears on the terminal on my PC, can't type anything in it (it just shows '#', but I can browser folders using 'SSH Secure File Transfer'.

    Initially I suspect that it was because recently i installed mobileTerminal and Python on my IPhone. So I uninstalled Python and mobileTerminal. After that I tried to ssh again, and this time the terminal looks normal, except that when I try to do 'ls', the terminal hangs, and my IPhone also got extremely slow.

    also tried uninstall and reinstall openssh. doesn't help. aside from that, I have 'Services' and uictl installed to turn on and off openssh.

    Something else that I recently did is to add a .profile file in /var/root
    that's all

    ssh is very useful, i hope someone can help me to get this fixed.
    Last edited by peeInMyPantz; 2007-10-07 at 02:22 AM.
    2007-10-07 02:19 AM
  2. Cody Overcash's Avatar
    It takes awhile the first time as it makes a key
    2007-10-08 02:44 AM
  3. peeInMyPantz's Avatar
    It takes awhile the first time as it makes a key
    i know... but that wasn't my first time...
    after the slow first time.... it has been working fine... the problem started recently

    *edit*---------------------------------------------------------
    ok...
    i decided to uninstall python, mobileterminal and openssh again...
    then only reinstall opessh.
    try to ssh to my iphone.. this time i works for a while..
    it at least shows
    "-sh-3.2#"
    after that i typed ls, and i can list the directory...
    if i try to type anything after that.. .it will logout automatically... good thing is it doesn't hang my iphone...

    then everytime i reconnect via ssh, it shows me the prompt, but everytime i type something, on the press of my third alphabet, it will logout... else.. if i type something with 2 alphabets e.g. 'ls', it will logout when i press 'enter'

    then i try deleting .bash_history in /var/root
    after deleting it.. i ssh into my iphone... i can at least execute 'ls' once again... then the problem repeats itself.. until i delete the same file

    *edit*---------------------------------------------------------
    .... after further testing... the problem is not specific to openssh
    installed Term-vt100 (first time trying)
    execute "ls",... list my directory
    execute "ls" again.. it exits Term-vt100

    *edit*---------------------------------------------------------
    reinstalled BSD Subsystem.... finally it works...
    just that it doesn't show sh-3.2# anymore... just show #
    but that's fine
    reinstalled everythign else i uninstalled above... doesn't interfere with it.
    i wonder what i did to cause the problem in the first place
    Last edited by peeInMyPantz; 2007-10-08 at 05:11 AM. Reason: Automerged Doublepost
    2007-10-08 04:28 AM
  4. Cody Overcash's Avatar
    whoa I can back to check and you already got it covered, so thinking BSD subsystem?
    2007-10-09 04:52 AM
  5. peeInMyPantz's Avatar
    whoa I can back to check and you already got it covered, so thinking BSD subsystem?
    yup. working perfectly now..
    think i messed it when i accidentally changed shell
    2007-10-09 06:03 AM
LINK TO POST COPIED TO CLIPBOARD