User Tag List

  1. sccooper's Avatar
    I have two iPhones, one jailbreaks just fine, one refuses period. I've tried two different macs and get 2 different errors. I've updated jailbreak and restored, iTunes and iTunes helper are both killed. Both phones are updated to 1.01. Oh and it syncs with iTunes still. Any insight would be great. Thanks.

    Error 1: jailbreak on other phone works great on this machine

    Administrators-Computer-3:~/phonedmg scooper$ ./jailbreak
    [jailbreak 1.0] by ziel w/ special thanks to GeoHot and the rest of the #iphone-dev crew.

    Looking for iPhone...
    Pairing Issue.

    Sorry, apparently things just didn't work out.
    Look on the bright side, if jail was that good for Paris maybe you should give it a second chance.

    Administrators-Computer-3:~/phonedmg scooper$

    Error 2: jailbreak doesn't want to even think about it, no I haven't tried the working phone on this machine yet. This is the machine it's paired with.

    [Administrators-Computer-4:~/phonedmg] angelaro% ./jailbreak
    [jailbreak 1.0] by ziel w/ special thanks to GeoHot, iZsh, roxfan, Nightwatch and the rest of the #iphone-dev crew.

    Looking for iPhone...
    Sending Files...

    *** If iTunes is running, please close it.
    *** Hold the POWER and HOME buttons for approximately 25s.
    *** Release when the display says 'Please Connect to iTunes'.

    Sending More Files...
    Segmentation fault
    [Administrators-Computer-4:~/phonedmg] angelaro%

    I figured out why it doesn't work on one machine, its a PPC. The other is an intel mac. But it's the intel mac that won't pair at all. Does the iPhone have to be modded on the machine it pulls it's library from? So maybe it's because the phone has a version of OS X from a PPC instead of intel on it? Hum...
    Last edited by sccooper; 2007-08-04 at 03:49 AM. Reason: Automerged Doublepost
    2007-08-04 03:27 AM
  2. cboyle4's Avatar
    i am having a similar problem, when i jailbreak and then hold for 25 secs it says:

    Sending More Files...
    Booting iPhone....

    and then it says that i need to hold longer, and i have made it so that itunes doesnt automatically sync it.

    whats the dilio?
    Big Black
    2007-08-04 07:03 AM
  3. arthursdomain's Avatar
    sccooper - did you try a full restore then jailbreak it again?
    2007-08-04 07:15 AM
  4. sccooper's Avatar
    I did restore it, on the PPC Mac. My guess is it's the fact that it's restored and synched from a PPC Mac and has a PPC system on it that the Intel Mac won't read from it. The Intel Mac is the one giving the unable to pair message. So I guess I'm sunk?

    I am curious now what jailbreak does (after I've already run it blindly on my $600 device lol) that is causing it to not be a universal binary and work on PPC. I had assumed it was just running some shell script and unix commands to modify and move some files around but I guess not? Maybe the owner of jailbreak needs to just recompile it in Xcode as a universal binary? I've got some coding experience but not OS X coding experience, so maybe I just don't understand the specifics here but it sure seems like someone took the shortcut route on the tool. I'm not hating, I love being able to mod my phone, as long as it's an Intel Mac.
    2007-08-04 04:14 PM
  5. sccooper's Avatar
    With bruce_wayne's help we figured out my second iPhone's problem. Since my intel mac had never "seen" the second phone in iTunes it just didn't want to recognize it (pair with it). Maybe no one else has seen this problem because naturally their mac has synced with their one iPhone before. So his suggestion was to open iTunes, let it "see" it for the first time, eject and close itunes then jailbreak. Tada! Works now, happily modding and a happy wife to boot.
    2007-08-08 03:08 AM