1. cgmcdaniel's Avatar
    Well I upgraded from 1.1.1 to 1.1.2 using Octoprep and the Jailbreak tools described in the Guide. Everything worked great, and I now have jailbroken 1.1.2 phone with Installer installed and all my 3rd party apps.

    Then today I tried using WinSCP via OpenSSH to access the phone as I always have. No go. I get network closed unexpectedly error.

    I checked to be sure OpenSSH was installed. It showed as installed in Installer. I then uninstalled and reinstalled it to be sure. Same error.

    I installed iToggle and tried to turn on OpenSSH that way. It would say it was on, but when I go out of iToggle and back in again it shows that OpenSSH is not on.

    I'm not sure what to do at this point. I'm 99% sure this is an issue with OpenSSH, but since a reinstall did not help I'm not sure what to do next.

    All help appreciated!

    CGM
    2007-11-21 11:53 PM
  2. apercele79's Avatar
    download SERVICES from installer,it will show you that SSH is either turned on or off
    it may be off and you dont even know it
    2007-11-22 12:26 AM
  3. TheOrioles33's Avatar
    Unfortunately I am having the same issue. Services says SSH is running but I cant get in. It worked like a charm before the update and re-jailbreak. My friend did the same thing as me and his SSH works fine. Very strange.
    2007-11-22 01:00 AM
  4. cgmcdaniel's Avatar
    iToggle does the same thing, but I gave services a try too. I still cannot get in.

    That said I am pretty sure OpenSSH is not runnning. When I go into the SYSINFO app and look at processes I do not see anything that looks like it.

    I wonder why it will not start up under 1.1.2. I had no problems at all under earlier versions.

    I know that when I ran the 1.1.2 Jailbreak it had a check-box asking if I wanted to install SSH. I checked the box. I wonder if that somehow corrupted SSH and is preventing it from running?

    CGM

    Rather than using Installer to install OpenSSH, I used iBrkr and installed OpenSSH that way. For some bizarre reason OpenSSH works now.

    All I kind think of is that some kind of corruption occured during the upgrade to 1.1.2 that caused the installation of SSH to get hosed. Installer could not overlay for some reason, but iBrkr can.

    Give it a shot, it worked for me.

    CGM
    Last edited by cgmcdaniel; 2007-11-22 at 06:44 AM. Reason: Automerged Doublepost
    2007-11-22 06:44 AM
  5. qdabean's Avatar
    I had the same problem. However I found out that you must have BSD Subsystem installed (which I didn't). Now both my edge and ssh work fine and I can toggle them on or off in itoggle. Make you have ssh turned off on the ssh switch that gets (optionally) installed when you jailbreak 1.1.2. before you toggle ssh in itoggle otherwise it won't work.
    2007-11-22 12:40 PM
  6. simonphp's Avatar
    I'm able to get to the connect to SSH host but when I insert the password of "dottie", it returns Permission denied. I installed services and SSH is ON.

    Here's what I'm entering:
    Code:
    % ssh [email protected]_IP_Address
    [email protected]_IP_Address password:
    Permission denied, please try again
    2008-01-15 03:14 AM
LINK TO POST COPIED TO CLIPBOARD