1. pangster's Avatar
    Hi,

    Read tons of threads on this - but the more i read.. the more i'm getting confused so wondered if someone could advise? help me?

    I'm in the UK and bought a US 8 GB iPhone in Hong Kong when i was over there. It's running 1.1.2 and is currently unlocked - the details from the about screen are:

    Version: 1.1.2 (3B48b)
    Model: MA712LL
    Modem Firmware: 04.02.13_G

    I was thinking about upgrading it to the latest 1.1.4 firmware - but wanted to check the best way/how to do this? - is it just a case of downloading and running iLiberty?? and what are the main differences between 1.1.2 and 1.1.4 (i.e. is it worth the hassle) - i'm also running Installer and have a few third party apps and have heard that these will be deleted once the phone is upgraded? - is this still the case??

    sorry for so many questions - want to make sure i cover everything though! lol!..

    can anyone help??

    surely someone must know??
    Last edited by pangster; 2008-06-27 at 04:44 PM. Reason: Automerged Doublepost
    2008-06-27 04:44 PM
  2. rvashi's Avatar
    I've never had experience with 1.1.2 as ever since I've owned an iPhone, I've had 1.1.3 or above. I think 1.1.4 is an awesome and very stable firmware.

    I would recommend you upgrade your phone first using iTunes to 1.1.4 stock. Then use the Pwnage Tool or WinPwn to pwn your phone and load up a pwned copy of 1.1.4. If all that seems too complicated. Just upgrade your phone to 1.1.4 using iTunes then use iLiberty or Independence or ZiPhone to Jailbreak and/or Unlock.

    When you upgrade your phone, all your apps and data will be deleted and you will have to reload everything back on the phone.

    Hope that helps...ask if you have any more questions. I know these forums aren't as active as some of the PocketPC forums that I use also. So just be patient...I'll try to help as much as possible...and hopefully other people can chime in.
    2008-06-27 07:53 PM
  3. smirkis's Avatar
    DO NOT USE ZIPHONE!

    use iliberty+ or learn about pwnage tools or winpwn for windows.

    its not as hard as u think it is. do a fresh restore to 1.1.4 HOLD SHIFT AND CLICK RESTORE then after you've downloaded 1.1.4 firmware file select it in itunes and let it do its thing

    when its done, use iliberty+ or winpwn and follow those instructions on getting ur phone jailbroken/unlocked again. u will lose all apps, but u will get installer.app back after its re-jailbroken. then you can go back and install all the apps u had before
    1.1.1>1.1.2>1.1.4>2.0>2.1>2.2>3.1>3.1.2 blackra1n'd

    waitin on my white iphone 4
    2008-06-27 08:37 PM
  4. rvashi's Avatar
    Yah I second that...don't use Ziphone. But everyone has there preferences so that's why I put all of the jailbreaking/unlocking tools out there so you can pick which one you wanna use.

    I highly recommend Pwnage Tool or WinPwn....but just learn everything about it first. Like, smirkis said, its not that difficult.
    2008-06-27 08:39 PM
  5. pangster's Avatar
    DO NOT USE ZIPHONE!

    use iliberty+ or learn about pwnage tools or winpwn for windows.

    its not as hard as u think it is. do a fresh restore to 1.1.4 HOLD SHIFT AND CLICK RESTORE then after you've downloaded 1.1.4 firmware file select it in itunes and let it do its thing

    when its done, use iliberty+ or winpwn and follow those instructions on getting ur phone jailbroken/unlocked again. u will lose all apps, but u will get installer.app back after its re-jailbroken. then you can go back and install all the apps u had before
    thanks rvashi and smirkis for the replies.. so get this right..

    1. i hook my iphone up to my PC and let it sync with itunes

    2. I hold down the shift key on my keyboard and select restore in itunes

    3. this will install 1.1.4 on my phone

    4. I then need to use iLibertyX (which i've already downloaded) to unlock it?

    ok - i think i've got my head around that! lol! - seems easier than i thought..

    i'm just confused with one of the settings in iLibertyX.. it says n one of the options:

    Downgrade bootloader from 4.6 to 3.9 Fake blank: for phones 1.1.2 or newer, you must use the 3.9 Fake blank bootloader to unlock baseband 04.04.05_G. If you do not wish to use the 3.9 FB bootloader, your baseband will be changed to 04.02.13_G. For the best functionality, check this option
    my phone currently has 04.02.13_G so does this mean i select this option?? sorry for the dumb *** questions!..
    2008-06-27 09:37 PM
  6. rvashi's Avatar
    I've never used iLibertyX. I've only used ZiPhone and Pwnage...but pwnage is much much better...becuase anything you do is undoable.

    As far as your question goes....I don't think there is any harm in keeping your current baseband 4.02.13. I don't think there is any need to do a fake blank however, again, I am not too sure about this one since i've never dealt with 1.1.2 and have always been a legit AT&T user thus never had the need to unlock either. Maybe someone else can comfirm.
    2008-06-27 09:59 PM
  7. pangster's Avatar
    ok - quick update.. i've now updated to 1.1.4 through iliberty and its working like a dream! a lot easier than i thought it'd be!! thanks for all your help and replies!!!
    2008-06-28 03:49 AM
  8. Poseidon79's Avatar
    Glad you got it working. Welcome to the forum.
    2008-06-28 04:06 AM
  9. rvashi's Avatar
    ok - quick update.. i've now updated to 1.1.4 through iliberty and its working like a dream! a lot easier than i thought it'd be!! thanks for all your help and replies!!!
    Glad you got it working and like it! Don't forget to hit the thanks button.
    If someone helped you, hit their THANKS button.
    2008-06-28 04:07 AM
  10. pangster's Avatar
    Glad you got it working and like it! Don't forget to hit the thanks button.
    rvashi - i did hit the thanks button! lol! to everyone who replied as i appreciate the time and effort you guys put in replying to me.. ! lol!..

    i had a couple of hick ups with iliberty - but i managed to solve them.. now its working great! - except i don't seem to be able to get customize to work??..
    2008-06-28 04:11 AM
  11. rvashi's Avatar
    Customize is still very much Beta. I posted in their forum a few times but those are totally useless. No one ever responds or helps. So I just uninstalled it after so many restores and tries. haha
    If someone helped you, hit their THANKS button.
    2008-06-28 04:14 AM
  12. pangster's Avatar
    lol!!! - fair enough!!!...

    i meant to ask.. what should my modem firmware be after updating to 1.1.4?? - it still shows as 04.02.13_G - is this correct??..
    Last edited by pangster; 2008-06-28 at 04:17 AM. Reason: Automerged Doublepost
    2008-06-28 04:17 AM
  13. rvashi's Avatar
    04.05.04_G is my Baseband. But I am also running 2.0 (5A331).

    But not really sure what the Baseband for 1.1.4 is...maybe Poseidon or someone else knows for sure.
    If someone helped you, hit their THANKS button.
    2008-06-28 05:05 AM
  14. rvlyssup's Avatar
    i meant to ask.. what should my modem firmware be after updating to 1.1.4?? - it still shows as 04.02.13_G - is this correct??..
    It should be 04.04.05...does your "locate me" feature work? You Tube, mail, etc too?

    Heck, at least you got her working again...
    My Week 51 8Gig is "retired", currently using i580 on Boost Mobile. Yeah, I miss my i...
    Wifey's - 8GB 3G unlocked & jailbroken using blacksn0w, GO GEO!
    Also retired Week 29 4 GiG on 3.1 custom firmware & originally Unlocked & JB via WinPwn.
    Unbranded & Unlocked Custom WM6 Cingy 8125, R.I.P Cingy 8525 (WSOD)
    BB Bold, Miami Ink v3, v235, & an mpx220, all unlocked!
    2008-06-29 08:16 AM
  15. pangster's Avatar
    It should be 04.04.05...does your "locate me" feature work? You Tube, mail, etc too?

    Heck, at least you got her working again...
    yep everything works spot on!! (mail, youtube, phone etc) - i even got Customize working.. apart from the locate me feature which i'm not too bothered about anyway.. lol!..

    EDIT: the locate me feature is now working after i installed Navizon - not sure why as it works even when Navizon is disabled?..
    Last edited by pangster; 2008-06-29 at 09:09 PM.
    2008-06-29 11:30 AM
  16. rvlyssup's Avatar
    yep everything works spot on!! (mail, youtube, phone etc) - i even got Customize working.. apart from the locate me feature which i'm not too bothered about anyway.. lol!..
    Awesome!!
    "locate me" won't work on 04.02.13_G BB and you are correct that it is not a real big deal.

    Customize 2.0 works on all FW and BB versions...
    My Week 51 8Gig is "retired", currently using i580 on Boost Mobile. Yeah, I miss my i...
    Wifey's - 8GB 3G unlocked & jailbroken using blacksn0w, GO GEO!
    Also retired Week 29 4 GiG on 3.1 custom firmware & originally Unlocked & JB via WinPwn.
    Unbranded & Unlocked Custom WM6 Cingy 8125, R.I.P Cingy 8525 (WSOD)
    BB Bold, Miami Ink v3, v235, & an mpx220, all unlocked!
    2008-06-29 07:47 PM
  17. pangster's Avatar
    Awesome!!
    "locate me" won't work on 04.02.13_G BB and you are correct that it is not a real big deal.
    that's what i read before as well - so i took some screenshots:

    Screenshot of system settings confirming firmware and BB:



    Screenshot after pressing the locate me button:



    Screenshot after it located me (about half a mile away! lol!):



    2008-06-29 08:28 PM
LINK TO POST COPIED TO CLIPBOARD