1. romanolney's Avatar
    ERROR: 1012

    I upgraded my hardware unlocked 1.1.4 iPhone to the new 2FW release. Surprise surprise, nothing worked. So I’ve been trying to downgrade to 1.1.4 again using iTunes 7.5. No problem there, except…when I complete the restore of 1.1.4 i get error 1012

    I managed to boot the phone, and checked the IMEI, ICCID, Modem etc… and the values were all blank. Then i got a msg on the iPhone screen saying “This iPhone cannot make or receive calls.”

    I've tried iliberty/zibri etc etc no luck. Also tried to use iTunes 7.7 to restore the phone using an official o2 sim card... but still no luck.

    Anyone getting similar problems?
    Bit stuck on where to go? any ideas?
    2008-07-13 10:12 PM
  2. jasonbutey's Avatar
    Hey
    i have the same probelm
    i have no idea wat to do
    people say to virganize the phone which i have done
    i used iliberty to unlock the phone n thought it was that then used ziphone n it wasnt that too cause that did the same problem.
    i just which someone could find a unlocking software for 2.0 so then i can use that hahah
    2008-07-13 10:24 PM
  3. romanolney's Avatar
    the phone isn't bricked... at the worst we'd need to do the original hardware unlock again... but I am going to sit back and wait for PWNAGE 2 release this week from the dev team.
    If you have any success in the meantime, would love to know.
    2008-07-14 12:05 AM
  4. jasonbutey's Avatar
    whens the pwnage 2 for windows come out ?

    i fixed it
    restore you fone back to 1.1.4 with itunes 7.5
    then use ziphone to unlock it so on
    and then use
    KiPhone
    that to fix the reception problem

    it works
    im happy
    now i iwll just wait until the 2.0 pwnage software comes out
    Last edited by jasonbutey; 2008-07-14 at 02:17 PM. Reason: Automerged Doublepost
    2008-07-14 02:17 PM
  5. asilveir_br's Avatar
    It worked really fine for me without any problems. Just to be more clear, step by step instructions are:

    BrooksGarrett.com » Blog Archive » Downgrading iPhone (1G) 2.0 to 1.1.4

    I hope this to helps.

    Andre.
    2008-07-14 05:41 PM
LINK TO POST COPIED TO CLIPBOARD