1. equlizer's Avatar
    Is it possible to downgrade the original 2.0 firmware for the 3g down to the 1.14 or whatever it is? has anyone tried it?
    2008-07-17 04:48 AM
  2. cpjr's Avatar
    Why??????????????
    2008-07-17 04:58 AM
  3. Trent J.'s Avatar
    I think I remember somebody saying it was impossible..

    Sorry for your luck =[
    Proud MMi Retired Moderator.
    2008-07-17 04:59 AM
  4. lostgame's Avatar
    Why??????????????
    Because there are no jailbroken apps for 2.0 yet...
    2008-07-26 08:17 PM
  5. cpjr's Avatar
    Because there are no jailbroken apps for 2.0 yet...
    And? You have the AppStore, you have a 3G network that is WAY faster than Edge, you have GPS functionality.

    All that will be lost by downgrading.....call me crazy, but the hacker apps arent that important to me. I would have bought/kept a first-gen Iphone for those purposes.
    2008-07-26 08:21 PM
LINK TO POST COPIED TO CLIPBOARD