1. pcuserforever's Avatar
    i have a friend with an unlocked 1.1.1. he is having some software issues and i want to back up his phone, upgrade to 1.1.4, iliberty+ jailbreak, and restore. my question is:
    can i use the current itunes or must i downgrade itunes to a version 6?
    if i have to do this, where can i get the older version.

    thanks for the help, i really love the site.
    2008-07-17 04:59 PM
LINK TO POST COPIED TO CLIPBOARD