User Tag List

  1. Maffoo's Avatar
    I boguht a 1st gen iPhone from my friend and it had 2.0 firmware on it, I successfully jailbroke it but when I tried to unlock it it somehow locked up and stayed in restore mode.
    Now when I plug it into iTunes and I try a restore I get error 1604. I've uninstalled every trace of Apple from my computer (Vista) and restarted, tried different USB ports and tried pretty much every other solution I've found online. The only thing I haven't tried it trying to restore with a Mac (as I don't own one), I even tried it on my XP computer and it didn't work.

    What can I do? It's still under warranty and as I bought it from a friend he might still have his receipt if I need to go to a Genius Bar. Is there another piece of software I could use to format the iPhone (because it seems to be a problem with that and not my PC software)or kick it out of restore mode? I tried iLiberty but it doesn't seem to recognise that the phone is connected...

    Thanks in advance =)
    2008-07-29 10:12 PM
  2. defmute's Avatar
    Turn off the phone
    Hold the power and home button for exactly 10 seconds
    let go of power button and continue to hold home buttom for exactly 10 more seconds.

    Then let go and plug into computer.

    Try shift restore again.
    2008-07-29 10:27 PM
  3. Maffoo's Avatar
    Oh I should have mentioned I tried it in DFU mode also, didn't work. Tried iTunes 7.5 with firmware 1.1.4 and thelatest iTunes with 2.0 firmware.
    2008-07-30 10:46 AM
  4. plummer's Avatar
    i just successfully downgraded back to 1.1.4 from 2.0. It took me a long time to finally get it to work....but this helped.
    linkhttp://www.modmyi.com/forums/general...0-1-1-4-a.html

    Also....make sure you uninstall any version of iTunes. Reboot and install version 7.7.1. Then uninstall it.......reboot and then delete any traces of iTunes folders. Install 7.5.....reboot. Then try and do the restore using different usb ports. I have found sometimes that front usb ports do not have the same juice as the back ports. Doing the above finally got me past the 1600 errors and to the 1015 (or whatever) error on doing the restore.

    After this.....i used Ziphone to do it's stuff. Hang on though....we are not done because it wouldn't recognize my carrier. SO.....it is because your firmware is the wrong version. Therefore I followed the above (the link) 2nd part.....and downgraded the firmware version and whatever else it wanted done. Then i went back to Ziphone and did the 'fix all' thingy again. All works great now.

    Good luck.....
    2008-08-01 05:37 PM
  5. scotty21's Avatar
    hey, i just wrote a fix for something like this in another post, i was getting error 1604 earlier this morning and this worked perfectly for me...i'm just gonna copy and paste what i wrote so some of it may not apply to u but the gist is there...

    i had the same problem just last night, i followed the steps to use pnwage without unlocking so i could just jailbreak my phone, but it went through the bootneuter process anyway, so i unplugged my iphone to stop it and got stuck in recovery mode and kept getting error 1604 when trying to restore it in iTunes. it took me 2 hours to find a way to fix it this morning, i got it back to non-unlocked/non-jailbroken, official 2.0 software and i wont be trying to pwn it again for sometime now. Basically, I downgraded to iTunes 7.5 and firmware 1.1.4 and then upgraded to 2.0.

    This is what i did.
    1. I used my windows computer (my iphone was formatted for my mac). So try a different computer, preferably a windows.
    2. Uninstall iTunes 7.7 on that computer (restart when prompted) and download iTunes 7.5 from here : Download iTunes 7.5.0.20 - FileHippo.com. (needless to say, if u dont have iTunes on that computer just download iTunes 7.5 and skip step 3)
    3. When you try to open it u might get the error that it can open because of iTunes Library.itl was used on a newer version. So go to My Documents, My Music, and then iTunes, and change 'iTunes Library.itl' to 'iTunes Library.itl.old'. Then go into Previous iTunes Libraries and copy one of them into the iTunes folder and rename it 'iTunes Library.itl' (i used my oldest dated one since the newer ones are formatted for 7.7 and other newer versions).
    4. Download firmware 1.1.4 from here: iPhone software 1.1.4 released: update precautions and troubleshooting - iPhone Atlas (just click on where it says 165 MB standalone download)
    5. Plug in ur iPhone, put it in DFU mode (make sure phone is off, hold power and home button til screen goes black, then let go of power button and hold only the home button until ur computer recognizes the usb device.
    6. iTunes should bring you to the device page, hold shift and click restore, and select the firmware 1.1.4 that you downloaded.
    7. for me, it was smooth sailing from there, it restored perfect going through its typical restore stages
    8. When it was done, it was activated and everything was good. i was running a clean 1.1.4 firmware. Then i plugged it into my mac, and updated and restored back to firmware 2.0 and got no errors, it updated just as it should and from its back up so i lost nothing. and i am now running on official 2.0 and everything is working like it's supposed to

    hopefully that'll work if u haven't tried it already!
    2008-08-05 01:46 AM
  6. dino2620's Avatar
    I am in the exact same situation, I always get 1600 errors when I try to do any kind of restore on itunes. I have tried itunes 7.5 and 7.7. I have tried downgrading back to 1.1.4 using itunes 7.5 in dfu mode... the itunes screen just gets stuck in the part where it says "restoring iphone firmware" and does not go any further, also the iphone gets stuck in the screen with the apple logo and the loader in the bottom. Could the hardware on my iphone be broken? because it will not restore to any firmware at all. I have tried on 2 windows xp computers and 1 macbook pro with no success. Is there any other way that I can restore my iphone without having to go through the restore process in Itunes.
    2008-08-05 03:10 AM
  7. Fear1508's Avatar
    I sometimes have those 1604 errors or w/e using itunes to restore. Usually what I do is, cause I have those problems either using itunes 7.5 or 7.6. Like when Im using itunes 7.5 and i get the 1600 error, i just update to 7.6 and restore and it then works. Then when it happens with itunes 7.6 i just uninstall it and install 7.5 and it works. Dont really have to delete any of the itunes library files or anything as long as you just swap between itunes 7.5, and 7.6. Hope that helps
    2008-08-06 08:12 AM
  8. morphiusrt's Avatar
    i got that trying to unlock 1.1.4 so all i did was unlocked 2.0 and it worked fine don't know what the problem was. but never uninstalled itunes or any of that.
    if this post help click the thanks
    2008-08-06 12:09 PM
  9. Fear1508's Avatar
    Well if you just said u unlocked 2.0. Then you must have been using itunes 7.7 which can't restore 1.1.4 iphones or older. Thats how u get those errors 1604
    2008-08-06 05:35 PM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD