1. InternalStorm's Avatar
    Hey guys,

    Alright so I have had a frustrating weekend of countless restores and reading up on all this iPhone junk trying to get my phone from 1.1.1 to 1.1.2. Long story short I had an unlocked 1.1.1 and I wanted to go to 1.1.3 but that screwed up once I got the 1.1.3 loaded. It seems that it was unlocked (it had my correct carrier showing in the Signal area) but not jailbroken so it was stuck on the emergency call screen. So, after tons and tons of times trying to get it to at least 1.1.2 it just keeps giving me an error when I try jailbreaking.

    What I do is make sure I am in 1.1.1, I restore twice, then I jailbreak, make sure the basband is 4.01 or w/e it is supposed to be for 1.1.1, then I install oktprep and after that I restore the 1.1.2 firmware. After that I run the Jailbreak software on the computer, but it tells me that I need to run oktprep prior to jailbreaking, which I had already done!! I tried so many times, I have tried with an unlocked 1.1.1, a locked 1.1.1, with a Mac and a PC running different versions of iTunes, and all that stuff and I just can't seem to get past this part, as if Oktprep is not working.

    I believe I got to 1.1.2 and jailbroke it the very first time I attempted going all the way to 1.1.3, but I think that screwed something up and now I can't jailbreak 1.1.2. The boot loader is 3.9 stil, I have checked...

    Any help would be appreciated! I don't want to have to sell this thing and get another iPhone just to be able to upgrade, because there are some improvements in the upgrades that I really need!

    Thanks a lot!
    2008-02-12 06:56 AM
  2. nickh's Avatar
    You have to hit Update, NOT Restore, as restore button wipes out the Oktoprep, Update is the button above restore, you will have to start again at 1.1.1 and update to 1.1.2 this will solve your problem.
    2008-02-12 08:12 AM
  3. InternalStorm's Avatar
    Awesome thanks a lot that worked!! Now I wonder if it's worth going to 1.1.3 or not.. I'll just keep it this way for now and we'll see how things go for a while.
    2008-02-12 08:17 AM
  4. nickh's Avatar
    Good to hear, Hope all goes well.

    Nick
    2008-02-12 09:46 AM
  5. InternalStorm's Avatar
    Okay so thanks a lot Nick it works great now. I found out how easy it was to go to 1.1.3 and so I did it without a hitch and updated the basband and unlocked it. Now I have one problem though, when I install something in Installer, installer will get to the installation bit and then it just exits to the homescreen and the program doesn't get installed. If anyone can give any pointers that would be great!
    2008-02-12 09:53 AM
  6. sziklassy's Avatar
    Your thread has become something else. This is not the place to continue with such a question if you want people to see it. That being said, the best I can recommend is doing a restore. This is the magic answer
    ------------------------------------------------------------------------------------------------------------------------------------------------------------------
    I once prayed to God for an iPhone, but quickly found out He didn't work that way...so I stole an iPhone and prayed for His forgiveness.

    A dog is the only thing on earth that loves you more than you love yourself. - Josh Billings
    2008-02-12 12:08 PM
LINK TO POST COPIED TO CLIPBOARD