1. weepiglet's Avatar
    Is there anyone in the UK with an O2 contract sim (not an iphone contract) working in there iphone?

    I have a 1.1.2 OTB which has been jailbroken (NOT UNLOCKED) and want to move up to 1.1.3 (is it safe?). Can someone advise how to upgrade and jailbreak 1.1.3 taking into account I D'ONT WANT TO UNLOCK, JUST JAILBREAK as I have an O2 SIM and have no need to unlock

    Hope all that makes sense!!
    2008-02-18 12:00 PM
  2. lamper's Avatar
    I am using O2 simplicity tarrif and I upgraded my 1.1.2 OTB last night. Used Zibris 2.3 software on my mac, you still need to unlock to use the simplicity card, even though it's still O2 (I know this is different to 1.1.2)

    It all went really smooth except i had to SSH my carrier list to restore Edge.

    If you are in no rush I would wait till the end of the month to see what the SDK brings and if 1.1.4 will be released, 1.1.3 dosen't really bring much additional functionality.
    2008-02-18 01:02 PM
  3. weepiglet's Avatar
    Cheers lamper...it's changing everyday and that's why I'm reluctant to do it. I am not a techie so all this new fangled chat about sdk, ssh, bootloaders etc is all very confusing...I just want to click once and everything will be done!!

    Looking forward to an easier method if 1.1.4 comes along
    2008-02-18 01:07 PM
  4. glj100's Avatar
    I am using an O2 sim, its a contract sim though through my company. It does not have edge on the contract and uses GPRS instead. I had a 1.1.2 OTB and jailbroke it. I have now updated it to 1.1.3 04.02 with 4.6 boot loader with Ziphone. It has unlocked to use any sim and I have tried Orange, T-Mobile ,Vodafone and they all work. Everyting works except GPS locator as my baseband is to low. Using locate me works though anf then I get a GPS location on Google maps.

    Waiting for the SDK now.

    GLJ




    Looking forward
    2008-02-18 09:20 PM
LINK TO POST COPIED TO CLIPBOARD