1. gman8966's Avatar
    My wifi is working now somehow, but I get terrible signal. I literally cannot walk more than 20 feet before it will drop out completely. I read that the antenna cover can possibly reduce the quality of the signal. Because I have had my iphone open before, my antenna cover is slightly distorted; it doesn't sit flush with the bottom of the phone, I ordered a new battery cover. I will report if this makes any difference in signal with the new cover and with it completely off.
    2008-09-10 10:50 PM
  2. kchociej's Avatar
    I have the same no wifi problem. I upgraded from 1.1.4 to 2.0.2 with pwnage tool 2.5. After pwnage I can not connect to any wifi signal. I googled the crap out of the internet looking for a solution and still no dice. Even after pwning it 3 times and playing with the options...still nothing!

    Throughout the day I randomly get a wifi signal for just a few seconds and it disappears. I have wifi at home, school and work, so it's definitley the phone acting up and not the wifi source.

    I have T-Mobile and just got my tzones working. The new APN is epc.tmobile.com ...it seems to be faster than the older wap.voicestream.com leave username and password blank just like the old one.

    Who else thinks this firmware sucks? My original f.w. was 1.1.1 and I've been upgrading with each new release. The keyboard lag is annoying and the phone seems to be overall slower.
    Last edited by kchociej; 2008-09-11 at 11:44 PM.
    2008-09-11 11:39 PM
  3. CaptainChaos's Avatar
    I miss 1.1.4
    I am not sure if I get wifi or not as I haven't been around a wifi source to check. This seems to be rather common.

    I read that some people's phones are defaulting to the Edge network while trying to get onto wifi. They say that if they remove their simcards they can then join networks.
    2008-09-12 12:07 AM
  4. CorsoN's Avatar
    I am in exactly the same situation as you Kchociej. I have looked everywhere with no luck, and I am not happy at all with this situation with my iPhone.
    2008-09-12 12:19 AM
  5. DoerrFan's Avatar
    Try turning FakeBlank ON in bootneuter. Maybe that'll help.
    2008-09-12 12:34 AM
  6. CorsoN's Avatar
    No luck, I have already try that. And also I have tried taken the sim card off, but nothing at all.
    Thanks anyway.
    2008-09-12 01:00 AM
  7. DoerrFan's Avatar
    No luck, I have already try that. And also I have tried taken the sim card off, but nothing at all.
    Thanks anyway.
    Hm, annoying problem you got there, last resort lets try this.
    MAKE SURE YOU RUN THE DIAGNOSTICS AND FOLLOW DIRECTIONS EXACTLY BEFORE TO MAKE SURE THIS IS YOUR PROBLEM!
    2008-09-12 01:55 AM
  8. bigemoney's Avatar
    Add me to the growing list of people with the same problem. I can't use this method that you just linked because my wifi address isn't greyed out. Please let me know when someone finds the solution. I need WIFI!!! Thanks
    2008-09-12 06:13 AM
  9. lucam1970's Avatar
    so I tried to upgrade to 2.1 ...

    no failure ... no problems during the process but I am still not able to have wi-fi connection working ....

    When I was on 2.01 and 2.02 I had 3.9 baseband

    Do you think I should try to flash it to 4.6 version(with bootneuer) ?
    2008-09-13 11:18 PM
  10. CorsoN's Avatar
    It is up to you, but I am on 4.6 already and no changes. No wifi anyway.
    2008-09-13 11:34 PM
  11. lucam1970's Avatar
    arghhhhh ... Is there any way out?

    Without wi-fi ... all of us have a nice ipod with some basic telephone function ....

    It's so
    2008-09-14 02:37 AM
  12. trevelyn's Avatar
    i tried every thing and this finally worked just open boot neuter turn on 3.9 turn on fake bank turn on nuter then hit flash and then restart twice back to norman walla hey i had been working on trying to get my wifi back to working for 3weeks I TRIED EVERYTHING TRY THIS THANKS FOR THE HELP GUYS
    2008-09-14 06:24 PM
  13. CorsoN's Avatar
    Hi Trevelyn, would you mind to explain everything you did again, step by step please. Many Thanks.
    2008-09-15 12:05 AM
33 12
LINK TO POST COPIED TO CLIPBOARD