1. LarryInAz's Avatar
    I've been cruising along just fine with my jailbroken 3G. Latest firmware 2.0.2 and used Mac PwnageTool about 10 days ago. No problems until this morning when I sync'd my phone as I have many times before and after the jailbreaking. I usually sync for new media as well as charging 2-3 times a day.
    However this morning I noticed my phone went from just under 1 gig free to nearly 3.5 gig free when it said the sync'ing was done. I went to the iPod icon of the phone and it shows a large NO CONTENT page! I then go to the Settings/General/About page and it shows 0 Songs and 0 Videos and 126 Photos.
    Only way I could fix it short of restoring [and re-pwn'ing] the phone and then having to redownload and reconfigure all my tweaking [several hours of effort] was to toggle off the music, podcasts, ringtones, etc.

    I tried sync'ing the phone so it would legitamtely delete the files which brought the meter down to 735megs of Apps, then I toggled all the music, podcasts, ringtones, etc. back on the way they were before and all seemed ok. But even though it shows that I should have 12+ gigs of media it still says NO CONTENT.

    FWIW on another iPhone forum a user suggested: "...to fix SSH into var/mobile/Media and delete the iTunes_Control folder and then sync all of my music again" which I did but when I attempted to do this I first get a warning about not being able to undo this action and I tell it to delete it anyway I then get a FAILURE message.

    Any help would be greatly appreciated...
    2008-09-07 01:26 AM
  2. stlcaddie's Avatar
    Have you ever installed swaplibrary from cydia or installer....sometimes it messes up with out you ever touching it.
    2008-09-07 01:32 AM
  3. LarryInAz's Avatar
    Have you ever installed swaplibrary from cydia or installer....sometimes it messes up with out you ever touching it.
    I do have SwapCameraRoll [would have installed it via Cydia] but don't have "swaplibrary".
    2008-09-07 01:42 AM
  4. stlcaddie's Avatar
    Mmm...I don't know if they deal with the same problem. But i would start there by uninstalling and see if the backup it replaces helps out....after done installing then reboot then resync and see what happens.
    2008-09-07 01:47 AM
  5. LarryInAz's Avatar

    FWIW my original attempt at SSH'ing my iPhone to delete the iTunes_Control folder was via my Mac using FuGu. As described in my first post in this thread I received a FAILURE error message and was not able to delete the folder.

    However I just attempted to delete the folder via my Windoze Vista laptop using WinSCP and it deleted it successfully without any issues.

    FYI, I did not uninstall SwapCameraRoll and I don't have a clue why FuGu wouldn't let me delete that folder while WinSCP did. What bothers me most though is why did all my audio and video media "disappear" and my iPhone said NO CONTENT ?

    FWIW - since I am at work and not home where my Mac is that contains all my media i.e. Podcasts and lots of music, etc. I sync'ed the iPhone on my laptop to make certain it will show the media and it does. It even backed up the 50+ App Store apps that I had on the phone so they are still there until I get home and since my contacts, calendar, etc are "in the cloud" via MobileMe I'm good.

    Hopefully this info helps anyone else that might have a similar catastrophe.
    I was not looking forward to restoring, repawning and then re-tweaking my phone.
    2008-09-07 03:33 AM
  6. LarryInAz's Avatar
    This is getting to be a royal PITA [Pain In The Arse]

    The NO CONTENT problem reappeared over the weekend.
    To attempt to fix it again I repeated what I did earlier per Matty's suggestion, SSH into var/mobile/Media and delete the iTunes_Control folder and per a suggestion on another iPhones forum I downgraded my iTunes from 7.7.1 to 7.7.0. The person suggested my NO CONTENT issue was probably caused by a known bug in the newer 7.7.1.

    I then sync'ed the iPhone with some music and podcasts and iTunes made it look like it installed these items normally and the "meter" showed it had several gigs of media. However even though this worked last time it didn't work this time. The only difference is I'm using 7.7.0.

    Short of just restoring the phone and not PWN'ing it do you have any other suggestions? This is driving me batty...
    2008-09-09 06:08 AM