1. uvbisani's Avatar

    "USB Device not Recognized".

    This is the problem with my iphone. I am running a windows XP SP2. Prior to the problem evrything was running fine. Even now my other iphone is being recognized and is being sync with itunes.

    1. Checked that my cable is not faulty.
    2. Tried a hard RESET.
    3. Phone does get into DFU mode but is not recognized by computer.
    4. After plugging in and the bubble eruption triied to install driver for iphone but it says no specific driver found for this hardware.

    Please somebody help.

    I have googled for 4 days in a row for a possible solution but to no avail.

    Can somebody point it out if this is a hardware problem or a software problem.


    I cant go back to apple for relpacement as i am an indian.
    There are no major tech's here for iphone repair.

    This happened after i upgraded to ver 2.2

    Common Guys help me out here.

    Aint there any one who could help me here
    Last edited by uvbisani; 2009-01-05 at 02:37 PM. Reason: Automerged Doublepost
    2009-01-05 02:37 PM
  2. toaster1974's Avatar
    Here is what I recommend:

    1. with itunes running turn off iphone
    2. Hold the power and home button
    3. When the apple logo appears keep holding the home button, but release the power button.
    4. You will get 2 pop ups. keep holding the home button until you click ok for the second pop up that says "Itunes has detected a phone in recovery mode"
    5. Now that you are not holding any buttons click restore
    6. Once the phone is restored in iTunes Immediately run Quickpwn 2.2
    7. Make sure it is Quickpwn 2.2
    8. After Quickpwn reboots your phone go back to itunes and setup your phone

    Hope this gets it done for ya.
    2009-01-05 08:00 PM
  3. uvbisani's Avatar
    But you dont understand that my computer is not even recognising it as a known harware. It says USB not recognised even with ITUNES running and as sson as i click the popup my phone seems to disconnect.

    Even than i tried what you suggested but it did not work.
    Thanks anyways.

    Any body else who could lead me to a solution.
    Last edited by uvbisani; 2009-01-06 at 07:44 AM. Reason: Automerged Doublepost
    2009-01-06 07:44 AM
  4. uvbisani's Avatar
    Aint there anybody in this big community who can help me out here.
    2009-01-07 02:40 PM
  5. strider101's Avatar
    I have a 2G 8GB iphone that just went nuts for no reason....when i plugged into my PC a popup was displayed saying "usb not recognized" and the iphone would not sync or charge. After a week of messing about with cables other peoples PC's and reading other peoples trials and errors about logic board failures and take it back to apple and apple blaming vista's drivers this is what i did...

    1) Deleted Itunes,Quicktime,Safari,MobileMe,Apple software updater, Apple mobile device, any driver files called usbaapl.sys and anything else Apple related.

    2) When all Apple related stuff was deleted i plugged the iphone into usb port and windows recognized it as iphone and installed Windows drivers. When driver install was complete iphone was recognized in device manager as Imaging Device and green charging icon was displayed on iphone screen.

    3)I left iphone plugged in and reinstalled itunes, Happy Days itunes installed and when it was finished iphone was recognized in itunes and charging battery was displayed on screen!!!

    4)Restored iphone to version 3.0 and jailbroke and unlocked using Redsn0w 7.1...

    I did this on Windows Xp system but hopefully taking these steps on any PC will sort your problems and if at 1st you don't succeed try again,i was trying for a week hope this helps.GOOD LUCK
    2009-07-19 08:28 PM
  6. tbancroft61's Avatar
    I had the same problem with a used iPhone I bought on eBay. It had a shorted battery and a detached negative lead which caused the phone to be inoperative. I replaced the battery and had to solder the ground to the metal case since the lead had come off the system board. Once the phone turned on I got the "usb device not recognized' message on my windows xp computer.

    I read all the postings I could find on this problem, but none of the suggestions helped. I uninstalled all Apple software and tried connecting, still got the message.

    I finally decided to diassemble the phone again and check all the connectors following instructions on disassembly from the web. I reassembled the phone and the phone rebooted and happily the message was now gone and I was able to jailbreak the phone.

    I can't be sure which connection was loose, but I am guessing it was the usb cable had come out a little.
    2009-10-12 07:59 PM