1. InspektaX's Avatar
    Hey guys

    after spending all day today on the net looking at every youtube video, blog post and other resource on this prob i am no closer to solving it.

    I purchased an iphone that was 2.2.1 jailbroken and working fine when i got it, after i added a few apps i noticed it was sluggish and freezing up here and there. Last night while at work i noticed it had just turned itself off. I restarted it and it just st at the apple screen for hours.

    This morning i decided to restore the firmware so i downloaded the iPhone1,2_2.2_5G77_Restore firmware and put it in DFU mode and restored the program. it got halfway then i got the 1013 error 3/4 of the way through, i restart the phone and it just sits on the apple logo, ive checked various sources and they say to open quickpwn and get the message to soft reset your phone and it should activte it, tried that, dosent work. Itunes dosent even pick up the iphone anymore but i have had the message "Itunes cannot activate your iphone due to the sim card or something like that" it was working fine and i just cant seem to find any further information that can help me with this, im totally stuck. if anyone can shed any light on this it would be awesome as im close to jumping on my iphone... thanks in advance,.....
    2009-04-13 10:16 AM
  2. the_rahul_009's Avatar
    I faced a similar type of problem and the problem was with my cable. I was using a chinese made cable and so it was not restoring. As soon as i tried with the original cable it restored properly
    2009-04-13 11:12 AM
  3. confucious's Avatar
    Ehy are you trying to restore 2.20 on a phone that had 2.21?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2009-04-13 11:12 AM
  4. AngryLemming's Avatar
    Been there, after toying around with Categories too much. Everything seemed fine, then it all went to hell. I forced it to DFU, connected it to my MacBook, then used QuickPWN to get the computer to recognize it (just that, nothing more) and then opened iTunes and did a restore, then jumped back to QuickPWN and jailbroke it. To get iTunes to recognize the iPhone was impossible, but I figured QuickPWn drew upon different resources to recognize it (blind guessing.) In the end, I hard restarted it many times and only happened to get a fragile bridge through QuickPWN and the iPhone. Doing a factory restore pulled it out of the flames though, so start there and jailbreak it after the fact. Maybe it was a fluke, but it is worth a try.
    2009-04-13 11:29 AM
  5. confucious's Avatar
    Error 1013 is because an earlier version of the software is being used. Using the correct version will resolve the error.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2009-04-13 11:42 AM
  6. InspektaX's Avatar
    so your saying i should be restoring to the 2.2.1 (3G): iPhone1,2_2.2.1_5H11_Restore.ipsw firmware and not the 2.2? even though i have tried installing the 2.2 and 2.1?

    OK i i restored using 2.2.1 and it loaded on no probs, then i launched quickpwn and it found my iphone but when i selected the ipsw firmware file i get an error saying "firmware error string" and i cant get any further, the iphone just sits at the apple logo, any ideas what to try next guys? seems to be looking slightly better i guess, at least i can load the firmware on it.... o yer when i open i tunes it now gives me an error saying that it cant activate my iphone because of a sim error.....

    OK guys new progress, i downloaded QuickPwn-225-2 and it worked with the ipsw firmware file no probs, i went through the stages and it loaded the files onto the iphone and then restared and showed the screen flashing the nco and kernel files, then i got the all clear from quickpwn saying it apperars to be complete, restarting your iphone. but again i get stuck on the apple icon, dosent budge past that. cant seem to connect to it with itunes either.
    Last edited by InspektaX; 2009-04-13 at 02:42 PM. Reason: Automerged Doublepost
    2009-04-13 02:42 PM
  7. MrWHOx's Avatar
    dude. ITS THE CABLE. simple as that. are you using an old/damaged/chinese knockoff itunes cable? i went through that same experience, but by luck, it went through and reflashed my phone. However, afterwards, i couldnt even CHARGE my phone. go get another cable and restore 2.2.1 and jailbreak.
    2009-04-13 06:11 PM
  8. mokylim's Avatar
    funny thing about the cable.but things like this happen
    2009-04-13 06:58 PM
  9. confucious's Avatar
    It might be the cable. But I doubt it.
    Far more likely is a simple timeout.
    The problem of the iPhone (and I assume the iPod Touch as well) getting stuck on the boot logo is caused by the built in timer which only allows 2 minutes for all apps to get registered. If it has failed to register all apps in 2 minutes it resprings and starts again thus ending up in a loop.
    This is a common occurrence when many apps are loaded and it takes longer than 2 minutes to register them all.
    This explains why a restore and setting up as a new device works as it is not trying to load all the apps.
    The solution is to temporarily move mobilewatchdog.bundle from /System/Library/SystemConfiguration/ to another directory (/ will do) until the device boots.
    When it has booted successfully mobilewatchdog.bundle MUST be moved back to /System/Library/SystemConfiguration/ - unless you want your device to respring every 10 minutes.
    You can move mobilewatchdog.bundle ether by SSH (if it is installed) or by DiskAid.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2009-04-13 10:07 PM
  10. InspektaX's Avatar
    Hey guys thanks for the replys,

    I doubt it is the cable, its a legit apple cable and is working fine with my brothers iphone.

    I dont have ssh on my phone so i tried diskaid and it connects to my brothers phone no probs, when i put mine in i get this error, CONNECTION FAILLED, COULDNT GET PRODUCT VERSION

    I could go buy another cable today and try that tonight when im back from work. But im guessing its got to be something with the install, ill try another recovery now and see if if diskaid can pick it up again. any more suggestions guys?

    also after i restore i just let it sit in it itunes and then eventually if i unplug it i get the error about the sim not being activated, and other times i will get an invalid response from the device error.
    Last edited by InspektaX; 2009-04-14 at 04:38 AM. Reason: Automerged Doublepost
    2009-04-14 04:38 AM
  11. confucious's Avatar
    Restore and set up as New phone. Jailbrake then restore from your backup.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2009-04-14 08:21 AM
  12. ks503's Avatar
    After the error 1013 happens close itunes, run quickpwn, jailbreak, done. This worked for me.
    2009-04-14 09:27 AM
  13. InspektaX's Avatar
    hey guys

    well it will let me resotre it fine but when it reboots it just sits on the apple logo, if i time the restarts right i can get into quickpwn and get it to reconigse it and jailbreak it but after that it will just sit on the apple/pineapple logo for hours on end. dosent a firmware restore wipe everything from the phone start fresh? Is it possible there are some files remaining from my previous working install that are conflicting with the boot process? Is it worth downloading a custom 2.2.1 5h11 firmware file thats already jailbroken and try that? Any further ideas would be great before i punch it harder and break the screen.

    i noticed confucious you mentioned before there could be something hanging in the boot process, the app process's? is there any other way other than ssh or disktune i can access the iphone to move the folder? Also another quick question, after i do a restore in itunes should it give me the option to name my iphone and copy over my files because i got that once and then from then on after i try restoring i dont get that option anymore.....

    hey guys ive just noticed something that might mean something to someone, after i quickpwn the phone reboots and stays on the apple icon for about 3-4 min and makes a few usb beeps, then it turns itself off and does the process again, however ive noticed twice that itunes has come up saying it has reconigned the iphone and asks if i would like to restore my backup from a week ago, however when i try to click on it, it freezes and hangs till the iphone reboots again in its never ending cycle.....
    Last edited by InspektaX; 2009-04-14 at 03:58 PM. Reason: Automerged Doublepost
    2009-04-14 03:58 PM
  14. confucious's Avatar
    How to repair “Apple Logo Screen Of Death” (endless boot) without SSH access! | TwiPhone.com
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2009-04-14 04:03 PM
  15. InspektaX's Avatar
    ok i managed to get to the root via diskaid and move our mobilewatchdog bundle, restarted the phone but still have the same problem, just the apple logo, any other ideas on what to move/try next from the file structure?

    ok guys sorry for all the messages and countless posts, just really want to sort this prob out

    Ive managed to get this far now from trying everything ive read and been advised...

    Restore to 2.2.1 5H11
    Quickpwn
    restart device
    nothing happens
    plug into itunes wait for 5min or more...
    eventually picks up device and register it as a new iphone...
    reboot...
    gets stuck on apple screen..
    use diskaid to move mobilewatchdog folder out and reboot..
    wait for about 15min...
    nothing.
    plug into itunes, gets device could not be reconignsed, 0x00008 or something close to those numbers and reboots itself.

    any ideas?

    ok guys sorry for all the messages and countless posts, just really want to sort this prob out

    Ive managed to get this far now from trying everything ive read and been advised...

    Restore to 2.2.1 5H11
    Quickpwn
    restart device
    nothing happens
    plug into itunes wait for 5min or more...
    eventually picks up device and register it as a new iphone...
    reboot...
    gets stuck on apple screen..
    use diskaid to move mobilewatchdog folder out and reboot..
    wait for about 15min...
    nothing.
    plug into itunes, gets device could not be reconignsed, 0x00008 or something close to those numbers, then it just reboots itself

    any ideas?
    Last edited by InspektaX; 2009-04-15 at 06:53 AM. Reason: Automerged Doublepost
    2009-04-15 06:53 AM
  16. confucious's Avatar
    Did you set up as a new phone then use quickpwn ?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2009-04-15 11:07 AM
  17. InspektaX's Avatar
    nope i had to quickown it before i set it up as a new phone because all i get after restoring it is the sim activation error, wont give me the option to restore it as a new phone.
    2009-04-15 11:07 AM
  18. confucious's Avatar
    What SIM do you have in it?
    Why won't it activate?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2009-04-15 11:31 AM
  19. InspektaX's Avatar
    I just have my vodaphone sim in it, the one i was using before. It wont activate because its not the original sim from the phone, i bought the phone from ebay and it was already unlocked and jailbroken, i just put my sim in it and it worked no probs.
    2009-04-15 11:32 AM
  20. confucious's Avatar
    That's the problem. You never said that the phone was unlocked just that it was jailbroken.
    The only way it could have been unlocked on 2.21 is by using a custom FW which is why you are having problems. Having restored 2.21 without a custom FW your only way of unlocking now is with a piggyback SIM.
    You should have mentioned that the phone was unlocked!
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2009-04-15 12:10 PM
24 12
LINK TO POST COPIED TO CLIPBOARD