1. Greenkirby21's Avatar
    hey, so my friend has an ipod touch 2g. she tried to jailbreak it and broke it. So, she came over, since I "supposidly" know how to fix it, but I am stumped. It doesnt turn on, so I put it into DFU restore, and my itunes found it. I hit restore, and it said wrong software. So, I downloaded the 2.2.1(what she had) and did option click, and it says wrong firmware. I know she has a 2g(it has speakers). Also, I tried to jailbreak it, since restoring isn't working AT ALL, but quickpwn and pwnage wont even recognize it. I am really stumped, and I own an iphone, can anyone help me out?
    2009-05-16 07:50 AM
  2. bhz1's Avatar
    Had the same problem jailbreaking an ipod touch the other day for my son's friend. Ive done iphones dozens of times but this was my first ipod touch. At first quickpwn kept telling me the wrong firmware but I noticed it didnt download fully. (file size too small) I found a different source rebooted the computer and quickpwn recognized the firmware. However qhile quickpwn told me that it completed successfully, the ipod was stuck on endless reboot so I ended up using pwnage and all was well.
    2009-05-17 02:09 AM
LINK TO POST COPIED TO CLIPBOARD