User Tag List

  1. boyb's Avatar
    Hi,

    I have an iPhone 3G 16GB model. I bought it second hand from a guy on craigslist. It worked fine until one day I decided to use it with iTunes and put some music on. My first time using it I connected it and it said "You are currently running version 3.0, please upgrade to 3.0.1" (or something to that effect). So I decided to do it, figuring it would be a standard update (as I have done plenty of times before on my iPod).

    Well it got about 75% of the way there and gave me error 1015, and locked my phone in recovery mode where it has been since. I emailed the guy back from craigslist asking if he knew any reason why. He told me that he had firmware 3.1 beta on the iPhone. I'm still not sure why it recognized 3.1 beta as 3.0 and tried to upgrade to 3.0.1, but it did. However, I guess this explained where the trouble came from on the phone.

    So finally I found this forum which seemed useful:
    http://modmyi.com/forums/general/662...3-1-3-0-a.html

    Unfortunately when I do this it fails to give me error 1015 and gives 1604 instead. It cannot even get past the "preparing iPhone for restoration" phase.

    I have tried using redsn0w to jailbreak it (something I was eventually intending to do anyway), and it gets so far as the "Activating" stage, freezes for 10 minutes and resets the iPhone in recovery mode.

    Can someone just tell me how to put an OS on it, 3.0, 3.0.1, 3.1 I really don't care at this point. I also don't care if I lose my recovery information (installed apps, contacts, etc), just as long as I get this damn thing working again.

    It's really frustrating that I can't use my phone and i'm worried that it might be permanently broken. Please help, I really appreciate it.

    Thanks in advance.
    Last edited by boyb; 2009-09-01 at 01:46 AM.
    2009-09-01 01:44 AM
  2. PolishHacker's Avatar
    My friend had the same problem all you have to do is put your Iphone in DFU Mode and just restore to the 3.0 Firmware. After you restored it to the 3.0 Firmware go back to itunes and upgrade to the 3.1 and then jailbreak
    2009-09-01 03:43 AM
  3. Bo Troxell's Avatar
    3.1 has not been released yet I think you mean 3.0.1. just stay on 3.0 if that's what you restored to, you'll be fine.
    smaller sig.png
    2009-09-01 04:01 AM
  4. boyb's Avatar
    sorry, perhaps I wasn't clear with what I wanted. My iPhone is still stuck in recovery mode. The screen shows the USB pointing to the iTunes logo. I cannot get this to go away or load any OS.

    3.1 is released as a beta phase, for developers. That's what the previous owner installed on it. I want to put 3.0 back on it. But I can't seem to put any OS on it.
    2009-09-01 04:52 AM
  5. Bo Troxell's Avatar
    Yes your correct, it is available to devs.
    Put the phone in DFU mode and then restore in iTunes. In case you need them here instructions.

    INSTRUCTIONS
    Step 1. Turn off iPhone
    Step 2. Hold down the power and home button.
    Step 3. When you see the Apple logo, release the power button but continue holding the home button down.
    Step 4. Open iTunes and wait for it to tell you that it detects iPhone in restore/recovery mode.

    Alternative Method:
    Step 1. Connect iPhone to USB then listen to the sound when it connects and disconnects.
    Step 2. Hold the home and power buttons until hear the disconnect sound then release power button.
    Step 3. Wait until you hear another sound then release home button.
    smaller sig.png
    2009-09-01 05:00 AM
  6. boyb's Avatar
    Thanks for the response.

    Unfortunately I have already tried this and it does not work. Following your method gets to the "preparing iPhone for restore..." stage, then it gives the 1604 error.
    2009-09-01 05:13 AM
  7. Bo Troxell's Avatar
    have you Googled to see what that error is?
    smaller sig.png
    2009-09-01 05:17 AM
  8. boyb's Avatar
    Yes, I have but I cannot find anything that has actually helped me fix it. I have tried several different methods but all to no avail. Thanks again.
    2009-09-01 04:33 PM
  9. soulthoughts's Avatar
    Is your itunes up to date?
    2009-09-01 05:55 PM
  10. boyb's Avatar
    I've tried it both ways,

    Currently I'm running 8.1.1 because of the instructions in this post:
    http://modmyi.com/forums/general/662...3-1-3-0-a.html
    Last edited by boyb; 2009-09-01 at 09:36 PM.
    2009-09-01 06:03 PM
  11. Bo Troxell's Avatar
    iTunes needs to be at least 8.2
    smaller sig.png
    2009-09-01 06:51 PM
  12. ddonuts4's Avatar
    Try it on a different computer.
    2009-09-02 04:22 AM
  13. soulthoughts's Avatar
    iTunes needs to be at least 8.2
    Yup. That's what I said too.
    2009-09-02 10:38 PM
  14. Bo Troxell's Avatar
    ^ just thought I would spell it out for him, lolz
    smaller sig.png
    2009-09-02 10:40 PM
LINK TO POST COPIED TO CLIPBOARD