1. reemix78's Avatar
    I was doing a retore to fix a cydia problem and got distracted and accidently upgraded my 3g 3.0 to 3.1... I have been away for a minute and didn't even really know about the upgrade so I wasn't expecting it. Anyway....I have since been able to downgrade back to 3.0 (using method found here, http://modmyi.com/forums/3g-s-downgr...ml#post4954929), re-jailbroke with no problems, fixed cydia problems hopefully for good, added source repo666.ultrasn0w.com, and downloaded ultrasnow, but it will not read t-mob sim card, it just stays with "searching" and doesn't pick anything up. It read an at&t sim card just fine before and after jailbreaking, however after downloading repo666 and ultrasnow and trying t-mobile card it gave me some trouble reading at&t card. Thinking it may be the source I added it to another iphone that did not previosly have ultrasnow unlock and it worked fine with both at&t and t-mobile sim cards. Tried everything above again twice and same result. So now I'm stuck hoping someone can offer some assistance??? Thanks and srry so lengthy!
    2009-09-17 04:19 PM
  2. bondkt's Avatar
    there is no way to downgrade your baseband, sorry =/
    Last edited by bondkt; 2009-09-17 at 11:50 PM.
    2009-09-17 04:54 PM
  3. reemix78's Avatar
    Do you know if they are gonna fix this eventually, or if they are even working on it?
    2009-09-17 05:29 PM
  4. BlackWolf's Avatar
    noone can say really. it's a question of if they find another hole in the 3.1 baseband, or any future baseband. if so, that baseband will become unlockable and they will release tools to do so.

    but it could be that your unlock is permanently broken, at least I wouldn't wait for a quick solution.
    2009-09-17 05:54 PM
  5. titeo's Avatar
    the baseband for 3.1 is 05.11.07 right? **** i think the guy who sold me the phone recently updated to 3.1 but couldn't jailbreak it so he then downgraded to 3.0.1 but the baseband isn't downgraded.

    ****....i can't unlock my 3G...only jailbreak...
    1st Gen iPhone 2.0 - Jailbroken and Unlocked on T-Mobile
    2009-09-17 06:44 PM
  6. BlackWolf's Avatar
    the baseband for 3.1 is 05.11.07 right? **** i think the guy who sold me the phone recently updated to 3.1 but couldn't jailbreak it so he then downgraded to 3.0.1 but the baseband isn't downgraded.

    ****....i can't unlock my 3G...only jailbreak...
    if your baseband is 05.11.07 than yeah, the phone has been at 3.1 at one point or another. sorry to say, but for now that leaves you with a pretty ipod, not more. currently there is nothing you can do about it.
    2009-09-17 08:13 PM
  7. reemix78's Avatar
    So right now all the PwnageTool 3.1 does is jailbreak the 3.1 firmware? It doesnt make the phone unlockable?
    2009-09-17 08:51 PM
  8. PhoneLine's Avatar
    The tool allows you to update the phone with a modified firmware which would have allowed you to install 3.1 and keep the old baseband.

    But if you updated the phone with the stock apple file or via itunes regular restore, you have lost that option and the baseband is now the new version which is currently (and perhaps permanently) unlockable.
    2009-09-17 08:57 PM
LINK TO POST COPIED TO CLIPBOARD