1. maxduck's Avatar
    About to JB a friends 3GS. Apple store bought, f/w 3.0.1.

    I go to capture the ibec and ibss (as per iclarified http://www.iclarified.com/entry/index.php?enid=4400 )

    In DFU mode the dialogue box comes up saying "this will verify the restore with Apple". Will this screw me into needing 3.1?

    But are the ibec and ibss necessary or not??

    Anybody with any insights?

    I've searched but can't find any answers

    thanks!
    Last edited by maxduck; 2009-09-24 at 04:28 PM.
    2009-09-24 04:07 PM
  2. Simtech's Avatar
    No, you didn't search. There is only about 8 million threads on this topic.
    2009-09-24 04:33 PM
  3. maxduck's Avatar
    well the closest I came in my searching was people asking the same question and nobody answering with any definitiveness. Or if they did they were soon shouted down with opposing views. I thought I'd start a new thread with one simple question. Oh well.
    2009-09-24 05:17 PM
  4. BlackWolf's Avatar
    I'm not quite getting your question. here is some stuff:

    1) if you want to restore to 3.0 or 3.0.1, you need to have your ECID SHSH on file in cydia. if you havn't gotten them yet, you cannot anymore, but you should still get your 3.1 SHSH in cydia to make sure that you can restore to 3.1

    2) if you need to unlock 3.1 then you DO need the ibec and ibss. but: if you havn't gotten them yet, you cannot anymore, so you are stuck with 3.0.1 forever and ever, which gets even worse because you can't restore anymore. if anything happens to your phone ever -> bad luck.

    3) if you do not need an unlock, you only need the ibec and ibss if you want to use pwnagetool to jailbreak the phone, but you can get them at any time, so there is no real hurry (I guess ... I still advise you to get them asap). you probably won't need them if redsn0w for 3.1 is released
    2009-09-24 09:35 PM
  5. maxduck's Avatar
    thanks Blackwolf, that's a great help!


    I understood the first two points it was the third I didn't:

    "3) if you do not need an unlock, you only need the ibec and ibss if you want to use pwnagetool to jailbreak the phone, but you can get them at any time, so there is no real hurry (I guess ... I still advise you to get them asap). you probably won't need them if redsn0w for 3.1 is released"

    it is the getting them @ anytime part. That what I was trying to do thru putting the phone into DFU... hence the apple verification problem.

    So, I'm exploring other ways to get the ibec and ibss on a mac.

    cheers!
    2009-09-25 02:20 AM
  6. BlackWolf's Avatar
    thanks Blackwolf, that's a great help!


    I understood the first two points it was the third I didn't:

    "3) if you do not need an unlock, you only need the ibec and ibss if you want to use pwnagetool to jailbreak the phone, but you can get them at any time, so there is no real hurry (I guess ... I still advise you to get them asap). you probably won't need them if redsn0w for 3.1 is released"

    it is the getting them @ anytime part. That what I was trying to do thru putting the phone into DFU... hence the apple verification problem.

    So, I'm exploring other ways to get the ibec and ibss on a mac.

    cheers!
    well, if you want to jailbreak you probably won't get them now. the thing is that you need to restore to 3.1 to get them. if you do that now, you're stuck on 3.1 without a JB until one gets developed. but as soon as the 3.1 JB is out, you just restore to 3.1, grab the iBEC and iBSS, then use them to create a jailbroken custom firmware -> done. your unlock is lost forever then, but you are jailbroken on 3.1
    2009-09-25 11:55 AM
  7. maxduck's Avatar
    well, if you want to jailbreak you probably won't get them now. the thing is that you need to restore to 3.1 to get them. if you do that now, you're stuck on 3.1 without a JB until one gets developed. but as soon as the 3.1 JB is out, you just restore to 3.1, grab the iBEC and iBSS, then use them to create a jailbroken custom firmware -> done. your unlock is lost forever then, but you are jailbroken on 3.1
    it's unlocked from apple store so fortunately that doesn't have to be in the equation.

    it's now jailbroken so when the 3.1 JB comes out, we'll grab the files and sit happy, fortunate there's some seriously smart and motivated people out there doing great work to keep us relatively freer!

    thanks again for ur help.
    2009-09-25 05:00 PM
  8. BlackWolf's Avatar
    it's unlocked from apple store so fortunately that doesn't have to be in the equation.

    it's now jailbroken so when the 3.1 JB comes out, we'll grab the files and sit happy, fortunate there's some seriously smart and motivated people out there doing great work to keep us relatively freer!

    thanks again for ur help.
    well, if it's already unlocked by apple then you are lucky, you will be able to go to 3.1 and JB it :-)
    2009-09-25 06:35 PM
LINK TO POST COPIED TO CLIPBOARD