1. karong's Avatar
    Ok let me start at the begining. Ive been using a unlocked iphone 2G for a while now, no issues. I upgraded to the 3.1 software the other day and it locked the phone. Now its at the "connect to itunes" screen like its fresh out the box. When i connect it to itunes it tells me i need a valid sim to activate of course. I tried using redsnow to unlock. downloaded all the files, when thru the whole process but still not unlocked. itunes still needs a valid sim. Now i dont have a sim cuz i been using it mostly as a ipod since i have a Blackberry and buy prepaid sims when i need it. So my question is what am I doing wrong? I did the unlock process 3 times to completion but still no go.

    PS. one the first step in the unlocking it says restore the iphone but I cant even get that far in itunes to that so u usually skip that step. could that be it? when i plug into itunes it just tells me i need a valid sim. I cant even get to the point to restore
    2009-10-01 03:01 AM
  2. Bo Troxell's Avatar
    Put the phone in DFU mode and then you can do a shift+click & restore iTunes will see it then.
    You may have to downgrade to 3.0.1 to get the unlock back though
    2009-10-01 03:07 AM
  3. karong's Avatar
    ok how to i downgrade?
    2009-10-01 03:14 AM
  4. Bo Troxell's Avatar
    You'll have to downgrade your iTunes to 8.2.1, you can Google that it's really easy to do and get the info.
    Then do a shift+click & restore to 8.2.1 on your phone pointing at the .ipsw file that you'll need.
    Then jailbreak with redsn0w 0.8 using the 2 bootloader files to unlock.
    You can get everything you need here for the jailbreak/unlock including the .ipsw restore file.
    2009-10-01 03:19 AM
  5. karong's Avatar
    Thanks but i just got it. I just had to do the shift+restore, upload the firware i downloaded and THEN follow the unlock steps and it worked. Thanks
    2009-10-01 03:46 AM
  6. pingywon's Avatar
    I am running itunes 9.0 and have firmware 3.1 on a 2G.

    Its not my phone and I dont have a valid sim for it.

    Everytime I make custom firmware packages from pwnage tool 3.1 the option restore fails. I either get a error 1600 or 21xx.

    Can you tell me how you got this to work for you in more details....

    im pulln my hair out here!
    2009-10-02 05:11 AM
LINK TO POST COPIED TO CLIPBOARD