1. x2d3wow's Avatar
    Hello,

    I have a brand new iphone 3GS that has been put into [accidentally] put into recovery mode. It is on O2 Pay As You Go, and has been activated at purchase. I am trying to jailbreak it with pwnagetool, but instead got the device into recovery mode instead of DFU. When I try to restore to a fresh 3.0.1 (noncustom) it gives me an error that my device isn't eligible. Can someone help me

    1) Get out of Recovery Mode
    2) Get Pwnagetool to recognize my device in DFU mode
    3) Succeed!

    When I tried to put the iphone in DFU mode (before it went into recovery) pwnagetool refused to recognize the phone when turned on (displayed the "Connect you Phone" msg) except when the phone was booting up, when it gave me the timings, which I followed and it went into something like DFU mode (IE black screen, no response from button presses unless both pressed together for 15 secs), however pwnagetool told me that the device wasn't in DFU mode.

    Suggestions, or perhaps an alternative method to do this (a pointer to a guide would be great)

    Also - if all of these questions are a bit too much, help me answer one - how do I get my phone out of recovery mode in 3.0.1?

    Thanks!
    2009-10-11 01:52 AM
  2. Chiitus's Avatar
    I had the same problem on my iPhone 3G.. OS 3.0, lol. Well this method worked for me:
    Hold down the Sleep and Home buttons until screen goes blank and shows apple logo again, then keep holding home for like 20 seconds.
    2009-10-11 02:34 AM
LINK TO POST COPIED TO CLIPBOARD