1. akoik's Avatar
    I see that some folks are able to get winterboard and other springboard apps running with no probs after a 3.1.2 jb on 3gs, but I also see that others are having the same problem I am and they aren't working. There must be something I'm doing wrong, or could do different.

    I saw some comment about having to run it a few times. Do I need to UNjb my phone (restore from iTunes) first each time? When I've tried just running Blackra1n, it's not putting the Blackra1n app back on my phone (saw something about deleting Cydia too to fix this).

    Any help would be greatly appreciated!
    Melanie
    2009-10-12 05:28 PM
  2. mommadee's Avatar
    Yes i had the same problem or sometimes i wouldn't have all the sources in cydia. When you jailbreak it and install cydia make sure it does the complete upgrade and make sure you have all the sources there it suppose to have and then it should work.
    2009-10-12 06:29 PM
  3. michada's Avatar
    make sure you have winterboard "blacklisted" if you have backgrounder installed....
    2009-10-12 06:41 PM
  4. akoik's Avatar
    I didn't know what I was doing, so didn't do the complete upgrade with cydia. I also uninstalled the blackra1n app and can't figure out how to get it back on my phone (have restored from itunes and then re-run blackra1n). What now?

    Thanks!
    2009-10-12 06:43 PM
  5. itsmejdn's Avatar
    I am running on Windows Vista 64-bit, with a 3G[S] on 3.1.2. I followed the instructions step by step from one of the posts here and Cydia installed correctly. Winterboard works as well. Only thing that doesnt work is something i cant say in Cydia (missing deposits), but oh well-- App Sync 3.1 works. :-)
    Nothing beats the iPhone.
    2009-10-12 07:00 PM
  6. liutszho's Avatar
    How do you blacklist winterboard?

    I'm no expert but what I did to get it work is install five icon dock first, then installed winterboard. But instead of rebooting, I pressed the homescreen button and powered off and powered on myself.

    Hope that helps.
    2009-10-12 07:01 PM
  7. akoik's Avatar
    Tried the 5 Icon fix, and it doesn't work either. Five Icon itself doesn't work. :0(
    Melanie
    2009-10-12 07:08 PM
  8. michada's Avatar
    you only have to do this if you have backgrounder installed. Tap the icon, then tap Application specific and after it opens put a check next to winterboard....
    2009-10-12 07:15 PM
  9. liutszho's Avatar
    Tried the 5 Icon fix, and it doesn't work either. Five Icon itself doesn't work. :0(
    Melanie
    Damn do you have mobile substrate installed?

    Maybe the backgrounder blacklist solution can help
    2009-10-12 07:31 PM
  10. janHR's Avatar
    I had Backgrounder and Winterboard and Winterboard wouldn't change any settings if checked. I uninstalled then reinstalled and got stuck in boot loop.

    Since some of you guys say that it works on 3GS and 3.1.2 I will try some of the ideas mentioned here.

    So:
    -Checking to see and blacklist it in Backgrounder
    -When done installing, turn off the phone, don't use the reboot option Cydia gives.

    Any other ideas or tricks?
    I would hate to lose another couple of hours doing another restore...
    Last edited by janHR; 2009-10-12 at 11:06 PM.
    2009-10-12 08:01 PM
  11. akoik's Avatar
    Oh yay! Got it working now! Total newbie error....wasn't doing a proper restore. Now off to play....
    Melanie
    2009-10-12 08:14 PM
  12. Town3r's Avatar
    what are the steps too getting winterboard working.

    I have a iPhone 3GS firmware 3.1.2.
    I normally sync with a macbook.
    but i used a windows 7 pc to use blackra1n.
    it said it worked.
    Blackra1n icon was there and i installed all the apps. Cydia, Icy, Rock
    Cydia did it's update thing but not sure.
    Installed Winterboard through Cydia and then a Complete Theme and a sound pack.
    Opened Winterboard selected the theme hit the home button it did the spinny circle thing and then nothing.
    Reopened Winterboad unchecked the theme and selected the sound pack files.
    This also didn't work.
    Not sure what to do now.

    Doing a restore n going to try blackra1n agian.
    Last edited by Town3r; 2009-10-13 at 01:28 AM. Reason: Automerged Doublepost
    2009-10-13 01:28 AM
  13. shaldi's Avatar
    if ur iphone 3gs is ver 3.1 n unlockable. after u restore to 3.1.2 it should be unlock also. but u must connect to internet always b4 n after restored. because it must connected to apple to send ur iphone info or wat ever. after unlock u will be able to blackrain it. mine successs with 2 3gs updated n blackrained. for ur info i use windows vista ultimate.
    2009-10-13 01:58 AM
  14. bays's Avatar
    my experience, in case anyone has the same issue

    -3GS, 3.1 out of the box
    -Jailbreak with blackra1n
    -installed cydia, icy, rock
    - installed winterboard- would not apply any themes or changes

    -restored / updated in itunes to 3.1.2
    -jailbreak again with blackra1n
    -installed cydia only
    -installed winterboard again and it works
    2009-10-13 02:55 AM
  15. kickstart23's Avatar
    i have seen some post that you should only download cydia first. then through cydia get icy..that what i did and i havent had a single problem with cydia or winterboard....
    2009-10-13 03:07 AM
  16. mommadee's Avatar
    I forgot to add you're not suppose to add all 3 (cydia,rock and icy) either icy or cydia because when you add all 3 it messes them all up.
    2009-10-13 03:26 AM
  17. manishkatiyar's Avatar
    Once I removed ICE and reinstalled Cydia and Winterboard, all my themes started working fine.
    2009-10-13 08:20 AM
  18. cervantes008's Avatar
    I am having tons of issues with after the Blackra1n. Winterboard not working, downloaded Cydelete, no icon, couldn't unintall Icy, Sbsettings not opening, downladed Pogoplank, not installing or opening. Just can't figure out anything. I have a 3gs 3.1, but don't know if I can restore to start fresh. Is it possible to restore with a custom 3.1 IPSW? Any ideas?
    2009-10-13 06:04 PM
  19. Town3r's Avatar
    yeah i did the restore to 3.1.2 using itunes.
    made it ra1n
    installed cydia and rock
    installed winterboard and it worked
    2009-10-13 06:06 PM
  20. l0k0's Avatar
    I installed a 3.1 custom firmware to keep my unlockable baseband. So far everything is up and running as usual. So i dont think its winterboard thats having the problems with 3.1. There has to be something else causing the conflict.
    2009-10-13 07:30 PM
25 12
LINK TO POST COPIED TO CLIPBOARD