1. savior_of_the_broken's Avatar
    Cydia was working then I downloaded 3 new repositories (They were between the letters A-D) and then when I was finished it closed out and I haven't been able to get in since that time.

    Does anyone know what I should do? Should I openssh and try to delete the repositories? Would that work? What is the folder where they are stored?

    I'm open for any ideas...
    2009-10-14 09:56 PM
  2. photec2's Avatar
    Same thing is happening to me,

    Mine says::

    Error: Database

    Encountered a section with no Package header
    2009-10-14 11:08 PM
  3. savior_of_the_broken's Avatar
    No one knows?
    2009-10-18 06:43 PM
  4. L00i3's Avatar
    You could try this. Not sure if it applies, but who knows?

    [FIX] Sub-process bzip2 has returned an error... - iPod touch Fans forum
    2009-10-18 06:46 PM
  5. savior_of_the_broken's Avatar
    Thanks L00i3 I went in and deleted the sources and I'm still being shut out of Cydia.

    Any suggestions?

    I followed another link and found this:

    "My Cydia was crashing every time it opened. I traced it to corrupt files in /var/lib/dpkg/updates. Deleting them fixed Cydia. I can't guarantee that will fix Cydia crashes but it has worked for several people who have asked the same question here recently.

    Here are a few methods to delete them.

    SSH into the phone and type "rm /var/lib/dpkg/updates/*" (without quotes) and hit enter. Delete the updates.

    Or:

    Open MobileTerminal on the phone and type "rm /var/lib/dpkg/updates/*" (without quotes) and hit enter.

    Or:

    Use the apps iFile or Discover from Cydia to browse to /var/lib/dpkg/updates/ and swipe the files then select delete, or in iFile select edit, check all the files, then tap the trash can at the bottom."

    I used the first method. It worked!! I'm back in Cydia!
    Last edited by savior_of_the_broken; 2009-10-21 at 04:35 PM. Reason: Automerged Doublepost
    2009-10-21 04:35 PM
LINK TO POST COPIED TO CLIPBOARD