1. Andynsb's Avatar
    Im trying to downgrade my phone to 3.0 version and I need to jailbreak it and unlock it after that. I cant get it to downgrade because of an error 1015.

    Help..
    2009-10-16 02:13 PM
  2. mkblade's Avatar
    Does the error appear after the restoring process or before it? Have u also tried in a previous version of iTunes (8.2)?
    2009-10-16 02:17 PM
  3. Andynsb's Avatar
    It happens 75% way done in the middle... of itunes is 8.2
    2009-10-16 02:28 PM
  4. mkblade's Avatar
    Hmm I easily dg my iPhone (2G) to 3.0 from 3.1.2 but I was running iTunes 9. U could try iTunes 9 too see if it has an effect…and usually if u get an error at the end of the process it means it was restored (we just don't see it) and in that case I just run quickpwn 2.2.1 and follow it's instructions in resetting the device
    2009-10-16 02:33 PM
  5. Andynsb's Avatar
    shoot me.
    2009-10-16 02:41 PM
  6. mkblade's Avatar
    1. Download and install iTunes 9
    2. Download and save firmware 3.0.1 on your desktop
    3. Open iTunes & shift+restore click and select the firmware you just downloaded
    4. During the process you might encounter that error (1015), just ignore it and close iTunes
    5. Run QuickPwn 2.2.1 and follow it's steps in the beginning in resetting your device
    6. After that's done, open iTunes and it should find your phone and continue with it's process of restoring from backup
    7. You should be finished with restoring now and be on fw 3.0.1
    8. Now download redsn0w 0.8 so that you can jailbreak it and just follow it's directions (Note: Since you will have 3.0.1 installed, when redsn0w asks you to select a fw choose firmware 3.0, NOT 3.0.1) and it will all be fine!
    Hope it helps!!
    2009-10-16 02:50 PM
  7. Andynsb's Avatar
    It doesnt give me the option to "backup" I have no sim card in it.
    2009-10-16 03:06 PM
  8. alvink83's Avatar
    Im trying to downgrade my phone to 3.0 version and I need to jailbreak it and unlock it after that. I cant get it to downgrade because of an error 1015.

    Help..
    You will get error 1015 from iTunes is because your iPhone baseband could not be downgraded.

    Firmawre 3.1 - Baseband 05.11.07
    Firmware 3.0 - Baseband 04.26.08

    Restore twice your iPhone 3G with firmware 3.0 and then jailbreak with redsn0w 0.8. You can't unlock as the ultrasn0w unlock only works on baseband 04.26.08.
    2009-10-16 03:58 PM
  9. Andynsb's Avatar
    restore twice? I get the error... twice...?
    2009-10-16 04:00 PM
  10. alvink83's Avatar
    Yes... You'll get the error twice...

    Em... May I know why you want to downgrade?
    2009-10-16 04:03 PM
  11. Andynsb's Avatar
    I cant unlock & jailbreak 3.1 but i can unlock and jailbreak 3.0
    2009-10-16 04:07 PM
  12. alvink83's Avatar
    I see... Once your iPhone baseband is updated to 05.11.07, currently there is no software unlock solution. You can only jailbreak your iPhone on firmware 3.0.
    2009-10-16 04:14 PM
  13. Andynsb's Avatar
    Im going to burn down the nearest apple facility!!!!! ARGH!HGHAGHG!HGAHG!
    2009-10-16 04:16 PM
  14. mkblade's Avatar
    downgrading is still possible whether its 3G or 2G..in case for the 3G you can downgrade but unfortunately your baseband will stay at 05.11.07..but if you want to have 3.0.x its possible and you can still jailbreak it...just cant unlock it, yet!

    It doesnt give me the option to "backup" I have no sim card in it.
    did you do atleast the previous steps...installing itunes 9, shift+restoring to fw, near the end of process it gives error 1015..then running QuickPwn?
    I have done the same steps on my 2G & 3G and its worked..
    Last edited by mkblade; 2009-10-16 at 05:22 PM. Reason: Automerged Doublepost
    2009-10-16 05:22 PM
LINK TO POST COPIED TO CLIPBOARD