1. ifruitfly's Avatar
    Please help! Complex, cannot restore jailbrokem iphone, even DFU fails. Error message at SAME point each time when itunes is “waiting for phone” half way through restore process

    I have been up all night (LITERLY) trying to find a solution, I have read a lot of the SAME stuff over-and-over-and-over again so I will try to make this as concise as possible.

    I have a 3GS running 3.1.2. I updated due to the ease of jailbraeking with blackra1n. So I jailbroke the phone a couple days ago, everything went smoothly and I had been having the time of my life, until…

    I downloaded NES and the same emulator for saga genesis. I also downloaded the ROMs for both of them. The NES would not open, the saga did open. I played sonic for a few minutes but the sounds were crackling. I decided to uninstall all 4 of the aforementioned packages from cydia to avoid any problems.

    While uninstalling NES, the iphone crashed and got stuck in reboot mode. (It is possible, that cydia was trying to give me a delayed error message for the “sinful source” during the uninstall. I don’t remember exactly). I finally figured out how to turn it off, but once turned back on, it goes right back to the reboot loop.

    I tried to restore it but itunes will not restore. It comes back saying “an unknown error occurred (9).” I have done nearly EVERYTHING the support page said to do. I have done nearly EVERYTHING the forums said to do, and nothing!

    I am running windows XP.
    -- I have used different USB wires and ports, even a hub, rebooted pc etc etc
    -- I have tried it in both reboot mode and DFU mode
    -- I know DFU is being done correctly because windows confirms this, and the log files from the failed restore do as well

    Here is what happens:
    -- The SAME thing happens REGARDLESS of how I try to restore, DFU, or not.
    -- itunes begins the restore process. It gets through the “preparing phase” just fine.
    -- Executing software, no problem. Verifying with apple; the screen goes white for about 30 seconds. (Are they bricking me?). Then it “prepares for restore”.
    -- At this point itunes says it is “waiting for the phone”. Now you can see the apple logo and a progress bar. The progress bar does not advance at all, and after five seconds the error message comes up.

    Because the exact same thing is happening at the exact same point, I don’t think uninstalling itunes or creating a new account will make a difference, am I wrong?

    Additional information and questions:
    I synced and backed-up two or three times after the jailbreak, most recently a few hours before the crash. I copied the backup file to my desktop. If I uninstall itunes, will I be able to restore from last backup?

    After jailbreaking, I changed the root and admin passwords via terminal as advised. Could changing these passwords from alpine be the problem? And if so, is there a fix?

    I live about an hour and a half from an apple store. I will happily go there if I have to, but would clearly like to avoid it... The phone is ‘still under warrantee’, well.. yah know... sorta… Of course I will not tell them I jailbroke the phone, but will they be able to tell? I wanted to wait for some responses before calling since apple doesn’t care if your phone gets stolen, but jailbreaking, that’s another story. Plus, I’m not exactly sure how to “call” them… Lastly, and most obviously, do any of you know what the problem is and how it can be solved?

    ANY advice, help, suggestion, insight, anything will be greatly appreciated!!
    2009-11-12 01:59 AM
  2. torturedsoul802's Avatar
    Well, assuming these problems persist, Apple shouldnt give you much of a problem about a replacement... Also, what steps are you using to start the restore? What custom firmware are you trying to load?

    8GB iPhone 2G
    Jailbroken 3.1.2 Firmware
    Winterboard Free
    Now with ANDROID Power!!

    HTC Dream (T-Mobile G1)
    Random Eclair/Donut ROMs
    CyanogenMod Recovery 1.4
    8GB Class 6 Transcend Micro-SD w/ A2SD
    Compcache w/ Backing-swap
    Haykuro's Danger SPL
    2009-11-13 08:27 PM
  3. Robcoffee's Avatar
    Keep trying with stock iTunes and stock iPhone firmware, if you can try a different computer (ie if you have a friend with itunes on their computer) but keep putting it in DFU and restoring again.

    Waiting for iphone for me seems to be when the processor gets stuck during a process and it can take some goes to kick it back out. Ultimately though this could well be a hardware issue and in this state I doubt whether any jailbreak could be detected by Apple so your best bet is to use your warranty and get a replacement - without Warranty I would keep plugging away at the restores but as you have Warranty get it swapped.
    iPhone 5s 64gb iOS 7
    rMBP 15" 16gb 500gb
    @c0ff33a and @PhoneMainiac
    2009-11-13 09:34 PM
  4. Staj's Avatar
    likely that the cydia app was not meant for 3.1.2 as most apps on cydia are not updated yet so maybe next time you wont try to pirate nintendo games.
    2009-11-13 10:56 PM