User Tag List

  1. iCherub's Avatar
    Here's the deal.. My iPhone 3G which I recently exchanged and activated by genius bar has a baseband 5.11.07 with firmware 3.1.2 version. I used the blacksn0w new jailbreak through the installation of the Blackra1n and everything seemed to be fine. When I changed the SIM from the supported original one to different one the carrier connect perfectly but the interface locks with the iTunes and USB cable picture and a message tells me that a Different SIM was inserted and iTunes shows me the same message when I connect to it. I tried Blacksn0w which presumably solve the new baseband problem. I tried several SIM that didn't work. My friends have the iPhone 3GS from same place I bought but they told me that in that Apple Store the iPhones are not locked to certain Carrier. One of the iPhones is jailbroken and the other not but when they changed to SIM to other they didn't have problem launching it.

    Why my iPhone 3G refuses any other SIM although its supposed to be unlocked from apple itself?
    Is there anyway to solve this without restoring the iPhone?

    I will appreciate it so much if I got help thanks.
    2009-12-20 12:48 AM
  2. kickercom's Avatar
    same problem jailbreak works .....and lock not unlocking

    2009-12-20 02:49 PM
  3. kickercom's Avatar
    same problem jailbreak works .....and lock not unlocking

    there has to be some that can help unlock?
    2009-12-22 11:14 AM
  4. sotexcustomz's Avatar
    any fix?? i just got another 3g on 3.1.2fw and 5.11.07baseband i need to unlock and jailbreak, any ideas??
    2010-01-06 03:00 AM

Tags for this Thread