User Tag List

  1. ibr4ke4iph0nz's Avatar
    Hi everyone! I have an insight for those of you that are having issues related to blackra1n and jailbreaking iphone 3g. Specifically if you are PC users on Windows.

    Having been an expert in IT and programming for over the last 12 years, I have seen my fair share of bugs, glitches, and downright horrible code. Blackra1n is a well intended program, but as with all code, it is not perfect. Well, I should rephrase, the code works well for its purpose but computers in general don't always 'play well' with others. I have found an issue that some of you will have as you go to jailbreak devices and can help you out with this simple advice.

    I am going to assume that you have done your homework and found a few troubleshooting tips such as killing processes with the exception of the AppleMobileDeviceService, and making sure that if you are running vista or higher you are setting the program to run in compatibility mode. All the other hold this, Airplane mode that, pray to the tree gods stuff is well intended advice, but not correct. If it works, it just so happens that your USB controller driver was cleared. The issue in fact lies within your USB controllers, not your phone, not a curse that your 4th grade sweetheart put on you for breaking up with them, and not the devil, well...maybe the devil!

    The Work-Around

    Quite a few people are successful performing their first jailbreak running blackra1n. If you are not, then I suggest simply changing the USB port you use and try again. Remember that if you are doing this from a multi-port hub, you must change the master cable's location, not just another port in the hub as all it's ports are sharing the same controller resources.

    Multiple Jailbreaks from the Same Machine

    If you are performing multiple jailbreaks, then you should listen up. Some people have no problems jailbreaking multiple times from the same port. I, however, was not that fortunate. After pouring through many forums and resources I found that switching the USB port worked well...But then I ran out of ports. So I experimented and found that if I deleted my USB controllers in Device Manager and rebooted, they would be found again and I could re-use a USB port to do multiple jailbreaks. I can only assume that caching, or bad code is causing this, but I am not sure and do not want to sound negative. I do know that this has worked for me and I have successfully jailbroke 35+ devices now without an error. As a matter of fact, if I perform these steps without err I am finished in 1 minute or less.

    I sincerely hope that this helps you and if it doesn't please feel free to post on here and I will do my best to answer your questions.

    Also thanks to Modmyi.com and the moderators who have really put together a great place to share and innovate ideas relating to these devices!

    -Jb
    "Computers are one of the most dangerous technological inventions - Well, next to handguns and tequilla!"
    2010-01-01 11:51 PM
  2. coagulator's Avatar
    thanks for the info, but i still got the black screen upon switching usb ports. you mentioned removing the usb ports from the controller, and restarting the computer. would this keep me from getting a black screen?
    thanks in advance!

    thanks for the info, but i still got the black screen upon switching usb ports. you mentioned removing the usb ports from the controller, and restarting the computer. would this keep me from getting a black screen?
    thanks in advance!
    Last edited by coagulator; 2010-01-08 at 02:31 AM. Reason: Automerged Doublepost
    2010-01-08 02:31 AM
  3. nikisweeting's Avatar
    I have a 2G iTouch model # is A1288. I recently upgraded to 3.1.3. It has never been jail broken before, how can I jailbreak it now? Blackra1n will get it to the black screen but it will never load geohot's image. Switching USB port doesnt work either.
    2010-03-18 08:21 AM
  4. whysoserious1's Avatar
    i have had this issues many times and what has worked for me most of the time is to re-run blackrain once or twice more in a row and then I get GeoHots pic on the screen.

    once or twice i have switched ports or just re-downloaded blackrain and its worked.

    I guess there are different variations as to why the black screen happens. I do agree though it seems that some of the back end code running Blackrain can sometime not want to play nice with computers
    Last edited by whysoserious1; 2010-03-20 at 07:17 AM.
    2010-03-20 07:14 AM
  5. nikisweeting's Avatar
    i got my itouch jail broken successfully by downgrading to 3.1.2, then using redsn0w to modify the ipsw. I have one slight problem tho, when I install openSSH via cydia i can connect to it remotely, but after authentication it gives me this error:
    NMBP:~ Nick$ ssh [email protected]
    [email protected]'s password:
    dyld: lazy symbol binding failed: Symbol not found: _login
    Referenced from: /usr/sbin/sshd
    Expected in: /usr/lib/libSystem.B.dylib

    dyld: Symbol not found: _login
    Referenced from: /usr/sbin/sshd
    Expected in: /usr/lib/libSystem.B.dylib

    Connection to 10.0.1.99 closed by remote host.
    Connection to 10.0.1.99 closed.
    -----
    is there any way to fix this without re-jailbreaking? I tried uninstalling and re-installing with icy and then rock with no success.
    2010-03-20 04:13 PM
  6. H3lpBlackra1n's Avatar
    @ibr4ke4iphonz:- ur post might just be the soln I need. Vista doesn't detect my device via USB. I ran blackra1n multiple times via same laptop all was well untill the USB was entirely useless for charging /sync. The laptop detected the phone only in recovery mode.
    Should I uninstall all the USB drivers(including hidden) from device manager; restart laptop and then connect the iPhone??? Will that fix the issue?? Lookin to hear from u soon.
    2010-09-12 12:15 PM
  7. nikisweeting's Avatar
    After finally jailbreaking my 2nd Gen 8gb itouch i highly recommend that you dont use blackra1n. There are many other ways to jailbreak iOS4 such as Redsn0w or JailbreakMe

    To fix your usb problem i suggest you put your ipod into recovery mode, restore it to iOS 4, then jailbreak it using one of the two options listed above.
    2010-09-13 12:53 PM
  8. warrenwiz5's Avatar
    I have tried all that you suggested, and I am still having problems jailbreaking my 2G iPhone.

    I am still getting the black screen as you suggest.

    I have even found other videos/suggestions to get it to work and it still doesn't go through:
    [ame=http://www.youtube.com/watch?v=w8UYSfPEKnQ]YouTube - How to Fix Blackra1n Jailbreak Problem iphone 3G/iPod Touch (No Boot Logo)(Windows)[/ame]

    I am open to videos, etc. to showing me how to fix this.

    Summary:
    I restore my iPhone to the latest firmware, I get the "Connect to iTunes" screen, and (because I want it to work with a T-Mobile SIM card) it tells me to plug in a SIM Card to activate my iPhone. Once at this screen, I try to run blackra1n, and it restarts, shows the Apple logo, then goes to the plug+iTunes logo, and then gives me a black screen while blackra1n tells me it finished successfully, though it obviously did not. It will stay at the black screen as long as it is plugged in, but once I unplug it, about 10-15 seconds later it will return to the "No SIM" screen.

    I've tried RedSnow and many others to no avail as well...

    Any help would be greatly appreciated.
    2010-11-22 09:56 PM
  9. iYeow's Avatar
    I have tried all that you suggested, and I am still having problems jailbreaking my 2G iPhone.

    I am still getting the black screen as you suggest.

    I have even found other videos/suggestions to get it to work and it still doesn't go through:


    I am open to videos, etc. to showing me how to fix this.

    Summary:
    I restore my iPhone to the latest firmware, I get the "Connect to iTunes" screen, and (because I want it to work with a T-Mobile SIM card) it tells me to plug in a SIM Card to activate my iPhone. Once at this screen, I try to run blackra1n, and it restarts, shows the Apple logo, then goes to the plug+iTunes logo, and then gives me a black screen while blackra1n tells me it finished successfully, though it obviously did not. It will stay at the black screen as long as it is plugged in, but once I unplug it, about 10-15 seconds later it will return to the "No SIM" screen.

    I've tried RedSnow and many others to no avail as well...

    Any help would be greatly appreciated.
    Blackra1n is not meant for 2g iphones, you should read this guide :
    How to Jailbreak/Unlock 3.1.3 iPhone 2G Windows & OS X
    Put your iphone into recovery mode : Turn it off, while holding the Home button, plug your iphone in until you see Itunes Cable logo comes out.
    Once you have restored to 3.1.3, run redsn0w 0.9.4 but browse to 3.1.2 ipsw , check only the box install cydia and unlocks. You will need BL 3.9 and BL 4.6
    2010-11-22 10:17 PM
  10. warrenwiz5's Avatar
    So the redsnow help was awesome, but now I'm having problems powering the phone down... apparently my power button is loose/shot.

    What can I do to help this along? I've been researching, but not as much as my previous 6 hours looking into how to get it unlocked, so I'll keep plugging around...

    Thanks for the help thus far! This is awesome.
    -Marsh
    2010-11-22 11:42 PM
LINK TO POST COPIED TO CLIPBOARD