User Tag List

  1. bannson's Avatar
    Recently I got my first iPhone, a 1st generation 8GB. The previous owner had broken it somehow so he just gave it to me. So far I have gotten it to boot on a jailbroken 3.1.2 to the springboard but this is where I am stuck.

    what I don't have:



    what I have:

    • root file system access
    • springboard
    • I can install jailbroken apps but I have to build them into a custom firmware with PwnageTool


    I have never gotten the "Repair Needed" message on the phone but I have gotten a message that says that a restore is needed whenever the phone is rebooted

    As far as I can tell from a good amount of searching is that the baseband is broken. From the 3 or [ame="http://www.iphonealley.com/forums/showthread.php?t=1936"]4[/ame] posts that I found where people had the same problems as me they were all running firmware 1.1.4 or something around there. Since I cant seem to downgrade past firmware 3.0 I don't know if I can use the solutions in in those posts to fix my problem

    So, is there a way to fix a broken baseband on a 1st gen iPhone running firmware 3.1.2 or have I misdiagnosed my problem?

    UPDATE

    I have managed to SSH into a command line of firmware 3.0 if that makes any difference. I have tried the bbupdater and iEraser that was the solution for this problem on firmware 1.1.1/1.1.4 but that doesn't work.

    Anybody know if BBUpdaterExtreme works on the 1st gen iPhone with the firmware 3.x baseband?
    Last edited by bannson; 2010-02-19 at 06:28 AM.
    2010-02-16 08:05 PM
LINK TO POST COPIED TO CLIPBOARD