1. dhamien's Avatar
    Hi dhamien,

    Yes, it has an old bootrom (FW3.1.2 / 7D11 / 05.07.11 / iBoot-359.3) and I used blackra1n to jailbreak it previously, if this information is useful

    I think my company network is preventing the connection. I am at home now and able to ping the server as well as obtain my .shsh from Saurik's server. Able to restore to the original 3.1.2 firmware now. At least I am seeing the chrome Apple logo now.

    I guess it's better not to update to 3.1.3

    Thank you, j3st3r3 and dhamien for your suggestions and patience.
    Good you're at least able to restore now. I personally used a pwnagetool made CFW on windows XP for my phone as well and it gave me 160x errors until I tried it without putting the phone in DFU or recovery mode. Maybe that's what went wrong. My phone was already jailbroken at the time, so if you want to try it, try jailbreaking at 3.1.2 with redsn0w/blackra1n and then shift-restore to the CFW with the phone turned on and booted fully and sitting on the homescreen (springboard). That's what worked for me.
    2010-03-30 03:21 PM
  2. boiwafu's Avatar
    Hi guys I really need help because I have little knowledge about iphone stuff since I just bought my first one.
    It has FW 3.1(7C144) and BB 5.11.07
    I didn't want to update it to 3.1.3 since there's still no jailbreak so I tried with a custom 3.1.2, then I had this 1604 error, then it was stuck in this itunes+usb screen. Then shift restore doesn't work anymore, the only option allowed was to update to newest version. Is there a way that I could just return to how it was in the beginning since I don't think I was able to update anyway. Thanks
    2010-04-17 07:45 PM
  3. dhamien's Avatar
    Connect your phone to your computer, then:

    Try exiting recovery mode by holding both power and home button until you see the Apple logo, then let go of both buttons immediately. Wait a second and then power on like you would normally.

    Alternately, you can try going to DFU mode first by holding both power and home button for 10 seconds, then let go of the power button but keep holding home button for another 10 seconds. From here, exit DFU the same way I just described exiting recovery mode.

    If neither of those work, try booting the phone with either blackra1n or quickpwn 2.2
    2010-04-17 07:56 PM
  4. boiwafu's Avatar
    neither recovery/dfu mode worked

    can i use blackra1n or quickpwn 2.2 to boot it even though it hasn't been jailbroken yet?

    and don't i need to update to 3.1.2 first or can i use with 3.1?

    blackra1n did the job. now it's back the way it was. thanks
    Last edited by boiwafu; 2010-04-17 at 09:11 PM. Reason: Automerged Doublepost
    2010-04-17 09:11 PM
  5. dhamien's Avatar
    neither recovery/dfu mode worked

    can i use blackra1n or quickpwn 2.2 to boot it even though it hasn't been jailbroken yet?

    and don't i need to update to 3.1.2 first or can i use with 3.1?

    blackra1n did the job. now it's back the way it was. thanks
    Good to hear
    2010-04-18 12:12 AM
  6. Rocky34's Avatar
    Good you're at least able to restore now. I personally used a pwnagetool made CFW on windows XP for my phone as well and it gave me 160x errors until I tried it without putting the phone in DFU or recovery mode. Maybe that's what went wrong. My phone was already jailbroken at the time, so if you want to try it, try jailbreaking at 3.1.2 with redsn0w/blackra1n and then shift-restore to the CFW with the phone turned on and booted fully and sitting on the homescreen (springboard). That's what worked for me.
    Hi dhamien !
    "wish you also had a Mac" (guess you will!)
    I see you kept the old bb but maybe you've got an idea whether CFW could get me out of tethering with the new baseband, or is there no concern ?
    I've bought this 3G S upgraded. Then downgraded to 3.1.2 (SHSH on file for 3.1.2/3.1.3), used Terminal to reboot, jailbroke with redsn0w.
    I have network and carrier.
    f0recast sez
    "Untethered jailbreak : Depends if it's refurbished"
    It's not!
    So I wonder if there's a way. Do you know what untethered JB depends of ?

    Cheers!
    2010-04-18 10:51 AM
  7. dhamien's Avatar
    No, unfortunately there's no way around the tethered thing. If you have it now, there's no tool that'll fix it. Supposedly there are actually quite a few exploits found that could change that but release is being held off by the devs for now. I don't know how long that'll be but one dev, p0sixninja, said he could almost guarantee that there'd be one this month. These things can change from day to day, so hope for the best but expect .. well less.

    As for what's causing it, it's the bootrom of the phone. An old bug, called the 24kpwn exploit, was used in the early 3GS phones but Apple has since updated the bootrom and fixed the exploit. The bootrom is a physical chip that cannot be up- or downgraded like the firmware can, meaning that if you have the old one, there's no risk of it being upgraded.
    2010-04-18 12:35 PM
  8. Rocky34's Avatar
    Hm, you basically confirm what I redoubted.
    On the other hand, I quite agree with the devs not to publish the solution right away (to my opinion they found out).
    Yes, they talked about the 24th of April a couple of days ago, I'll be patient whatever time it'll take.

    Good explanation.
    This 3G S is from week 43, bootrom 6.4 according to f0recast.
    It was just the "untethered"-mention that gave a little hope

    Thanx for your answer !
    Last edited by Rocky34; 2010-04-18 at 01:52 PM.
    2010-04-18 01:35 PM
28 12
LINK TO POST COPIED TO CLIPBOARD