1. walkman1990's Avatar
    ^^^ could i do what i planned or no?
    2010-03-25 05:41 AM
  2. j3st3r's Avatar
    try searching google for a custom 3gs 3.1.2 made with pwnagetool "not activated"..I have seen where alot of people have had trouble with ipsws made with sn0wbreeze

    if u update it thru iTunes 3.1.3 then u will be stuck with no jailbreak and no way to try and load a custom firmware since your 3.1.2 shsh's are not stored on cydia
    Last edited by j3st3r; 2010-03-25 at 05:50 AM. Reason: Automerged Doublepost
    2010-03-25 05:50 AM
  3. walkman1990's Avatar
    well looks like im pretty screwed tried it on a complete different computer and got the same errors.. if i cant find a custom firmware online tomorrow, looks like ill just restore it to the 3.1.3

    any other help would be greatly appreciated before i restore to 3.1.3 :/
    Last edited by walkman1990; 2010-03-25 at 09:12 AM. Reason: Automerged Doublepost
    2010-03-25 09:12 AM
  4. j3st3r's Avatar
    sent you a p.m.
    2010-03-25 03:18 PM
  5. walkman1990's Avatar
    pmed back! Any final suggestions from anyone if the custom firmware I download from online doesnt work?

    Thanks!

    FIXED!!! With 3.1.2 still on there, cyida,icy installed.. thanks so much

    A BIG BIG THANKS to J3ST3R3 for his help, definitely wouldnt have been possible!!
    Last edited by walkman1990; 2010-03-25 at 11:03 PM. Reason: Automerged Doublepost
    2010-03-25 11:03 PM
  6. mojof1's Avatar
    pmed back! Any final suggestions from anyone if the custom firmware I download from online doesnt work?

    Thanks!

    FIXED!!! With 3.1.2 still on there, cyida,icy installed.. thanks so much

    A BIG BIG THANKS to J3ST3R3 for his help, definitely wouldnt have been possible!!

    Hey dude,

    I'glad I found this post. Originally i posted in another thread asking how the guy restored his phone (cydia only has 3.1.3 saved for me on saurik's server) on 3.1.2 with old baseband. the reason I wanted to restore was because I've been losing signal frequently just the way you described it ever since i jb'd with blackrain (non-tethered).

    So having done what you did, did you get that problem fixed?
    Can you please please do a write on what you did and what it accomplished? I've been searching on this for the whole day. I'd really appreciate your help, thanks!!
    Last edited by mojof1; 2010-03-28 at 02:33 AM.
    2010-03-28 12:47 AM
  7. j3st3r's Avatar
    google and download a custom 3.1.2 ipsw created with pwnagetool (very important) and shift+restore to that...it will already be jailbroken when you are done..that simple
    2010-03-28 03:20 AM
  8. mojof1's Avatar
    google and download a custom 3.1.2 ipsw created with pwnagetool (very important) and shift+restore to that...it will already be jailbroken when you are done..that simple

    thx......... i saw that you've already posted the same thing a while ago
    that doesn't answer whether the op fixed the "no service" signal

    did you end up getting that fixed or are you just leaving it not jailbroken?
    2010-03-28 03:31 AM
  9. j3st3r's Avatar
    quote from walkman1990
    "FIXED!!! With 3.1.2 still on there, cyida,icy installed.. thanks so much"

    to answer the jailbreak question...when you restore to a custom firmware you are already jailbroken...that's part of creating the firmware
    2010-03-28 03:55 AM
  10. mojof1's Avatar
    quote from walkman1990
    "FIXED!!! With 3.1.2 still on there, cyida,icy installed.. thanks so much"

    to answer the jailbreak question...when you restore to a custom firmware you are already jailbroken...that's part of creating the firmware


    i see. thanks for clearing that up for me. So after reading the op's original post again, it sounds like it was Snow (unlocking from the carrier) that was causing the frequent "no service" problem?

    So i've downloaded a custom file made by pwnage from here

    Download Custom Firmware 3.1.2 IPSW – Jailbreak, Activate, Unlock iPhone 2G, 3G, 3GS [Mac and Windows] | iLikeMyiPhone

    and selected the one called "custom firmware not activated official carriers"

    if I haven't mistaken, when I doshift+restore from iTunes now, iTunes should give me an error since apple is not signing 3.1.2 anymore. how would I deal with that

    sorry for being so persistent and askign so many questions. i'm obviously a newbie here and really don't want to take any wrong steps to kill my phone.

    thanks again.
    2010-03-28 05:01 AM
  11. j3st3r's Avatar
    custom firmwares do not need to be signed so you shouldn't get that error
    2010-03-28 05:10 AM
  12. mojof1's Avatar
    custom firmwares do not need to be signed so you shouldn't get that error
    cool i'll try that and post back
    thanks again!

    Ok so i've done a restore via DFU mode... got the 1600 error, then got out of DFU mode and it booted up fine.

    i don't think that did anything though. all my data is still there and blackra1n icon still there. am i missing a step somewhere?
    Last edited by mojof1; 2010-03-28 at 08:12 PM. Reason: Automerged Doublepost
    2010-03-28 08:12 PM
  13. j3st3r's Avatar
    don't really know alot about blackra1n but when it is jailbroken using it the icon will stay there unless you delete it...if you have a cydia icon then you are jailbroken...
    2010-03-28 10:32 PM
  14. mojof1's Avatar
    actually there are no changes whatsoever. even my data remains intact which means the restore did not complete successfully. I think this has to do with 1600 error. Any other ideas?

    Also, if I want to do a restore so that my phone is in the state it was before any jailbreaking/unlocking is done, what would i do? Keep in mind that Cydia only has 3.1.3 firmware saved for me, and I would like to stay on 3.1.2. thanks again.
    2010-03-31 01:49 AM
  15. j3st3r's Avatar
    actually there are no changes whatsoever. even my data remains intact which means the restore did not complete successfully. I think this has to do with 1600 error. Any other ideas?

    Also, if I want to do a restore so that my phone is in the state it was before any jailbreaking/unlocking is done, what would i do? Keep in mind that Cydia only has 3.1.3 firmware saved for me, and I would like to stay on 3.1.2. thanks again.
    try doing the restore from the home screen..not dfu mode and see if that helps...also you can not go back to an unjailbroken state unless it is to 3.1.3 because those are the only shsh's you have....
    2010-03-31 03:40 AM
  16. mojof1's Avatar
    oh man.. so i guess I can't go into the apple store for service anymore if I want to retain the 3.1.2.

    I'll try the method you mentioned, thanks.

    my phone actually screwed up really badly to the point where it wouldn't function at all... it was just stuck at the apple logo

    however, after a couple of tries restoring via restore mode with custom non-activated fw, i managed to restore it properly

    thanks a lot for your help again j3st3r
    Last edited by mojof1; 2010-04-01 at 03:06 AM. Reason: Automerged Doublepost
    2010-04-01 03:06 AM
  17. j3st3r's Avatar
    oh man.. so i guess I can't go into the apple store for service anymore if I want to retain the 3.1.2.

    I'll try the method you mentioned, thanks.

    my phone actually screwed up really badly to the point where it wouldn't function at all... it was just stuck at the apple logo

    however, after a couple of tries restoring via restore mode with custom non-activated fw, i managed to restore it properly

    thanks a lot for your help again j3st3r
    no problem...glad it got some act right about it
    2010-04-01 04:36 AM
37 12
LINK TO POST COPIED TO CLIPBOARD