1. slickb0i's Avatar
    Hey guys,

    My name is Pete, I've been lurking around the site for quite some time. I currently have an iPhone 3GS running 3.1.2. SO, like most 3.1.2's whenever the phone restarts, it has to be plugged back into Blackra1n so it could get out of recovery mode. That's what I usually do and have been doing. I'm pretty good with JB'ing iPhones/iTouch. Anywho, my iPhone died last night so this morning (3GS) it went into Recovery Mode...no biggie. It has happened to me before, and the usual fix is to run Blackra1n again. So I hop onto my friend's Mac downloaded Blackra1n and ran the app. Then Geohot's logo comes up, and stays there for like 5mins the Apple logo comes up, and goes back into Recovery Mode WTF??

    I've looked online and everything but can't find a solution. I made sure my friend's laptop is a non-current version of iTunes. Infact, my phone froze last night and I had used the same computer to restart it and it worked fine. I've restarted the computer but no dice. I even used another laptop (Windows) and it still doesnt work. So far, I've tried 4 different computers and still no luck, if anyone can help me out, I'd appreciate it. Thanks in advance.
    2010-04-13 03:26 AM
  2. Zehlek's Avatar
    2010-04-13 03:35 AM
  3. slickb0i's Avatar
    Cool thanks man, I did everything the tutorial had said but till the part where it says, "now change your directory to
    c:/user/XXyour user XX/desktop/irecovery/irecovery_svn" what does that mean?

    Right before this, is the step to launch cmd prompt. Oh and I double click on iRecovery on my desktop it launches but then exits right away.

    Quick question for you guys, if I upgrade to 3.1.3, then I won't lose all of my contacts right?
    Last edited by slickb0i; 2010-04-13 at 04:29 PM. Reason: Automerged Doublepost
    2010-04-13 04:29 PM
  4. Owos's Avatar
    You won't lose your contacts if you synced your iPhone recently enough. You will lose the contacts that you entered after the last time you synced the iPhone though.
    2010-04-13 05:42 PM
  5. slickb0i's Avatar
    Yeah I get you, the only problem is that my last backup is from November..fml. I mean, I'm looking into data recovery apps but the problem with that is that I think it requires my phone to be working. Iunno, I might just have to restore it. So far I've tried:
    Blackra1n about 500x.
    Quickpwn about 10x.
    Different computers 4x.
    Youtube videos 5x.
    iRecovery 2x but can't figure it out.

    But nothing works, so it looks like I have no other choice. But I do appreciate the help guys, thanks.
    2010-04-13 10:37 PM
  6. tizzer's Avatar
    Rather than change the directory for irecovery just open a cmd prompt and drag the exe into it, type -s after the cursor and irecovery should open in dos. Enter the commands at the new prompt, it worked for me after a couple of attempts. Drives you bonkers though.
    2010-04-13 10:52 PM
  7. slickb0i's Avatar
    Tried that, cmd prompt window does not allow any thing to be dropped in.

    Ok, I tried dragging iRecovery icon from my desktop into cmd prompt and it worked on my Windows XP. But the only thing is that when I try opening iRecovery again from the desktop, it opens and closes by itself really fast. I'm lost.

    This is the stuff I see. I had to drop irecovery onto the C drive and rename it "r." Then I had to put this into command prompt: c:/r -s

    CUsers\Pete>c:/r -s
    iRecovery - Recovery Utility
    by wEsTbAeR-- and Tom3q

    Got USB


    =======================================
    ::
    :: iBoot for n88ap, Copyright 2009, Apple Inc.
    ::
    :: BUILD_TAG: iBoot-636.66
    ::
    :: BUILD_STYLE: RELEASE
    ::
    :: USB_SERIAL_NUMBER: CPID:8920 CPRV:15 CPFM:03 SCEP:03 BDID:00 ECID:000000
    2A3A0995CC IBFL:01 SRNM:[81942PPY3NP]
    ::
    =======================================

    [FTL:MSG] Apple NAND Driver (AND) RO
    [NAND] Found Chip ID 0x3294D79876 on FMI0:CE0
    [NAND] Found Chip ID 0x3294D79876 on FMI0:CE1
    [NAND] Found Chip ID 0x3294D79876 on FMI1:C8
    [NAND] Found Chip ID 0x3294D79876 on FMI1:CE9
    [FTL:MSG] FIL_Init [OK]
    [FTL:MSG] BUF_Init [OK]
    [FTL:MSG] FPart Init [OK]
    read new style signature 0x43313133 (line:375)
    [FTL:MSG] VSVFL Register [OK]
    [FTL:MSG] VFL Init [OK]
    [FTL:MSG] VFL_Open [OK]
    [FTL:MSG] YAFTL Register [OK]
    yaFTL::YAFTL_Open(l:2630): CXT is not valid . Performing full NAND R/O restore .
    ..
    [FTL:MSG] FTL_Open [OK]
    Boot Failure Count: 15 Panic Fail Cont: 0
    Delaying boot for 0 seconds. Hit enter to break into the command prompt...
    HFSInitPartition: 0x4fc44180
    Kernelcache image not valid
    Entering recovery mode, starting command prompt
    (Recovery) iPhone$

    And this is what I enter, but no luck:

    Entering recovery mode, starting command prompt
    (Recovery) iPhone$ setenv auto-boot true
    (Recovery) iPhone$ saveenv
    (Recovery) iPhone$ /exit
    Closing USB connection...

    CUsers\Pete>
    Last edited by slickb0i; 2010-04-15 at 05:55 PM. Reason: Automerged Doublepost
    2010-04-15 05:55 PM
  8. dr0herb's Avatar
    op, what version of itunes are you running
    2010-04-15 06:02 PM
  9. ricemast's Avatar
    i have exactly the same problem!
    I realllllyyy dont wana have to restore,
    there must be a fix,
    it looks to me like its running out of power before it can boot
    2010-04-15 08:48 PM
  10. vix2000's Avatar
    I wonder if this is anything to do with my problem. After official O2 unlock today my phone is stuck in restore mode and blackrain won't even run. I really dont want to restore to 3.1.3 but do I have another option?
    2010-04-15 08:59 PM
LINK TO POST COPIED TO CLIPBOARD