1. driverm's Avatar
    I have a 3G[S] which is sim locked. My OS was 3.1.2 and my baseband is 05.11.07 and I have an old bootrom. (iphone purchased on December 2th, 2009 and I have never restored it until then. I was using blackra1n for jailbrake and simunlock.

    However 3 days ago, after paying, downloading and installing an official app from itunes appstore, (app was Hipstamatic) my iphone restarted itself and stuck at apple logo. It was continuously restarting itself.

    I used Pwnage to jailbreak it again. I used 3.1.3 OS and pwnage successfully created the custom firmware. Btw, I checked "activate the phone" while creating the firmware from pwnage. At the final stage of creating the firmware, Pwnage tool asked me if my iphone has been pwned before. I had no clue about it, so clicked no, as it was being mentioned on the notice. Then it wanted me to connect the iphone to my mac, but it didnt recognized my iphone whether in recovery mode or in DFU mode.

    I exit pwnage and then installed the custom firmware by using itunes successfully. Iphone works great except its sim unlock. It wasnt Sim Unlocked! I tried installing Ultrasn0w from Cydia, but nothing changed! I also tried installing BootNeuter from Cydia, but whenever I tried to open it, the app gets stuck at "detecting device settings".

    A friend of mine told me I had to install blackra1n from Cydia. I installed it, and my iphone crashed! I had to reinstall custom firmware..

    BTW, I dont know if my iphone is tethered or not, but a week ago, before all this happened, I could normally restart my iphone w/o having to jailbreak every time.

    I actually donít need any jailbreak. If there is any chance of installing 3.1.2 without upgrading the baseband or bootrom, then I can use blackra1n RC3 to unlock my iphone.

    I m using my iphone for my business and I NEED THAT ALOT. Please please please help me on this issue, I need your help sooo much..

    Please help me

    Thanks alot...

    Twitter: twitter.com/pashalatzo
    Last edited by driverm; 2010-04-28 at 12:54 AM.
    2010-04-22 03:32 PM
  2. driverm's Avatar
    my problem has not solved yet. Please help mee....
    2010-04-26 12:16 PM
  3. z3r01's Avatar
    ok..now, if your iphone was jailbroken before , then that means shsh file was created for your iphone if you pressed it on cydia...so theoretically u can restore to 3.1.2 by pointing itunes to sauriks server. before attempting this use umbrella found in ih8snow website to determine if you do have an shsh file saved. if you dont, then restore to 3.1.3 using ur custom firmware and just install blackra1n...just make sure ur baseband wasnt updated to 5.12.01 because if it was then u cant unlock your iphone, just jailbreak it....
    2010-04-26 12:47 PM
  4. confucious's Avatar
    UltraSn0w wont work because your on the wrong BB.
    BlackSn0w from Geohot won't work because it is incompatible with 3.13 (despite the BB). This has been fixed by someone else and released as BlackSn0w RC2 which should work.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2010-04-26 12:52 PM
  5. driverm's Avatar
    blacksnow RC2 didnt worked either... It locked my iphone.

    So, I m looking for a way to install 3.1.2 stock firmware with Option + Click to Restore without upgrading the baseband or bootrom. Can I do that? Or bootrom or baseband will be upgraded if i dont use a custom firmware while doing that?
    2010-04-26 12:59 PM
  6. confucious's Avatar
    If you have your SHSH for 3.12 on file then just use Saurik's server and restore to stock 3.12 otherwise create a custom 3.12 FW.
    Your BB is still 05.11.07 isn't it?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2010-04-26 01:44 PM
  7. driverm's Avatar
    yes it is still 5.11.07

    BUT I dont think I have SHSH on the server. Because before all problems happened, I was using blackra1n. And after downloading the app from the itunes store, iphone restarted itself and stuck on apple logo.. couldnt do anything.. had to use pwnage to create custom firmware and install it with restore. AND i was using blackra1n jsut for unlocking.. I never installed cydia before.. NEVER..

    Any suggestions now ?
    2010-04-26 01:53 PM
  8. confucious's Avatar
    A pwned 3.12 should work.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2010-04-26 02:30 PM
  9. driverm's Avatar
    Hi

    A friend of mine has the same problems as me. Talked to him and learned some REALLY interesting ideas.. Please take a look and let me know if that sounds stupid or sounds meaningful

    First of all I want 2 remind u all that after restoring my iphone 3GS, 5.11.07, with pwnage custom 3.1.2 firmware, I couldnt be able to unlock my iphone. Installing blacksn0w from cydia or manually installing it.. All ended up to the stuck apple logo screen.

    kk, according to my friend, the problem behind my iphone is based on the "baseband". Before all the problems occured, I was using blackra1n for jailbreaking and blacksn0w for unlocking. But he is telling me that blackra1n is changing some static variables at the baseband and when I install custom firmware, it DOESNT RESET the baseband, soo it is why, everytime I install blacksn0w, I end up at the same stuck apple logo screen.

    Now, my friend is suggesting me to find a way for fresh install of baseband 5.11.07..

    most probably this will let me to solve my problems.

    Please let me know if this sounds like a very stupid idea or it really might be meaningful.

    Thanks lot.
    2010-04-27 01:24 PM
  10. dhamien's Avatar
    Sounds possible to me, though I'm not into the technicals about it. I know there's a command to specifically update the baseband although I don't know how to use it.
    2010-04-27 05:09 PM
  11. confucious's Avatar
    Manually flash iphone to 05.11.07 baseband
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2010-04-27 06:14 PM
  12. driverm's Avatar
    OMG OMG OMG IT WORKED

    thank u sooo muuucchhh CONFUCIOUS... This link may help ALOT OF PEOPLE.. Thanks again
    2010-04-27 10:13 PM
  13. dhamien's Avatar
    OMG OMG OMG IT WORKED

    thank u sooo muuucchhh CONFUCIOUS... This link may help ALOT OF PEOPLE.. Thanks again
    To avoid the problem in the future you should use blacksn0w RC2 instead of the original one.
    2010-04-27 10:16 PM
  14. driverm's Avatar
    I faced alot of problems during this situation, so I thought some people may learn sth from this walkthrough.. Here is what happened:

    I have a 3GS with 3.1.2 OS, 5.11.07 baseband and old bootrom. I was using blackra1n RC3 for jailbreak and for unlock, I was using blacksn0w. One day, I purchased Hipstamatic App from itunes store officially and installed it. After that, my iphone restarted itself in an hour and then stuck at apple logo. I tried to use iphonebrowser, iRecovery and all SSH tools to solve it, but couldnt succeed.

    After that I tried to create custom firmware with sn0wbreeze. I tried to restore my iphone with that firmware but itunes was giving me 1600 error while iphone was in Recovery mode and was giving error 2 while iphone was in DFU mode. Then, I read on blogs that i should use pwnage for creating custom firmware. According to them, pwnage was more reliable then sn0wbreeze. I created the custom firmwre with pwnage and installed it on my iphone successfully. It was working perfect! BUT I had to unlock it also!

    I tried adding "www.blackra1n.com" to sources of Cydia and install blacksn0w. iphone crashed and stuck at apple logo! Restore iphone again... Then I tried adding "cydia.pushfix.info" to sources and install blacksn0w RC2 FINAL. iphone crashed and stuck at apple logo again.. Restore iphone again too...

    One of my friends told me that when u install blackra1n and blacksn0w on iphone, it changes some static variable on baseband. If for any reason you have to install the firmware again, you cannot unlock it with blacksn0w because you dont have a "working" baseband now.. you have to reinstall it! you have to reinstall 5.11.07 on your iphone. I wrote about it on forums and one helpful person gave me a link about it. it was solving my problem at all! "tinyurl.com/34n2jdw" or "extechblog.wordpress.com/2010/03/23/blacksn0w-crashes-3-1-2-firmware-05-11-07-baseband-3gs-no-shsh-on-file-solution/"

    After doing what the blog post told me to, I added "cydia.pushfix.info" to the sources of Cydia and I installed "blacksn0w RC2 FINAL. I didnt reboot iphone, iphone suddenly worked and I could see my network provider's name on the screen.

    Here it is...

    If you need any help about this, you may always contact me from twitter @pashalatzo

    Thanks FEARtheSERVER, iH8sn0w, iHackinjosh, Confucious for their GREAT HELP...
    Last edited by driverm; 2010-04-27 at 11:42 PM.
    2010-04-27 11:38 PM
LINK TO POST COPIED TO CLIPBOARD