User Tag List

  1. DJ Hellfire's Avatar
    For months, I've been plagued with these issues after jailbreaking my 3GS (original release).

    1. Phone just randomly going to No Sevice or Searching on 3G.
    2. Phone goes to No Service immediately after sending MMS on 3G.
    3. Poor 3G performance at my house, even with 5 bars.
    4. SMS not sending on the first try, second, or third sometimes at my house and having to switch to Edge to send, even with 5 bars on 3G.
    5. About 10-15 seconds into a call, the call just fails and drops and phone goes to No Service on 3G, even with 5 bars no matter where I am at. Have to wait for service to restore then try call again. Usually fine the second time.

    As you can see, all my issues were happening on 3G. I tried restoring and rejailbreaking, as well as resetting network settings multiple times and still had issues. I've been on Blackra1n jailbreak for about the last several months, and Redsnow a bit before that. And I've read multiple places that Blacksnow was the issue. But I never used Blacksnow since I'm on AT&T, so I couldn't believe that was the answer. But the problem kept happening.

    Then I tried rolling stock for a few days and the phone worked flawlessly. So I knew it was Jailbreak related, and I was starting to believe it was Blackra1n, like I've read. So I tried jailbreaking with Snowbreeze and restored all my jailbreak apps with Aptbackup. Still happened again, yet Geo is being blamed. People were even saying he knows about the issue and refuses to address it, which I can't really believe.

    So then finally, I tried Redsnow yesterday. Once I restored to 3.1.2, I jailbroke with Redsnow and the phone was working fine, even after the jailbreak. So I'm like, yay, Redsnow. Then, as soon as I restored my jailbreak apps using RockApp restore, the problem started happening yet again.

    So now I'm thinking, it's not just jailbreak related, it has to be related to one of the apps. So I was gonna try removing apps one at a time to see if it would go away. I figured that since my problem was with 3G, I'll start with apps that "signal/reception" related. So I started with removing 3G Unrestrictor, and immediately, the issue went away. It's been fine, even at my house for over 24 hours now, on 3G. I've sent several MMS on the first try without going to No Service after. I've sent multiple SMS without them failing at all. All on 3G.

    So, if anyone is having similar issues and are using 3G Unrestrictor or the other app like it, try uninstalling it and see what happens. In the meantime, I'll report back in a few days to let you guys know if this is still working OK!
    Last edited by DJ Hellfire; 2010-04-28 at 01:29 AM.
    2010-04-27 06:02 AM
  2. Cory Gillmore's Avatar
    Thanks for sharing. I've experienced no issues with Unrestrictor but maybe some others are and this might help. Pretty interesting nonetheless.
    2010-04-27 07:05 AM
  3. prophetizer's Avatar
    oh man, i'm actually restoring as we speak and iv'e had similar issues, i just always assumed it was AT&T horrible service, since i first went to AT&T with the 3GS and had 3g unresrtictor on there within a day or so, if this is true, i really hope they fix it because there are so many times i really need that app. i guess i could keep my sprint mifi on me for the time being
    2010-04-27 04:08 PM
  4. dhamien's Avatar
    No issues for me with 3G Unrestrictor, but interesting for those that have.
    2010-04-27 04:12 PM
  5. prophetizer's Avatar
    well, i'm not saying this was causing my issue, maybe AT&T just sucks for me, but i'm going to try it out in some bad spots that i see daily for a week or so and not reinstall 3g unrestrictor
    2010-04-27 04:25 PM
  6. DJ Hellfire's Avatar
    So far, my ****'s been great since I took it off. We'll see though. It hasn't work this great jailbroken in a LONG time.
    Last edited by DJ Hellfire; 2010-04-28 at 01:28 AM.
    2010-04-27 09:53 PM
  7. mj0528's Avatar
    no issues with 3g unrestrictor here. This was actually one of my first JB apps I installed too. Not one issue other that the same ole at&t issue's that I had on 2 non-jb'd phones.
    2010-04-28 02:33 AM
  8. qnc's Avatar
    What vervion of 3G Unrestrictor are each of you using?
    Is it version related I was about to download this app.
    2010-04-28 05:36 AM
  9. DJ Hellfire's Avatar
    I was using whatever the latest version is. Always have.
    2010-04-28 06:00 AM
  10. prophetizer's Avatar
    well, i see no change with a fresh firmware install. i'm wondering if you set 3g unrestrictor to watch a program that it doesn't need to, and that was interfering.
    2010-04-28 07:00 PM
  11. DJ Hellfire's Avatar
    I only set it for the app store, slingplayer, and skype.
    2010-04-28 07:03 PM
  12. OpenIntro's Avatar
    FWIW, I have had the IDENTICAL problem as OP and I don't have 3G Unrestrictor installed on my phone :/
    2010-05-05 05:18 PM
  13. DJ Hellfire's Avatar
    Mine is still working fine. Although I had to restore two times since then. First time was because all of a sudden the phone would not sync to iTunes. Second one was because of Rock. Rock told me there were 5 updates, and they were stuff I didn't even know was on the phone. So I updated. All the updates failed and said something along the lines of "...firmware failed to install..." and after a reboot, the phone would not turn on. It was weird because now that I have restored again, those updates are not coming up in Rock now. It seemed like a hack or virus or something. Definitely weird.
    2010-05-05 05:52 PM
LINK TO POST COPIED TO CLIPBOARD