1. KwestJones's Avatar
    IGNORE ME, I'm AN IDIOT. DFU MODE WORKS JUST FINE..

    Man, this week has been a killer for me.

    The Current State of my iPhone:
    When I turn it on (I used redsn0w 0.9.4 to jailbreak and chose to see verbose logging) I get the Apple logo and in the logging the last thing you see is 'fsck failed...' and then the screen goes black. The battery is dead (yeah I shoulda charged it earlier but I was watching the game) and it won't take a charge. I have one of those car chargers that when it is charging the ring is orange and when its not charging the ring is green. Despite the fact that I have my dead iphone plugged in, it isn't charging. It will charge when I turn it on, but as soon as it says fsck failed...it stops charging.

    The history...(and its long but it may be helpful)
    Its a 32G Black iPhone 3GS with SHSH files on saurik's server for 3.1.2 and 3.1.3. (shout out to saurik)
    It was jailbroken by the original blackra!n (Shout out to geohot).
    I do also have applecare but with the logs running at bootup I'm not sure they'll take it back.

    I had one too many task managers (Kirakae, mQuickDo, Activator, maybe more, I felt the need to manage my tasks) and my phone got REALLY slow. I figured I needed to start over and apparently in all my reading I missed the warning that you should not reset everything through the apple menus. So that's what I did.

    Needless to say the phone never came back. I struggled with DHU mode for awhile too. (If you are dumb like me, when you hold the Power and Home button key, the Apple Logo will disappear, count to 7 and let go of the power button). After I got through that struggle, I was not able to restore my phone to 3.1.2 easily.

    To make a long story short, after 35.5 tries this is what worked for me.
    DHU Mode
    Restore to 3.1.3 through the traditional method.
    Restore to 3.1.2 holding the shift key and restore. (it will fail)
    Restore AGAIN to 3.1.2 holding the shift and restore. (it will fail)
    Jailbreak with redsn0w 0.9.4 (it will fail)
    Jailbreak with blackra!n (it will work)

    I got the advice from here.

    This was helpful too.

    Hallelujah! I was back after 6 days of horror. I installed rock and recovered my jailbroken apps. Restored my music, movies, and apps from the AppStore and was happily about my business. All was well. I could reboot, respring, and do everything I used to do. I considered spirit but decided leave well enough alone.

    So last night after using my iphone for every (games, phone, music [feel'n that Sade...Soldier of Love], the battery was low but like I said above I was watching the Cavs get a beatdown (where were you LBJ?) I let the battery die. In hindsite, BIG MISTAKE, so I run upstairs throw it in the charger. The battery with the redline appears so I go about my business. When I return to check on it its off again. So I watch it. I put it back in the charger, the apple logo pops up and log screens fly by, and then off. I later discover that fsck has failed and that it won't charge.

    I know there are alot of words on this post but now its dead and I was hoping someone would have some insight on what I can do next.

    I can't use iRecovery or any other post boot operation because the battery continues to die before it boots.

    Is there any other way to get it to charge? Can I force it to remain off while it charges?

    Thanks for any insight.
    Last edited by KwestJones; 2010-05-04 at 04:27 PM. Reason: I'm an idiot
    2010-05-04 03:52 PM
  2. yomommah's Avatar
    i had the same problem after i installed iacces for 3.x (piece of crap!!!)
    toss it into recovery mode and it should charge but you have to keep an eye on it since itll automatically turn off after a while (like 20 min i think)
    also if anyone knows a fix without doing a restore post it please!
    2010-05-06 02:58 AM
LINK TO POST COPIED TO CLIPBOARD