1. rilloteddy's Avatar

    In some kind of "desperate" mode, I guess, I ran blackra1n to try to kick it out of recovery-mode. This after I used the redsnow 2 fix. Before, when my iPhone was up 'n runnin, I was tethered and had to run blackrain everytime I rebooted (before the "unholy" rock/cydia update). I thought running blackrain might kick it this time as well.
    It did not went well! lol

    The result was that the iPhone got stuck in some kind of bootloop with spinning wheel on blackscreen to apple logo with bar for a few seconds then back to spinning wheel.
    I had to force the Phone into recovery-mode again.

    I ran iRecovery and this is what I got:

    (Note the non encouraging line
    "yaFTL::YAFTL_Open(l:2630): CXT is not valid . Performing full NAND R/O restore ... ")

    [FTL:MSG] Apple NAND Driver (AND) RO
    [NAND] Found Chip ID 0x3295DE987A on FMI0:CE0
    [NAND] Found Chip ID 0x3295DE987A on FMI0:CE1
    [NAND] Found Chip ID 0x3295DE987A on FMI1:C8
    [NAND] Found Chip ID 0x3295DE987A on FMI1:CE9
    [FTL:MSG] FIL_Init [OK]
    [FTL:MSG] BUF_Init [OK]
    [FTL:MSG] FPart Init [OK]
    read new style signature 0x43313133 (line:375)
    [FTL:MSG] VSVFL Register [OK]
    [FTL:MSG] VFL Init [OK]
    [FTL:MSG] VFL_Open [OK]
    [FTL:MSG] YAFTL Register [OK]
    yaFTL::YAFTL_Open(l:2630): CXT is not valid . Performing full NAND R/O restore ...
    [FTL:MSG] FTL_Open [OK]
    Boot Failure Count: 5 Panic Fail Cout: 0
    Delaying boot for 0 seconds. Hit enter to break into the command prompt...
    HFSInitPartition: 0x4fca8480
    Kernelcache image not valid
    Entering recovery mode, starting command prompt
    (Recovery) iPhone$

    But hey, maybe it's some useful information in your quest to conquer the rockapp mega-fail?

    As an architect and designer I can share some knowledge and insights on a few things! LOL

    *High ceiling spurs creative thinking!
    *Work preferably in daylight with large window(s), if night-time use a WELL lit room, around 1000lux.
    *Cushioning floor makes u feel more relaxed. Use a carpet!
    *You think better when you lie down.

    2010-05-15 03:42 AM
  2. tonhe's Avatar
    iBeej I'm a bit confused.. I don't see any download links here for the software...
    2010-05-15 03:49 AM
  3. rilloteddy's Avatar
    Hi Tonhe!

    Page 12:

    REDSN0W FOR MAC FIXED AND UPDATED!!! OH and the USR/SBIN version is up too!!!! Read on...

    As promised, I tested the redsn0w package I uploaded last night and I ran in to the problem you guys were talking about. Apparently, redsn0w doesn't handle a large payload very well, so it crashes.

    I uploaded the standard /sbin package again, so if anybody experienced the crashing issue, please download the app again. Furthermore, I patched in the /usr/sbin fix to see if this kicks the rest of you guys through the boot process. Yes, it's kind of annoying needing to run both, but it's worth a shot for those of you who didn't have success with the first go around.

    1.) Click here to download the redsn0w /SBIN PATCHER

    2.) Click here to download the redsn0w /USR/SBIN PATCHER (NEW!)

    Those two packages pretty much sum up the entire contents of diskdev-cmds, so any problems beyond this, is something worse. If it's kernel related, I will need to get diagnostics info from you and start figuring out why THAT is happening.

    AS for the WINDOWS PATCHER, I have 3 different solutions:

    1.) redsn0w disassembled version for windows. Sort of not working lol

    2.) The tested blackra1n disassembled and reassembled version for windows. Works, but dealing with a possible payload size problem, so the phone isn't receiving it.

    3.) You guys will be shocked to hear this. But I have already started a new project from scratch, borrowed the payload exploit file from blackra1n, and coded a windows jailbreak program from scratch! So far so good, and I have it using the newest libusb which fixes a huge mess of problems you saw in programs like iRecovery. It's a simple MFC app right now with the sole purpose of fixing /sbin;/usr/sbin but it's easy enough to expand it's capabilities in the future after this is all said and done. Since I have come this far with it, I might just code some recovery features in to the program later on.

    Sorry for slow responses today... busy work schedule and I have been working on it nonstop since I left the office. It's almost 4am, and it's WAY past my bed time. (Again... you guys need to remind me to sleep)


    I gotta say, the redsn0w MAC patchers work awesome. Every single night, I screw up diskdev-cmds and arbitrarily delete the binaries from /bin and /usr/sbin to break my phone just like the rest of you. I patch it every night before bed so my alarm works and I have a phone at work lol. So it's definitely a huge success where sbin is concerned.

    However! I updated packages from Cydia yesterday and it borked my phone in a different way. It would BOOT but never load the Springboard, sit at apple logo for 5 mins and then reboot. Again, I posted instructions on the site about this, and THIS problem is related to DYLIBs in the /Library/MobileSubstrate/DynamicLibraries folder. I'm getting really ticked off with all of these problems from Cydia/RockApp lately. As it stands right now, I have all of my DYLIBs moved out of the folder so my phone would work. I don't have time to deal with it because I'm working on the FIRST thing they screwed up. One problem at a time Saurik and Rock, thank you.

    Oh and briefly..... I have pretty much made it my mission to have a windows SOMETHING working on Friday. It's the weekend and I'm sure you guys would really like your phones working even more. I'm just going to bust my rear to make this happen. So just know, once again, im pretty damn serious about this.

    Good night.

    2010-05-15 03:58 AM
  4. nigel99's Avatar
    Redsn0w2 app–everything seems to be patching normally but on reboot the phone is still suffering the same apple logo to auto off.

    When I try patching the updated redsn0w app it crashes as it starts to patch unless I un-check install cydia.

    In verbose boot I get fsck failed and shutoff

    keep up the good work.
    2010-05-15 03:59 AM
  5. tonhe's Avatar
    Thanks! I found his blog and tried the app he had posted there.. but as soon as I told it to do its thing.. it just exited..

    I'll try both these versions

    As for the /sbin version -- it exits, just as nigel99 describes above..

    I'm currently trying the /usr/sbin version...and same issues.. my phone just powers off..

    After restarting the process and doing a verbose boot... I too see that I have fsck failed....

    Any suggestions?

    I should probably include this info...

    My phone is a 3g, running 3.1.2, JB using PwnageTool, not unlocked.
    I'm on a MBP running OS 10.6.3

    I've attempted to modify the modified payload.. removing /bin from one run, and /usr/bin from another to lower the payload size.. and it runs that way, but doesn't correct my problem. Still getting fsck failed. I might just start from scratch, but that means losing a bunch of photos.
    Last edited by tonhe; 2010-05-15 at 05:30 AM. Reason: Automerged Doublepost
    2010-05-15 05:30 AM
  6. iBeej's Avatar

    I successfully completed the disassembly/reassembly project using redsn0w for Windows. It's done, and it runs. Now, here at the concerns. It seems a few of you are experiencing issues with crashing. I don't like hearing this, as it was working great before I added the additional binaries. So the success stories since yesterday have stopped. I am removing the current MAC redsnow from the site temporarily so I can iron out the issues.

    The question is whether or not the windows version is going to work for everybody. Maybe some people... but I guess there are some unknowns on how redsn0w ITSELF handles the jailbreak. So it's not so much the problem of my payload, which i KNOW works awesome... it's now back down to typical jailbreak woes.

    This is why I spent time working on my own jailbreak from the ground up with C++. I am able to avoid the "unknowns" from other developer's software. To be honest, I wish I could have gone faster with that solution, as it's my preferred method of delivering this to you guys. Really, all I want is a robust and highly successful patcher to this problem.

    The REALLY BAD NEWS is, my redsn0w crashed in one of my tests, and it is doing what some of your phones are doing. Endless reboot. This is actually good news in the way that I can test it thoroughly. But here is the funny part... my problem is so far worse than anything I have heard of... because I absolutely cannot put the phone in to recovery mode!! rofl. And yes, I have pictures of my kids on there I never backed up. I did this on purpose, even when intentionally breaking it because it provides "motivation". I have no doubt in my mind I can pretty much fix anything when I put my mind to it, but it's kind of hard fixing something when you can't get in to recovery. DFU, fine yes... but I can't jailbreak from DFU.

    If any of you have run in to this problem before and have any light to shed on the mystery, let me know. I haven't been able to research it because I was working on this windows patch.

    Anyway, as promised, it is finished. Is there anybody online right now who has the SHUT OFF problem who can test this. I want to see it work before I go posting it. You can add me [email protected]

    Please only add me and msg me if your phone is SHUTTING OFF after 7 seconds during boot. The STUCK logo or endless reboot problem truly is a totally different problem, never MEANT to be rectified by the solutions outlined in this thread. But since I was already at it... I have offered to take a look in to this problem as well, because i'm in the position to more than likely provide a fix for that as well. The goal was to focus primarily on the /sbin patch, and then investigate the stuck logo/reboot loop next. and I think we are just about there.

    Anyway, I have redsn0w 9.0.4 for Windows reassembled and it contains /sbin AND /usr/sbin. So anybody with the SHUT OFF problem, please add me and let's test this out!

    Last edited by iBeej; 2010-05-28 at 08:53 PM.
    2010-05-15 05:47 AM
  7. xpate's Avatar
    You are aware of this?:

    Originally Posted by n1ckn4m3
    I was able to fix my issue, though I didn't use the method above. I downloaded his version of redsn0w and pulled the Cydia.tar.gz out of it, then extracted the \sbin folder in the archive to my iPhone using SSH. Once that was done, I SSH'd to the phone AS ROOT and did the following:

    apt-get update
    apt-get upgradeIt complained that I didn't have two required packages for one of the installed apps (Cydia), the two packages that Rock destroyed, and recommended I run an apt-get command to fix that (I hate to say I don't remember the precise command, but it told me what to do, so it'll tell you what to do as well if needed). I ran that command and then re-ran the commands above, and that resolved all of my issues.

    To tempt fate, after all was done and I uninstalled Rock, I did a hard power cycle on the phone -- and it booted right up normally. So the poster at SpaceSpark is correct, that is the reason this is broken, and his solution will work to fix it.

    Maybe his solution should be extended to run one time only script that runs the apt-get commands you mention the first time the iPhone boots.

    from here: iPhone 3GS 3.1.2 won't start - Hackint0sh
    2010-05-15 06:38 AM
  8. lexluthorx3's Avatar
    hows the windows fix?
    2010-05-15 06:52 AM
  9. CarlieQ25's Avatar
    He is currently working on it and testing it with a couple of people as I type. He is super "in the zone" though, so I can't actually talk to him to get a report. All I can say is that he is talking to himself in major nerd language that makes no sense to me and is typing frantically while also testing with some people through msn.
    2010-05-15 06:57 AM
  10. lexluthorx3's Avatar
    thank you Carlie for that quick update. im so excited to see my iphone working again.
    2010-05-15 07:28 AM
  11. CarlieQ25's Avatar
    I completely understand lex. I am madly in love with my iPhone and going a week without it while BJ worked on it was torture.

    He is still working away, talking to himself, typing and collaborating with forum people on msn. I will try to keep you all posted until I go to bed.

    I'm sure you are sick of hearing this, but he is close. He is just "right there". He has a working executable with a few people testing it right now. He is just trying to add a package to the executable without having to resize it.. Or something like that. It's all Greek to me.... He said it's just off by a few kilobytes.... Like I said, he is just talking to himself and it all makes no sense to me as I am not a nerd.
    2010-05-15 07:46 AM
  12. lexluthorx3's Avatar
    i'am refreshig this page every 2 minutes. cant wait to try the fix on my iphone.
    2010-05-15 07:53 AM
  13. faithless-1's Avatar
    I just encountered another problem, this tuesday I got a brand new computer from the insurance company cause they couldn't repair my old one. This one has Windows 7 and the problem is that now when I try to connect the iPhone after installing itunes it seems not to recognize that my iPhone is in recovery mode and neither does it recon DFU-mode. According to the driver install it is a Apple Mobile Device, which I am quite sure is not the case. Has anyone else experienced this, if so please tell me how you solved it.

    My first thought was that since an iPhone has never before been connected to this computer, trying to connect a broken one might give the not completete description of the device.

    Okay, I've found the problem. It simply didn't work in my USB 3.0 port, too easy
    Last edited by faithless-1; 2010-05-15 at 08:24 AM. Reason: Automerged Doublepost
    2010-05-15 08:24 AM
  14. javsay's Avatar
    Did you try redsn0w2?

    It went through the entire jailbreak successfully, the phone restarted and crashed at the apple logo for me. That's a step farther than I got with the patched version of redsn0w, so give it a try.

    I just downloaded the version which was on "http://www.spacesparkstudios.com/". I presume the link on that page is still for redsn0w1. I tried to use the link on page 12 of this thread to download redsn0w2 "2.) Click here to download the redsn0w /USR/SBIN PATCHER (NEW!)" but it doesn't work anymore. Where can I download the newest one - might as well test it out, any new info (e.g. diffrent results) might help iBeej. Anyway thanks!
    2010-05-15 09:43 AM
  15. ayeayre's Avatar
    i think he took it down, not sure but, read his previous posts, should explain..
    2010-05-15 10:25 AM
  16. iBeej's Avatar

    Hello again folks! It's the time you have all been waiting for. I have updated the locations and am now versioning the changes. Between two different platforms and all the work going in to this, I need to keep track of it all.

    I have put my heart and soul in to this. I hear all of your stories and I work on this as if it were my data too. I have seen a track record of success stories from the mac users, except for the recent updates. But I have to remind you, while this first release is exciting, I can't be sure what the success rate will be due to the large number of variables involved. Jailbreak used, phone hardware, firmware version, whether people used cydia, rock, which packages they installed, and the list seriously goes on and on. So go in to this open minded. Let's nail it down one step at a time.

    I need as much information as possible. Any data, logs.... anything that will help troubleshoot this going forward. Let's work as a team to come up with ways to get this critical data.

    The packages released today are called "DCC" short for diskdev-cmds. These packages are SPECIFICALLY targetd at the basic structure of this package. (This is the package RockApp screwed up. At least one of them.. I am starting to wonder if system-cmds is a missing link in this) So going forward, there will be additional packages. The hard part, disassembling code, is done and the rest is building specifically targeted payloads depending on data we can come up with.

    If you want to be a help to this whole thing, then going out and finding ways to retrieve debug,syslog information from the phone during boot time will help immensely. Let's find some utilities to make that happen.

    Meanwhile, I will be working on creating new payloads and will continue going from there. Furthermore, I still have my custom jailbreak program and I intend to build a recovery toolset with it. Especially a way to retrieve syslog. So I will also be working on this going forward. And of course, I will work with a lot of you one on one, provided you can contribute as much information as possible so we can construct an idea of what's occuring with your phone.

    The packages released today are perfectly constructed. There are NO differences between the Windows and Mac version (unless it's something internal to the code, which I probably haven't messed with, as I duplicated my efforts for each platform) In fact, both the windows and mac version use the exact same payload. They are built pretty much like the mac version was. I would say I have seen 20 people who have successfully recovered from this, using my mac patcher. But still a lot of other problems being reported.

    Let's make that very clear right now. There is a HUGE difference. These fixes were never intended to deal with the reboot loop, as the common and generally only symptom from the RockApp condition was a SHUT OFF during boot. NOT a reboot. I wont rule out the possibility of a reboot loop being a part of this... in fact i'm sure it's the effect of the same thing, but a totally different internal system problem I haven't been able to determine yet. So this thread sort of turned in to a blend, and it has been very hard keeping track of all of it. So while these initial releases are targeted specifically at the SHUTDOWN during boot, i'm already working on figuring out the boot loop... which strangely seems to occur after applying these fixes for some people. This is indicative of a secondary problem that needs to be dealt with before the phone properly works again.

    I have heard reports from the testers working with me that some saw a quick blurb about "fsck" failing. This is a bit puzzling, because that is one of the primary binaries my patcher is fixing. So turn on your verbose, anything that shows information during the patching process and/or boot process. fsck is a little bit more complicated than a single binary. So I have my theories there may be some supporting binaries that I may need to build in to the package, retest, watch logs, and try again.

    With all of that said, I apologize for the lengthy post, but I feel it helps keeping the lines of communication open so we are all clear. Here are the packages:

    WINDOWS v0.1 - "forked" redsn0w 0.9.4
    5.15.2010 3:40AM : Download Package b33jsn0w-ddc-0.1-win.zip

    MAC OSX v0.1 - "forked" redsn0w 0.9.4
    5.15.2010 3:40AM : Download Package b33jsn0w-ddc-0.1-mac.zip

    Good luck, and keep me posted! Can I go to bed now?

    Last edited by iBeej; 2010-05-28 at 08:52 PM.
    2010-05-15 11:42 AM
  17. Copyrighted's Avatar
    Well, first i want to say than you for all ur great efforts, you are GREAT!

    I tryed the b33jsn0w for windows but my phone is still stuck in iPhone logo, it stays about 4 mins. in Aplle logo and then restart again.

    Best Regards!
    2010-05-15 12:07 PM
  18. javsay's Avatar
    Well, let me just say good effort on compiling a windows version! Just tried the windows version but sadly, the iphone still shutsdown after 5 sec, i'll try the mac version in a bit. (Redsn0w worked, uploaded jailbreak data etc but still shutdown)

    Firmware 3.1.2 Iphone 3GS - old boot loader

    Still though cheers!
    2010-05-15 12:08 PM
  19. iBeej's Avatar
    Thanks for the quick feedback. This sounds like fsck is not doing it's job. I need to determine if this is a problem with certain people or a fundamental missing component in the payload. If it's the latter, then we move on to the next version. What helps me right now is DATA. No matter how nerdy it is. It speaks my language. So BE VERBOSE!

    If more binaries need to be included, I will most likely be moving really fast now that I got the hard stuff out of the way. Could see frequent updates. I will most likely post another update tomorrow...errr.. technically today. God I just need some sleep. So a few hours?

    Last edited by iBeej; 2010-05-28 at 08:51 PM.
    2010-05-15 12:19 PM
  20. brattygirl72's Avatar

    OMFG!!! Dude, my phone is working and all my data is on the phone!!! Thank you so much!!!!!! First thing I will be doing is deleting my RockApp! Good luck guys and gals! I hope you get your phone working today too.
    Please check your account for my donation.


    2010-05-15 12:20 PM
983 ... 91011121321 ...