1. Tryzik's Avatar
    It seems that there are many of us that are running the DDC patch and are going from the 7 second shutdown to the 7 second reboot loop. Any idea why this might be happening iBeej?

    The verbose boot is going by too fast for me to read any error message. Is there any way we can help to give you more information on this to get a fix?
    Sorry hear about your job situation. Sometimes these things work out for the best. I'm sure something bigger and better is waiting for you just around the corner for someone with your talent.

    I'm not sure if they'll help in the slightest in the next fix but just in case, here are the last few screens of the iphone verbose boot before it reboots. The last image should be the last screen that is displayed before restarting. Thanks again for all your help!









    2010-05-19 01:26 AM
  2. KublaKahn's Avatar
    Hey Tryzik,

    Thanks for posting the screenshots hopefully that helps out. Looks like assembly code.. yuck.

    Anyways, I was curious if you accidentally ran redsn0w with the wrong IPSW at any point?? The shots look like kernel trouble to me (but what do I know).
    2010-05-19 01:32 AM
  3. olcho's Avatar
    After several unsuccessful tries do run the windows fix, I finally managed to run the MAC fix and it worked like a charm. Thank you very much for all your efforts! I sent a modest donation - no one should be working for free, especially when you're helping so many people. Thank you again!
    2010-05-19 01:51 AM
  4. Tryzik's Avatar
    Hey Tryzik,

    Thanks for posting the screenshots hopefully that helps out. Looks like assembly code.. yuck.

    Anyways, I was curious if you accidentally ran redsn0w with the wrong IPSW at any point?? The shots look like kernel trouble to me (but what do I know).
    I'm almost certain that the iPhone has 3.1.2 and that's definitely what I have been using when applying thre b33jSn0w fixes.

    There seem to be quite a few people who have posted in this thread with the same 7 sec reboot problem. Could we really all have applied the wrong firmware?
    2010-05-19 02:06 AM
  5. spooky655's Avatar
    After a failed attempt to fix my iPod Touch 2G using the windows b33jsn0w, I finally got a hold of a mac and tried the mac fix.

    My iPod is now in the reboot loop (apple turns to white, then reboots). I have tried re-running the fix to no avail.

    After some experimenting, I found out how to get into recovery mode:

    1. During reboot loop, as soon as apple pops up, hold down the power and home buttons.

    2. The screen should soon turn white. Keeping holding buttons.

    3. Once the screen displays nothing, release ONLY the power button.

    4. Keep holding the home button until the recovery logo shows up.

    After going into recovery mode, I tried running blackrain from windows. Geohot would come on the screen for a second, but then disappear and the reboot loop would continue.

    Before I ever ran the fix, my iPod would shut off 7 seconds after powering on. I only vaguely remember how this originally happened so I might be wrong, but I believe what caused this was:

    1. I tried to update in rock. The iPhone firmware package (or whatever it was called) failed to install, and I'm pretty sure no other packages were installed other than a rock update (if they were, it might have been 1 or 2).

    2. I tried updating through cydia. A couple dependencies were installed, but the iPhone firmware package again failed.

    3. I shut off my iPod. When I turned it back on, it would shut off after 7 seconds.

    Thank you iBeej for your work! It's nice to see your fix had some affect. I know you will be able to solve this!
    2010-05-19 02:08 AM
  6. KublaKahn's Avatar
    I'm almost certain that the iPhone has 3.1.2 and that's definitely what I have been using when applying thre b33jSn0w fixes.

    There seem to be quite a few people who have posted in this thread with the same 7 sec reboot problem. Could we really all have applied the wrong firmware?
    Well that's kinda comforting. I tried 3.1.2 when I couldn't get 3.1 to work, so I was afraid I may have messed things up for good. Still might have. I'll continue to hold out in hopes of a fix for the continuous reboot.
    2010-05-19 02:10 AM
  7. spooky655's Avatar
    One thing to note is that when I installed the updates in Rock I don't remember any of them failing (I did an update all around 5/6). So maybe I had more things installed than many other?? not sure.
    I had some successful installations and I am stuck in the reboot loop as well. My post on the last page details it. Could there be a connection?
    Last edited by spooky655; 2010-05-19 at 02:26 AM.
    2010-05-19 02:19 AM
  8. funkwerk's Avatar
    ITS ALIVE!!!!!

    Beej you are a legend!!

    Donation is on the way!!!!!!!!!

    I have been on this thread since day one, hit with rock update and left with apple logo for 7 secs then switch off (not a reboot loop)

    Tried everything so far without luck, even the Windows release still left me with 'fsck failed' (got that result from using beej's windows release with Fix my Phone and Verbose boot checked)

    I followed mr_kill_666 link to use Mac OS X with VMware on windows and after running b33jsn0w for Mac for the first time I am back to the day it crashed!! Still unlocked, last call made, etc.

    I have a 16gb 3gs 3.1.2 JB and unlocked via blackra1n and blacksn0w

    I ran a few checks first via windows USBview to make sure i confirmed my bootrom was iBoot-359.3 (older) rather than the newer iBoot-359.3.2.
    My serial number shows week 39 so thought it was best to check first!

    I managed to get the Mac OS and VMware running on a 2 year old HP AMD 64bit laptop running Vista which has seen better days!! OK it was running a bit slow but it worked, eventually!

    Will keep watching the thread in case i can help,

    Again, thanks goes out to all those involved to get this sorted!

    PS: Nice one ROCK, you ****'s!!
    2010-05-19 03:02 AM
  9. cotarelo's Avatar
    Happened to me that I disabled 2 items in the mobile substrate addon section in SBSettings. And then I had the problem. Never had Rock installed, just Cydia and phone has been working with no problems since October.

    When I start the phone I have the apple logo and after two minutes or more, phone reboots and again apple logo...

    Can this method work for me? If not... any other alternative than backup?

    I have access to it via iRecovery, but not SSH, or, at least I do not know how... I can open a shell via iRecovery but then I have no clue what to do...
    Last edited by cotarelo; 2010-05-19 at 03:48 AM.
    2010-05-19 03:28 AM
  10. z1mp's Avatar
    Need some help.

    I can get the phone into DFU mode.
    Using the windows fix following the instructions at roughly 24-25 seconds remaining on step 3 it goes to a new screen loads stage 1 then stage 2, making the connect noise and immediately followed by the disconnect noise, then it just sits at "waiting for reboot". I have tried to turn the phone on at this point and nothing happens just a blank screen remains. It doesn't go into a loop either still stuck at the shutdown after 7 seconds problem.

    What am i doing wrong?
    Last edited by z1mp; 2010-05-19 at 05:40 AM.
    2010-05-19 04:56 AM
  11. KublaKahn's Avatar

    Do you think it is possible to fix the continuous reboot issue?? I'm contemplating just biting it and restoring my phone.
    2010-05-19 05:21 AM
  12. bassix's Avatar

    I have the issue of the Apple logo on for 4 minutes, then a power down with no reboot cycle. I've tried all of your modded software versions on both my Mac and on 2 different Windows machines...and my phone is in the same non-booting state.

    Upon watching the "downloading JB data" screen several times (each time lasts about 8 minutes, then the phone just reboots and then powers off after 4 mins. of the Apple logo.), I'm wondering if the data payload is EVEN GETTING INTO the phone. I'm thinking that my phone is just timing out after 8 minutes, for I never see the pineapple, any verbose log, any fsck errors, etc. I just see the quick white screen flash and then the reboot for 4 mins, and then power down.

    What's most interesting to me is reading that most of the people with this shutdown problem DIDN'T have Rock installed, and didn't necessarily have the problem occur directly after a Cydia update.

    Can you give me any opinion or encouragement regarding this issue for after reading so many lucky people getting success from the fsck errors and reboot errors (switching from Windows to Macs...) , I'm thinking that this shutdown problem may something that is entirely different altogether and a restore may be the only option.

    2010-05-19 06:03 AM
  13. iBeej's Avatar
    Of course it's possible to fix reboot issue. I'm working on it as we speak as it's closely related to everything else. The success rate for mac version is through the roof and I'm sorry you guys had to go through the whole VM process to get there.

    What I'm doing with these patches is getting the right combination of binaries missing from your phones and hex patching in other components to get the boot through. In some cases certain users have a bigger problem and are missing or running a wrong binary. For those of you with no success you can attempt to re-run the patcher a few times to see if that helps. My theory on why this might work as some users have mentioned, is a possible dependency issue effecting the ramdisk binaries somehow. This should be impossible unless the ramdisk is failing to 'fsck' the disk0s2 partition, which is required for the launchd process to mount the partition RW. If it can't mount the partition RW then it will fail when it tries to write my patch to the RO filesystem, resulting in errors with 'fsck' references both in the ramdisk and during boot (because you're missing it). There is s possibility re-running the patcher with certain configurations may produce results a little bit at a time as the patcher is executed. Personally this perplexes me because the ramdisk is perfectly packaged with what it needs, but may not handle certain situations where the filesystem has "unrecoverable" inode corruption. Even if this were the case, with a properly packaged ramdisk you can still *recover*.

    So you see the problem with modifying an existing tool is your limitation within the constraint of the image size relative to the binary. To give you an idea of what we are up against during the jailbreak process:

    1.) Environment ring is saved.
    2.) USB exploit is executed
    3.) boot/kernel payload is uploaded
    4.) redsn0w utilizes the IPSW to overcome a buffer size requirement, while blackra1n uses the set_image embedded with decryptipn keys in an IMG3 to work around the issue of using an IPSW.
    5.) The payload is executed and kernel patched
    6.) Ramdisk uploaded and booted in to memory
    7.) launchd, from inside the ramdisk, handles neccessary mounting, fstab updates, and eventual package distribution directly to your real user partition.

    This is a very rough procedure I listed but you get the idea. We have a software package for windows or mac, a payload, a decryptipn routine and/or file, a ramdisk package, and a bundle (or patch) package to write to disk0s2. With so many packages, modifying them, especially extending their size in an existing binary with hex/disassembly sort of corners you in to a confined 0x00 padded corner until you don't have enough room to prevent page faults without adjusting section headers. Which just sucks.

    There is only so much you can do bytes at a time until you get to the point where writing your own program makes a lot more sense. Which is why I spent a lot of time on this recently.

    But I do both and bounce back and forth. Some existing jailbreaks like blackra1n by geohot, have very specific instructions to extract specific binaries from a patch bundle, thus making attempts of simply adding binaries to a compressed bundle futile without modifying launchd first, with additional or replaced code to extraxt OUR binaries instead. To sum it up, it's s lot of work with a lot of unknowns due to using an existing jailbreak package coupled with a multitude of different iPhone configurations.

    I say all of this so you can try to get an idea of the process involved, and despite what may seem like horrible odds, you can see just how feasible it really is to fix any problem with enough patience and troubleshooting, with exception to hardware failure or entirely unrecoverable filesystem (which doesn't happen unless you or SOMETHING TRIED to do it).

    So don't give up. Especially if you have a lot to lose. Which is probably very likely since you are here. Too many successes by so many people to even remotely feel it's impossible. It's quite simple really... We are missing something. Find that something and we are well on our way.

    I have made it my mission to recover your treasured pictures and data. And I won't stop until you stop.

    Last edited by iBeej; 2010-05-28 at 09:26 PM.
    2010-05-19 06:39 AM
  14. KublaKahn's Avatar
    Thanks, iBeej. I really appreciate your hard work on this.

    I will continue to hold out for the time being. My output looks very similar, if not identical to the assembly code that someone posted a page or two back. Let me know if there is any info I can gather to help out, but so far seems like there are plenty of people in the same boat, so I'm sure you are well aware.
    2010-05-19 07:56 AM
  15. czxxx's Avatar
    I too appreciate the effort! I don't have newborn pictures on my phone, but I did turn 30 recently and quite a bit of the fun was documented with my phone. Let me just say that you only turn 30 once. hehe

    Possibly minor detail regarding troubleshooting this... When using iRecovery, the only command that works is "exit". All others just bring up another command prompt. Would I be wrong to assume that's a bad thing and possibly related to the overall problems I/we're having..?
    2010-05-19 08:10 AM
  16. iBeej's Avatar
    Yeah I AM reading everything you guys are providing. Sorry I have sucked lately at answering questions directly. I haven't even seen my PMs yet because of the job situation and then trying to focus on updates to the patchers.

    I am actually working on the update to windows DDC and hope to include SC right now. I can repeat the problems a lot of you are describing by blowing out binaries on my phone as usual. So when I get this posted I will feel confident I nailed down another set of variables and with a much more robust windows fix. Man I really want something posted within the next few hours. So I'm really pushing hard to get this done.

    I'm really amazed how much my efforts and all of our work together on this has spread around the Internet. I'm trying to avoid reading it, like the reddit comments where I'm praised for the hard work or referred to as a criminal or a chump. > If I'm those things for coming up with whatever solution to help people recover lost memories due to a complete RockApp disaster, then I'm guilty as charged.

    I do what I do because i'm using my strengths to contribue something to society that people benefit from. Especially when so many have put their faith and trust in me. It's an honor and uplifting experience to be treated so kindly with words of encouragement, praise, and appreciation by all of you. If that makes these negative individuals jealous or whatever it is, then they need to get out there and do something, rather than slandering people with nothing but good intentions.

    /rant ?

    Last edited by iBeej; 2010-05-28 at 09:25 PM.
    2010-05-19 08:17 AM
  17. bassix's Avatar
    Thanks for the info, Beej! I'll try to keep on holding out till you come out with the right 'package" for my phone's problem.

    @czxxx....Most people with our problem aren't able to input the command lines in iRecovery, after the initial -s command that is.
    2010-05-19 08:22 AM
  18. KingCon's Avatar

    I don't see anyone else stepping up to do anything about this problem. So consider your self deserving of the praise.
    2010-05-19 08:29 AM
  19. czxxx's Avatar
    IANAL, but I don't believe anything you're doing could be considered illegal. Also, I couldn't fathom calling someone a chump that helps so many people while expecting nothing in return. Especially if you still make a few bucks even with expecting nothing in return! There'll always be assholes and trolls trying to ruin everything. F'em

    Thanks. I've been following this since the beginning of the first thread, and all of this one. I've read so many people's experiences that they're all a blur. I wasn't sure if my situation had been fully represented, despite the likelihood of it being in those 24568726394872985 posts.
    Last edited by czxxx; 2010-05-19 at 09:21 AM.
    2010-05-19 08:38 AM
  20. cotarelo's Avatar
    Thanks iBeej for your effort on fixing others problem (as yours is already fixed).

    I did not tried your method because the symptoms on my iPhone are different (reboot loop after 4 minutes, related to mobile substrate).

    My question. If I apply your method... do I risk something? Anyway I don't mind to wait if there is a solution for the other problem coming out.
    2010-05-19 11:16 AM
983 ... 14222324252634 ...