1. je11y's Avatar
    Hello All

    Ill try and explain everything as clearly as possible.
    Im in the UK

    I have an iphone 3G which is my brothers.
    Its on 3.1.2 / BaseBand : 05.11.07

    Originally my brother tried to jailbreak and unlock the iphone with Blackra1n on Windows.
    After doing so the iphone now no longer gets any signal on O2, or Vodafone, although the carrier name appears.
    On T-Mobile I get signal bars and the carrier name.

    On all networks, when i try to make an outgoing call, the iphone immedietly states "Call Ended".

    If i try to make a call to the iphone I get the message "Calls are not currently being connected to this number"

    Ive tried turning OFF/ON : 3G, call waiting / forwarding, Airplane mode, Data Roaming .
    Ive done a fresh installtion of 3.1.2 via itunes and tried jailbreaking with redsn0w, but the result is still the same.

    Im starting to think the Baseband is corrupt, but can only find instructions to manually do it for the Iphone 3GS.

    If anyone has any suggestions etc then please let me know



    If anyone
    2010-06-23 01:43 PM
  2. dantehman1's Avatar
    try jumping up to 3.1.3 and spiriting it?
    If I've helped you remember to say
    2010-06-23 01:56 PM
  3. je11y's Avatar
    Hi

    Thanks for the reply
    Although I would rather not upgrade to 3.1.3 unless its a last resort as I believe it is not possible to unlock via jailbreak etc.
    2010-06-23 02:07 PM
  4. David91's Avatar
    Was this problem ever fixed? im suffering from it aswell

    iPhone 3G 4.0.1
    Jailbreak - Redsn0w 0.9.5b5-5
    Unlock - Ultrasn0w 0.93

    Thanks.
    2010-07-18 11:11 PM
LINK TO POST COPIED TO CLIPBOARD