1. Toonshorty's Avatar
    I currently own an iPhone 3G with 4.0 on it.

    I haven't done any jailbreaking to it before so I don't have previous .shsh files.

    I believe I need to downgrade to 3.1.3 but I don't have a 3.1.3 shsh file.

    Can anyone link me to a step by step guide on getting from 4.0 legit to 4.0 sn0wbreeze?
    2010-06-24 10:58 AM
  2. Will01's Avatar
    If your on a 3G and not a 3G[S] you dont need shsh. Thats a 3G[S] thing. Simply download a 313 ipsw, install it, then use snowbreeze(is 1.6 out already?)/pwnage tool to go to jailbroken iOS4 goodness.
    2010-06-24 11:08 AM
  3. Toonshorty's Avatar
    I believe it is.

    I've got sn0wbreeze v1.6.1
    2010-06-24 11:15 AM
  4. Will01's Avatar
    Ah yes so it is, was realised while I was sleeping

    Still not sure if it works on my stock 313 3G[S] with old boot. But I got SHSH saved through AutoSHSH so i'll give it a go tonight, nothing to lose really.
    2010-06-24 11:24 AM
  5. Toonshorty's Avatar
    Right, I restored it and got 1015 error (good apparently) but now all I get is an itunes logo and a USB cable.

    If I connect it to my PC nothing happens.

    EDIT: Do I need to install 3.1.3 JB on iPhone or just standard 3.1.3?
    2010-06-24 11:26 AM
  6. Will01's Avatar
    Just standard 3.1.3 or 3.1.2 I believe.

    The iTunes logo indicates activation is required. Just pop in and official sim and connect to itunes. Voila.

    Then cook yourself a nice iOS4.0 JB firmware in Snowbreeze and RESTORE it using shift+click on restore button in itunes.

    Magic!
    2010-06-24 11:41 AM
  7. Toonshorty's Avatar
    I've got an official SIM in it.

    It's an O2 one.

    iTunes doesn't recognise the device.
    2010-06-24 11:45 AM
  8. Will01's Avatar
    Hmm, there is a way around that tho, i'm not sure where I seen it but there is a guide somewhere. Google that error code 1015?
    2010-06-24 11:47 AM
  9. Toonshorty's Avatar
    Error 1015: This error is caused by attempts to downgrade the iPhone, iPad, or iPod touch's software. This can occur when you attempt to restore using an older .ipsw file. Downgrading to a previous version is not supported. To resolve this issue, attempt to restore with the latest iPhone, iPad, or iPod touch software available from Apple.
    From apple's site.
    2010-06-24 12:04 PM
  10. Will01's Avatar
    Nah mate, no need, take a look through this topic and follow the instructions carefully:

    http://modmyi.com/forums/general/715...0-bricked.html
    2010-06-24 12:19 PM
LINK TO POST COPIED TO CLIPBOARD