1. ephdub's Avatar
    - Running 3.1.3 (7E18) official firmware.
    - Was previously jailbroken (until I updated the firmware to 3.1.3 due to the Cydia update problem).

    I can't remember what I jailbroke with but I know it was NOT spirit. I have my SHSH blobs cached on Cydia. I'm running bootrom 359.3.
    model MC143C
    modem firmware 05.12.01

    Can anyone tell me what steps I can (if I'm able to) to upgrade to 4.0 or should I wait for Geohot's pwned4life? Is there any even distinct advantage to wait for Geohot's jailbreak vs what the dev team has made? I do have both mac and pc computers to work with.

    Any help is greatly appreciated.
    Last edited by ephdub; 2010-06-25 at 08:20 AM. Reason: to add more info
    2010-06-25 08:09 AM
  2. j3st3r's Avatar
    If you have your 3.1.2 shsh blobs then restore to that and jailbreak with redsn0w, once jailbroken use the mac and create a custom 4.0 with pwnagetool and option+restore to that in iTunes, you will be jailbroken and ready to go
    2010-06-25 08:27 AM
  3. ephdub's Avatar
    Thanks. I don't know if I was on 3.1.2 or earlier. I'll try though. Is there anyway to determine what firmware version of shsh blobs I have on back up or is it solely 3.1.2?
    2010-06-25 08:35 AM
  4. j3st3r's Avatar
    Download tinyumbrella and try to have it get your 3.1.2 shsh's, if cydia has them it will get them for you, if it does just restore to 3.1.2, jailbreak with either redsn0w or blackra1n and then follow the steps above
    2010-06-25 08:55 AM
  5. ephdub's Avatar
    Will try. Thanks for your help so far!

    I got my iphone 3.1.2 shsh blobs from cydia via tinyumbrella and tried running the tss server. I tried to downgrade via itunes and got an error code 3002. Any ideas? I got this on both my windows/mac machines...
    ------
    update 1:
    I was able to downgrade my iphone to 3.1.2 (using my windows 7 machine) by editing my hosts file and pointing it to Saurik's servers. Itunes allowed me to downgrade... then before it completed, Itunes spat out a 1015 code... and from my search, it was due to have a newer modem firmware that firmware 3.1.2 was used to. I then proceeded to use the information from bondkt's post (http://modmyi.com/forums/3g-s-downgr...-tutorial.html). From there I was able to boot my iphone to 3.1.2... and I'm now currently building my custom ios4 with pwnage 4.01!

    update 2:
    I jailbroke 3.1.2 via blackra1n. Used my custom ipsw that I built... no problems so far...

    update 3:
    everything works so far
    Last edited by ephdub; 2010-06-25 at 06:24 PM. Reason: update
    2010-06-25 10:43 AM
LINK TO POST COPIED TO CLIPBOARD